Anaconda Installer does not recognice the EFI Partition

Installer Issues via Installer -- Not for global upgrades or upgrading individual packages -- ONLY ISSUES WITH INSTALLATION OF THE OS -- Can't get Sabayon installed, than post here, otherwise use correct forums

Moderator: Moderators

Anaconda Installer does not recognice the EFI Partition

Postby Referner » Mon Sep 16, 2013 0:13

Anaconda installer does not recognice EFI partition on my notebook

There are 2 images attached

Image

Image
Referner
Baby Hen
 
Posts: 10
Joined: Tue Sep 19, 2006 14:48
Location: Burgos, Spain

Re: Anaconda Installer does not recognice the EFI Partition

Postby J Scho » Sun Dec 22, 2013 5:43

I'll second this issue. I have the same problem using the 14.01 version even though I saw posted what looked like Matthew Garrett had it fixed in 13.08. Does anyone have a solution update?
J Scho
Baby Hen
 
Posts: 1
Joined: Sun Dec 22, 2013 5:28

Re: Anaconda Installer does not recognice the EFI Partition

Postby TheCube42 » Sun Jan 05, 2014 4:17

Same issue here. And I'm running Ubuntu 13.10 just fine, with my EFI partition mounted at /boot/efi without any trouble. Looking at the partition with the GNOME Disks utility, I can confirm the partition type is correct, and the table is GPT. (On both 13.08 and 14.01, I might add.)

I'm running on a ThinkPad L440. I really want to make Sabayon work (after having Manjaro fail to boot on this thing for some weird reason after trying everything); but this one small error (which seems to be from Anaconda, I think?) is preventing me from installing it.
TheCube42
Baby Hen
 
Posts: 6
Joined: Sun May 06, 2012 3:30

Re: Anaconda Installer does not recognice the EFI Partition

Postby lxnay » Mon Jan 06, 2014 15:19

Can you paste the output of:
Code: Select all
fdisk -l /dev/sda


I'm curious to see if the partition type is set correctly.
Then, I'd like to know if your partition is formatted as FAT32 or FAT16/12.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Anaconda Installer does not recognice the EFI Partition

Postby lxnay » Mon Jan 06, 2014 15:24

It looks like that your EFI Boot Partition doesn't have the correct partition type, which MUST BE EF00. You can check this by using:

Code: Select all
gdisk -l /dev/sda


Make sure to post the output of this command as well.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Anaconda Installer does not recognice the EFI Partition

Postby TheCube42 » Mon Jan 06, 2014 15:56

Code: Select all
GPT fdisk (gdisk) version 0.8.7

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 976773168 sectors, 465.8 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 85C160B1-32FC-47EC-8EDB-965076BE9ECE
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 976773134
Partitions will be aligned on 2048-sector boundaries
Total free space is 2029 sectors (1014.5 KiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048         2050047   1000.0 MiB  2700 
   2         2050048         2582527   260.0 MiB   EF00  EFI system partition
   3         2582528         2844671   128.0 MiB   0C01  Microsoft reserved part
   4         2844672       539508735   255.9 GiB   0700  Basic data partition
   5       539508736       540225535   350.0 MiB   2700 
   6       540225536       940058623   190.7 GiB   8300 
   7       940058624       949825535   4.7 GiB     8200 
   8       949825536       976773119   12.8 GiB    2700


I am assuming you were thinking of "EF00," not "00EF"? Both the Arch Wiki article on UEFI and Gentoo Wiki article on EFI stub kernel say it's EF00.
TheCube42
Baby Hen
 
Posts: 6
Joined: Sun May 06, 2012 3:30

Re: Anaconda Installer does not recognice the EFI Partition

Postby lxnay » Mon Jan 06, 2014 16:40

Ok, that is the partition type, what's the filesystem type? FAT32 or what? And what were you trying to do with the installer? Please explain thoroughly, since you didn't provide many details on the first post.
And perhaps post the screenshots and error messages in English, I don't know Spanish.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Anaconda Installer does not recognice the EFI Partition

Postby TheCube42 » Mon Jan 06, 2014 17:09

fdisk doesn't seem to support GPT, so here's the output from parted:

Code: Select all
Model: ATA HGST HTS725050A7 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  1050MB  1049MB  ntfs                                          hidden, diag
 2      1050MB  1322MB  273MB   fat32           EFI system partition          boot, hidden
 3      1322MB  1456MB  134MB                   Microsoft reserved partition  msftres
 4      1456MB  276GB   275GB   ntfs            Basic data partition          msftdata
 5      276GB   277GB   367MB   ntfs                                          hidden, diag
 6      277GB   481GB   205GB   ext4
 7      481GB   486GB   5001MB  linux-swap(v1)
 8      486GB   500GB   13.8GB  ntfs                                          hidden, diag


And the error message in English:

Image

(Which wound indicate, by the way, that the Spanish message is fundamentally wrong. As far as I know, that would roughly translate to "Boot partitions can only be on a vfat filesystem.")
TheCube42
Baby Hen
 
Posts: 6
Joined: Sun May 06, 2012 3:30

Re: Anaconda Installer does not recognice the EFI Partition

Postby lxnay » Mon Jan 06, 2014 17:21

Can you file a bug? I think I can fix that.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Anaconda Installer does not recognice the EFI Partition

Postby lxnay » Mon Jan 06, 2014 17:34

TheCube42 wrote:Image


Why did you hide the partition layout in this case?
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Next

Return to Installer Issues - Calamares **Not for Package Manager Stuff**

Who is online

Users browsing this forum: No registered users and 2 guests