How to set my keyboard right?

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

How to set my keyboard right?

Postby nomko » Thu Jan 02, 2014 2:37

I'm not quite sure if my keyboard is set right. Everything seems to work fine but 1 key in particular not and that's the key with this symbol: '

Under Mint i could type words like thing's, I'm, that's without hitting the space bar when i entered the ' symbol. Under Sabayon i must hit the space bar every time when i want to type words with ' in it. Why is that and how do i set my keyboard right so i don't need to hit the space bar every time i have to use the ' symbol?

Image of the key
Last edited by nomko on Thu Jan 16, 2014 10:43, edited 1 time in total.
ASUS P5KPL-AM SE*Intel Core2 Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*Optiarc DVD-RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Sitecom X5-N600 Router
nomko
Young Hen
 
Posts: 37
Joined: Fri Dec 27, 2013 21:57
Location: The Netherlands

Re: How to set my keyboard right?

Postby imaginasys » Thu Jan 02, 2014 4:43

What is your graphic interface ? gnome, kde, xfce, ... There is different tools for different window managers..,

In KDE you select "system settings->Input devices" then on the "keyboard object" select the "Disposition" tab and at the bottom of the window there is a place to choose the correct keyboard disposition. If yours is not there , just click on the "+" icon and select your keyboard. If I choose "netherland" for country I see there is 5 variants of keyboard " default, Danish (sun type 6/7), netherland (macIntosh), netherland (standard), netherland (dead keys sun); So be sure to select the correct one for you. I can't help much for gnome since I doesn't use it.

PS: be sure that you are using the ' keys and not the ` keys wich is a dead key (in french).
Menus may not be named exactly as I named them since I'm using a french system and translate in english.
imaginasys
Simple Hen
 
Posts: 51
Joined: Sat Nov 23, 2013 6:59

Re: How to set my keyboard right?

Postby nomko » Thu Jan 02, 2014 9:24

imaginasys wrote:What is your graphic interface ? gnome, kde, xfce, ... There is different tools for different window managers


I installed Xfce and after getting all the updates i installed Cinnamon since i like this DE the most of all DE's available right now.


During installation i Choose the Dutch language and as keyboard lay-out US-international.
ASUS P5KPL-AM SE*Intel Core2 Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*Optiarc DVD-RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Sitecom X5-N600 Router
nomko
Young Hen
 
Posts: 37
Joined: Fri Dec 27, 2013 21:57
Location: The Netherlands

Re: How to set my keyboard right?

Postby imaginasys » Thu Jan 02, 2014 17:02

You should have an icon on your taskbar showing the keyboard you have. If you're using an american keyboard you should see a USA flag. Just right click on that icon and select correct keyboard or add first if it is not there.

You say you use an US-international keyboard. Does your keyboard look like the "US-style keyboard" on the following link

http://matadornetwork.com/abroad/the-ultimate-guide-to-computer-keyboards-around-the-world/

??

If yes, then your ' keys should be on the 3rd row from the bottom at the right just beside the "return" key.

If you type you ' key and follow with the "e" key does it show "é" or "è" ? If yes, then it's a dead key for an accent in french, spanish, or other language. Can you confirm that if you use this key, you have to press space to obtain the ' key ?

If you don't see a flag in you taskbar, then you have to go in your settings to add it. I don't have any XFCE on hand, so I'm a little bit in the dark! May be someone else from this list has XFCE and will be willing to help ?

Regards,
Bernard
imaginasys
Simple Hen
 
Posts: 51
Joined: Sat Nov 23, 2013 6:59

Re: How to set my keyboard right?

Postby imaginasys » Fri Jan 03, 2014 7:08

Hi,

I have installed an xubuntu in a kvm machine to see what's going on xfce with your "us-intnl-keyboard".

I have not installed dutch language since I don't speak it. I supposed your issue is only related to the keyboard you selected.

I have added the keyboard tool in the top panel. You have to select "xfce->Parameters->Panel" and add the keyboard layout tool in your panel. Then you can click on the icon of the tool (it show a country flag) and add whatever keyboard layout you need.

So once I have done that and added the "usa-intnl-keyboard" and activated it. I could then try the same keyboard that you have.

I have tried the ' key and the " key, and in both case I confirm I had to press the space to have it on my screen.
But good new, I have found that if you press the "alt" key with the ' key then it appears on the screen pronto.
Same for "alt" key with "shift" key and the " key (wich is located on the same key as the ' key).

I'm not sure if I'm clear enough. But simply put you only have to add the "alt" key with your ' or " key to type it directly.

So your issue is rather one of "keyboard layout" nothing is defective with your keyboard.

I hope it helps,
Regards,
Bernard
imaginasys
Simple Hen
 
Posts: 51
Joined: Sat Nov 23, 2013 6:59

Re: How to set my keyboard right?

Postby Fitzcarraldo » Fri Jan 03, 2014 7:36

I don't use Cinnamon, but I do use Xfce, and it's not difficult to set up your keyboard layout. See, for example, Selecting different keyboard layouts in Xfce. I have configured my SL Xfce installations for a British English keyboard (gb), a Brazilian Portuguese keyboard (br) and a Spanish keyboard (es). If you want to toggle between a US English keyboard (us) and a Dutch keyboard (nl) then use the applicable Layout code as indicated in brackets. In fact, if you use XkbLayout, you don't need to do it via the DE at all; it's up to you.

Code: Select all
man xkeyboard-config


See also The XKB Configuration Guide.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: How to set my keyboard right?

Postby nomko » Fri Jan 03, 2014 19:44

I have this keyboard..

This post doesn't make any sense, the link provided shows really strange keyboards for The Netherlands (we do use qwerty but the layout doesn't match the standard layout we have).

I've checked my xorg.con file and this is what i have as "InputDevice":
Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "keyboard"
EndSection



According to this site i have to add the following lines to a xorg.conf file to match my keyboard:

Section "InputClass"
Identifier "keyboard defaults"
MatchIsKeyboard "on"

Option "XkbModel" "trust_slimline"
Option "XkbLayout" "euro"
Option "XKbOptions" "eurosign:5"
EndSection

According the that link is has to be put in a files called: /etc/X11/xorg.conf.d. But i don't have that file, can i add the Section " InputClass" in the existing xorg.conf file??

Thanks!
ASUS P5KPL-AM SE*Intel Core2 Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*Optiarc DVD-RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Sitecom X5-N600 Router
nomko
Young Hen
 
Posts: 37
Joined: Fri Dec 27, 2013 21:57
Location: The Netherlands

Re: How to set my keyboard right?

Postby Fitzcarraldo » Fri Jan 03, 2014 23:43

The second link in your post points to your own same post (at least that's what happens in the browser on my PC).

If you don't have the directory /etc/X11/xorg.conf.d/ then create it. And create the file /etc/X11/xorg.conf.d/00-keyboard.conf as explained in the first link in my previous post. Just reduce the line Option "XkbLayout" "gb,br,es" to Option "XkbLayout" "us,nl" as I explained. Then reboot and use Alt-Shift to toggle between the two layouts as explained in my link. If that at least has an effect, then you can worry about finding the precise layout code for your keyboard.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: How to set my keyboard right?

Postby Fitzcarraldo » Fri Jan 03, 2014 23:59

Before trying the above, try the following first (and reboot):

Code: Select all
equo remove --nodeps --ask ibus

(For details see kde aplications without accents [Solved] and Dead keys not working in several applications [Solved]).
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: How to set my keyboard right?

Postby nomko » Sat Jan 04, 2014 0:24

Fitzcarraldo wrote:The second link in your post points to your own same post (at least that's what happens in the browser on my PC).

If you don't have the directory /etc/X11/xorg.conf.d/ then create it. And create the file /etc/X11/xorg.conf.d/00-keyboard.conf as explained in the first link in my previous post. Just reduce the line Option "XkbLayout" "gb,br,es" to Option "XkbLayout" "us,nl" as I explained. Then reboot and use Alt-Shift to toggle between the two layouts as explained in my link. If that at least has an effect, then you can worry about finding the precise layout code for your keyboard.


Sorry, no effect at all...

This is what i have in my /etc/locale.gen file:
en_US.UTF-8 UTF-8
en_US ISO-8859-1
nl_NL.UTF-8 UTF-8
nl_NL ISO-8859-1
[email protected] ISO-8859-15


My /etc/env.d/02locale file shows:
LANG="nl_NL.UTF-8"
SYSFONT="LatArCyrHeb-16"
ASUS P5KPL-AM SE*Intel Core2 Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*Optiarc DVD-RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Sitecom X5-N600 Router
nomko
Young Hen
 
Posts: 37
Joined: Fri Dec 27, 2013 21:57
Location: The Netherlands

Next

Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests