nvidia driver??

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

nvidia driver??

Postby nomko » Mon Dec 30, 2013 2:00

Hi everybody,

How can i tell which NVIDIA driver i have installed and if it supports 3D? As you can see in my signature i have the Geforce 9500GT card. Under Mint i had to install the proprietary driver to get my card fully supported.

Any help would be very much appreciated!
ASUS P5KPL-AM SE*Intel Core2 Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*Optiarc DVD-RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Sitecom X5-N600 Router
nomko
Young Hen
 
Posts: 37
Joined: Fri Dec 27, 2013 21:57
Location: The Netherlands

Re: nvidia driver??

Postby Provia » Mon Dec 30, 2013 11:20

Hi nomko.
In Sabayon is easy to configure your nvidia card.
First you have to check if opengl rendering is set on the proprietary driver with
Code: Select all
sudo eselect opengl list

Look where the asterisk is. It should be next to the nvidia entry.
If it's not then install the correct drivers for your kernel via Rigo or via terminal(better way)
Code: Select all
sudo equo install nvidia-drivers

Then autoconfigure the X server for your driver
Code: Select all
sudo nvidia-xconfig

And then switch opengl to nvidia
Code: Select all
sudo eselect opengl set nvidia
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo
Provia
Advanced Hen
 
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: nvidia driver??

Postby nomko » Tue Dec 31, 2013 0:08

Whats the difference between this command:
Code: Select all
sudo emerge nvidia-drivers

and this command:
Code: Select all
sudo equo install nvidia-drivers


The first command i found on the sabayon wiki.
ASUS P5KPL-AM SE*Intel Core2 Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*Optiarc DVD-RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Sitecom X5-N600 Router
nomko
Young Hen
 
Posts: 37
Joined: Fri Dec 27, 2013 21:57
Location: The Netherlands

Re: nvidia driver??

Postby Provia » Tue Dec 31, 2013 11:20

In Sabayon you have two ways to install packages:
-From portage with the emerge command -> This is the gentoo way; you compile programs from source
-From entropy with the equo command -> This is the sabayon way; you install precopiled packages

Generally for a new user is not recommended to use portage, use just entropy. Portage is usefull just if you want to compile a package with specific parameters(called flags) for optimizing performance.
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo
Provia
Advanced Hen
 
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: nvidia driver??

Postby nomko » Tue Dec 31, 2013 12:18

Provia wrote:In Sabayon you have two ways to install packages:
-From portage with the emerge command -> This is the gentoo way; you compile programs from source
-From entropy with the equo command -> This is the sabayon way; you install precopiled packages

Generally for a new user is not recommended to use portage, use just entropy. Portage is usefull just if you want to compile a package with specific parameters(called flags) for optimizing performance.



Okay. Thanks for the explaination!
ASUS P5KPL-AM SE*Intel Core2 Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*Optiarc DVD-RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Sitecom X5-N600 Router
nomko
Young Hen
 
Posts: 37
Joined: Fri Dec 27, 2013 21:57
Location: The Netherlands

Re: nvidia driver??

Postby devendetes » Sat Oct 11, 2014 19:11

I did the same thing but startx doesn't launch the x-session anymore
I' m running Sabayon 64bit
I have an Nvidia Geforce 820m
This is what I can read in /var/log/Xorg.0.log

[ 34.950]
X.Org X Server 1.14.7
Release Date: 2014-06-05
[ 34.950] X Protocol Version 11, Revision 0
[ 34.950] Build Operating System: Linux 3.14.0-sabayon x86_64 Gentoo
[ 34.950] Current Operating System: Linux sabayon 3.16.0-sabayon #1 SMP Mon Sep 22 02:50:15 UTC 2014 x86_64
[ 34.950] Kernel command line: BOOT_IMAGE=/boot/kernel-genkernel-x86_64-3.16.0-sabayon root=UUID=2905a9ba-2954-45d8-8753-876a6236e1ce ro
[ 34.950] Build Date: 14 July 2014 04:16:49PM
[ 34.950]
[ 34.950] Current version of pixman: 0.32.4
[ 34.950] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 34.950] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 34.951] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Oct 11 21:47:50 2014
[ 34.987] (==) Using config file: "/etc/X11/xorg.conf"
[ 34.987] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 35.033] (==) ServerLayout "Layout0"
[ 35.033] (**) |-->Screen "Screen0" (0)
[ 35.033] (**) | |-->Monitor "Monitor0"
[ 35.033] (**) | |-->Device "Device0"
[ 35.033] (**) |-->Input Device "Keyboard0"
[ 35.033] (**) |-->Input Device "Mouse0"
[ 35.033] (==) Automatically adding devices
[ 35.033] (==) Automatically enabling devices
[ 35.033] (==) Automatically adding GPU devices
[ 35.072] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[ 35.072] Entry deleted from font path.
[ 35.072] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 35.072] Entry deleted from font path.
[ 35.072] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 35.072] Entry deleted from font path.
[ 35.072] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[ 35.072] Entry deleted from font path.
[ 35.072] (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[ 35.075] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[ 35.075] Entry deleted from font path.
[ 35.075] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[ 35.075] (==) FontPath set to:
/usr/share/fonts/misc/
[ 35.075] (==) ModulePath set to "/usr/lib64/xorg/modules"
[ 35.075] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 35.075] (WW) Disabling Keyboard0
[ 35.075] (WW) Disabling Mouse0
[ 35.075] (II) Loader magic: 0x7febe0
[ 35.075] (II) Module ABI versions:
[ 35.075] X.Org ANSI C Emulation: 0.4
[ 35.075] X.Org Video Driver: 14.1
[ 35.075] X.Org XInput driver : 19.1
[ 35.075] X.Org Server Extension : 7.0
[ 35.075] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 35.075] (II) xfree86: Adding drm device (/dev/dri/card1)
[ 35.076] (--) PCI:*(0:0:2:0) 8086:0a16:103c:2212 rev 11, Mem @ 0xb5000000/4194304, 0xc0000000/268435456, I/O @ 0x00007000/64
[ 35.076] (--) PCI: (0:9:0:0) 10de:1140:103c:2212 rev 161, Mem @ 0xb3000000/16777216, 0xa0000000/268435456, 0xb0000000/33554432, I/O @ 0x00004000/128
[ 35.080] Initializing built-in extension Generic Event Extension
[ 35.080] Initializing built-in extension SHAPE
[ 35.080] Initializing built-in extension MIT-SHM
[ 35.080] Initializing built-in extension XInputExtension
[ 35.080] Initializing built-in extension XTEST
[ 35.080] Initializing built-in extension BIG-REQUESTS
[ 35.080] Initializing built-in extension SYNC
[ 35.080] Initializing built-in extension XKEYBOARD
[ 35.080] Initializing built-in extension XC-MISC
[ 35.080] Initializing built-in extension XINERAMA
[ 35.080] Initializing built-in extension XFIXES
[ 35.080] Initializing built-in extension RENDER
[ 35.080] Initializing built-in extension RANDR
[ 35.080] Initializing built-in extension COMPOSITE
[ 35.080] Initializing built-in extension DAMAGE
[ 35.080] Initializing built-in extension MIT-SCREEN-SAVER
[ 35.081] Initializing built-in extension DOUBLE-BUFFER
[ 35.081] Initializing built-in extension RECORD
[ 35.082] Initializing built-in extension DPMS
[ 35.083] Initializing built-in extension X-Resource
[ 35.084] Initializing built-in extension XVideo
[ 35.085] Initializing built-in extension XVideo-MotionCompensation
[ 35.086] Initializing built-in extension XFree86-VidModeExtension
[ 35.087] Initializing built-in extension XFree86-DGA
[ 35.088] Initializing built-in extension XFree86-DRI
[ 35.089] Initializing built-in extension DRI2
[ 35.089] (II) "glx" will be loaded by default.
[ 35.089] (II) LoadModule: "dri2"
[ 35.089] (II) Module "dri2" already built-in
[ 35.089] (II) LoadModule: "glamoregl"
[ 35.192] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
[ 36.221] (EE) Failed to load /usr/lib64/xorg/modules/libglamoregl.so: /usr/lib64/xorg/modules/libglamoregl.so: undefined symbol: _glapi_tls_Context
[ 36.221] (II) UnloadModule: "glamoregl"
[ 36.221] (II) Unloading glamoregl
[ 36.221] (EE) Failed to load module "glamoregl" (loader failed, 7)
[ 36.221] (II) LoadModule: "glx"
[ 36.221] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 36.628] (II) Module glx: vendor="NVIDIA Corporation"
[ 36.628] compiled for 4.0.2, module version = 1.0.0
[ 36.628] Module class: X.Org Server Extension
[ 36.636] (II) NVIDIA GLX Module 340.32 Tue Aug 5 20:32:43 PDT 2014
[ 36.646] Loading extension GLX
[ 36.646] (II) LoadModule: "nvidia"
[ 36.646] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[ 36.754] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 36.754] compiled for 4.0.2, module version = 1.0.0
[ 36.754] Module class: X.Org Video Driver
[ 36.766] (II) NVIDIA dlloader X Driver 340.32 Tue Aug 5 20:13:04 PDT 2014
[ 36.766] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 36.769] (++) using VT number 1

[ 36.769] (EE) No devices detected.
[ 36.769] (EE)
Fatal server error:
[ 36.769] (EE) no screens found(EE)
[ 36.769] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 36.769] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 36.769] (EE)




Now I cannot start an x-session anymore. I would like to have an x-session with the nvidia proprietary driver working.
What should I do?
Any help would be appreciated.
Intel Core i3-4005U CPU @ 1.70GHz (quad core)
4 GB DDR3 1600 Mhz
Nvidia Geforce 820M
Sabayon Linux x64 Openbox
devendetes
Baby Hen
 
Posts: 1
Joined: Sat Oct 11, 2014 0:35


Return to Hardware

Who is online

Users browsing this forum: No registered users and 4 guests