How do I enable virtual terminals? [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

How do I enable virtual terminals? [Solved]

Postby gh2k » Sat Dec 21, 2013 19:17

I just downloaded and installed 14.01 amd64 KDE last night on my 2009 Macbook. Very fast and cool release.

I noticed that whenever I use Ctrl-Alt-Fx (for x=1 to 6, plus on the Macbook I also have to hold down the Fn key), it takes me to what would be a virtual terminal but there is just a blank screen with no login prompt. Pressing return or any other single key does not change the blank (and completely black) screen. I am able to get back to KDE by doing Ctrl-Alt-F7. So the virtual terminals seem to be there but the tty process does not seem to allow me to login. I'm new to systemctl, but I do see

[email protected] loaded active running Getty on tty1

as well as

mypc etc # ps -ef|grep tty
root 3969 1 0 12:50 tty1 00:00:00 /sbin/agetty --noclear tty1 38400 linux

Yet, still no login prompt. How can I fix this?
Last edited by gh2k on Thu Jan 30, 2014 4:43, edited 1 time in total.
gh2k
Baby Hen
 
Posts: 2
Joined: Sat Dec 21, 2013 19:06

Re: How do I enable virtual terminals?

Postby gh2k » Sat Dec 21, 2013 23:27

I had wanted to make sure VTs were available because I was having video problems with the KDE taskbar getting garbled. I wanted to switch from the proprietary nvidia driver to the open source nouveau driver. The two latest released nvidia drivers both seemed to suffer from garbled taskbar on 14.01 KDE as well as some black screens in Google Chrome like when I went to youtube.com.

So late this afternoon when I got home, I tried switching over to nouveau even though I was worried I would not get back to a virtual terminal if nouveau did not work. I switched to nouveau by blacklisting nvidia in /etc/modprobe.d/blacklist.conf, commenting out the blacklist nouveau (i.e. unblacklisting nouveau) in the same file, doing eselect opengl set 3 (where 3 on my system is xorg-x11), and changing Driver "nvidia" to Driver "nouveau" in /etc/X11/xorg.conf. Then I rebooted.

Now everything seems to work well. No more garbled taskbar, no more black youtube.com page, and now my virtual terminals show up. Super!
gh2k
Baby Hen
 
Posts: 2
Joined: Sat Dec 21, 2013 19:06

Re: How do I enable virtual terminals?

Postby batvink » Sun Dec 22, 2013 10:33

Ah, that's great to hear, and see that one comes itself with a solution after some searching.

Oh, and that Fn thingy...
If you find that a problem (i do), you can solve that by followinf this guide from our Wiki:
https://wiki.sabayon.org/index.php?title=HOWTO:_Make_The_Function_Keys_Work_On_An_Apple_Keyboard

Also, please mark your post as [Solved]
You can read why and how here:
https://forum.sabayon.org/viewtopic.php?f=86&t=17059#p97600
User avatar
batvink
Old Dear Hen
 
Posts: 495
Joined: Sun Oct 28, 2007 11:44
Location: the netherlands


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 0 guests