KDE 4.11.3: Bluetooth adapter not found

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

KDE 4.11.3: Bluetooth adapter not found

Postby linuxfluesterer » Fri Nov 22, 2013 15:37

Hallo guys.
I've just upgraded my system to Sabayon 13.12, 64bit, and KDE 4.11.3. Before my bluetooth ran fine.
I am running my system with Kernel 3.12 now. But my problem appears as same as when I'm running Kernel 3.11.8.
The thing is, that my bluetooth adapter is no more found yet, neither in:
Code: Select all
hcitool scan
Device is not available: No such device

nor in KDE itself, when starting the bluetooth adapters module:
Code: Select all
kcmshell4 bluedeviladapters

But my bluetooth device is found and shown with hwinfo:
Code: Select all
hwinfo --bluetooth
03: USB 00.0: 11500 Bluetooth Device                           
  [Created at usb.122]
  Unique ID: 7dS8.+XjOheJX3H7
  Parent ID: KRJj.4Nx_qoDfSd7
  SysFS ID: /devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1.1/3-1.1:1.0
  SysFS BusID: 3-1.1:1.0
  Hardware Class: bluetooth
  Model: "Foxconn / Hon Hai Bluetooth Device"
  Hotplug: USB
  Vendor: usb 0x0489 "Foxconn / Hon Hai"
  Device: usb 0xe04e
  Revision: "0.02"
  Driver: "btusb"
  Driver Modules: "btusb"
  Speed: 12 Mbps
  Module Alias: "usb:v0489pE04Ed0002dcE0dsc01dp01icE0isc01ip01in00"
  Driver Info #0:
    Driver Status: ath3k is active
    Driver Activation Cmd: "modprobe ath3k"
  Driver Info #1:
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #2 (Hub)

systemd services are running:
Code: Select all
systemctl --show|grep blue
sys-devi...ooth-hci0.device loaded active plugged   /sys/devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1.1/3-1.1:1.0/bluetooth/hci0
sys-subs...ices-hci0.device loaded active plugged   /sys/subsystem/bluetooth/devices/hci0
bluetooth.service           loaded active running   Bluetooth service
bluetooth.target            loaded active active    Bluetooth

There is another interesting topic, which I miss, what was necessary to start bluetooth in versions before. There is no more 'bluetoothd'. Where is it gone? What is the substitute comand to catch the adapter?
Code: Select all
bluetoothd
command not found

Also /etc/init.d/bluetoothd doesn't exist. I can only guess, which is the source of the problem. Personally I would assume KDE 4.11.3, but due to hwinfo fails, there must be a command like 'bluetoothd', which is NOT part of KDE.
Anyone here experiencing the same?
Any idea? Thank you in advance.

-Linuxfluesterer (I love KDE ...)
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 704
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: KDE 4.11.3: Bluetooth adapter not found

Postby linuxfluesterer » Fri Nov 22, 2013 18:46

Update... When I do a 'bluetoothctl' command (as root) then I receive this:
Code: Select all
bluetoothctl
[NEW] Controller 68:94:23:70:1D:42 SSD1-K311-KDE411-0 [default]
[bluetooth]# list
Controller 68:94:23:70:1D:42 SSD1-K311-KDE411-0 [default]
[bluetooth]# power on
[CHG] Controller 68:94:23:70:1D:42 Class: 0x00010c
Changing power on succeeded
[CHG] Controller 68:94:23:70:1D:42 Powered: yes
[bluetooth]# scan on
Discovery started
[CHG] Controller 68:94:23:70:1D:42 Discovering: yes
[NEW] Device 00:01:E3:B6:53:DE S68H
[NEW] Device F0:08:F1:F7:D8:92 Wave II
[NEW] Device 00:1E:10:87:73:E2 Mama Handy .M
[bluetooth]#

It seems, my bluetooth is working (because it detects other devices like 'Mama Handy') but the problem is in KDE.
So, what can I do to activate in and for KDE 4.11.3?

-Linuxfluesterer (I love KDE ...)
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 704
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: KDE 4.11.3: Bluetooth adapter not found

Postby picard12 » Sun Nov 24, 2013 9:13

I have the same issue
picard12
Growing Hen
 
Posts: 114
Joined: Thu Jan 27, 2011 5:26

Re: KDE 4.11.3: Bluetooth adapter not found

Postby specialworld83 » Sun Nov 24, 2013 9:37

THE problem is libbluedevil bluedevil and, unfortunately, the actual packages only work with bluez 4 sabayon while since the last update gnome 3.10 bluez 5 has brought with it not doing more work bluetooth on kde.

installed packages:
libbluedevil 1.9.4
bluedevil 1.9.4

These packages do not work while the following

libbluedevil 2.0
bluedevil 2.0
work perfectly.

Expect Erculani update packages indicted.
Image
Image
specialworld83
Simple Hen
 
Posts: 97
Joined: Sat Nov 10, 2007 11:16

Re: KDE 4.11.3: Bluetooth adapter not found

Postby linuxfluesterer » Sun Nov 24, 2013 14:07

Thank you, Specialworld...
I was considering to restore my old Sabayon version with KDE 4.11.2 on my disk before I've read your post.
But then I've seen I still have an older Sabayon KDE version, which I can use in a VirtualBox machine.
So now, my host is still KDE 4.11.3 with the 'broken' bluedevil and libbluedevil, but I can use bluetooth via VirtualBox.
That is acceptable for me for the moment. I will wait for updates from Fabio (lxnay) to fix that issue.
Until then, this thread is not solved for me.

-Linuxfluesterer (I love KDE ...)
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 704
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: KDE 4.11.3: Bluetooth adapter not found

Postby specialworld83 » Sun Nov 24, 2013 14:56

linuxfluesterer wrote:Thank you, Specialworld...
I was considering to restore my old Sabayon version with KDE 4.11.2 on my disk before I've read your post.
But then I've seen I still have an older Sabayon KDE version, which I can use in a VirtualBox machine.
So now, my host is still KDE 4.11.3 with the 'broken' bluedevil and libbluedevil, but I can use bluetooth via VirtualBox.
That is acceptable for me for the moment. I will wait for updates from Fabio (lxnay) to fix that issue.
Until then, this thread is not solved for me.

-Linuxfluesterer (I love KDE ...)


I have the same problem, in fact I found the bug by accident because it affects all distros, there is also a similar post on the forum of opensuse.
Image
Image
specialworld83
Simple Hen
 
Posts: 97
Joined: Sat Nov 10, 2007 11:16

Postby patkoscsaba » Wed Nov 27, 2013 23:45

I just want to join the crowd. My keyboard and mouse are useless... Luckily I have this old kb at hand. Waiting for update.
patkoscsaba
Baby Hen
 
Posts: 4
Joined: Fri Jan 20, 2012 14:07
Location: Romania

Re: KDE 4.11.3: Bluetooth adapter not found

Postby eor2004 » Thu Nov 28, 2013 6:33

I have an usb bluetooth dongle, it is recognized if I do the "lsusb" command, however when I try to run "blueman" or "bluedevil" the applications do not open or start! :( So waiting too for the update!
Sabayon Linux MATE 64-bit
Gigabyte G41M-ES2L-->2gb ram
Intel Pentium Dual Core 2.60ghz-->E5300
WD-6400AAKS-Caviar-SE16-640gb-->XFS filesystem
User avatar
eor2004
Simple Hen
 
Posts: 85
Joined: Thu Jul 12, 2012 15:46
Location: Puerto Rico

Re: KDE 4.11.3: Bluetooth adapter not found

Postby lxnay » Thu Nov 28, 2013 10:15

I am pushing bluedevil and libbluedevil 2.0_pre1 to stable repositories.
I wonder if there is something to fix in the Xfce land as well...
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: KDE 4.11.3: Bluetooth adapter not found

Postby specialworld83 » Sun Dec 01, 2013 11:52

lxnay wrote:I am pushing bluedevil and libbluedevil 2.0_pre1 to stable repositories.
I wonder if there is something to fix in the Xfce land as well...


The transfer of files is not allowed, also not abiità sharing it from gnome to kde it.

No resolv bug
Image
Image
specialworld83
Simple Hen
 
Posts: 97
Joined: Sat Nov 10, 2007 11:16

Next

Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests