System freezes after configuring xorg

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Re: System freezes after configuring xorg

Postby Euro3000 » Fri Nov 08, 2013 19:20

No, it is not that I am concerned with performance, actualy I can't even say that my laptop is somehow slow... it is just this thing with a 1024x768 res only; insted of the 1280x800.
Ok, should I try now the Equo way?
Euro3000
Young Hen
 
Posts: 21
Joined: Sat Nov 02, 2013 10:48

Re: System freezes after configuring xorg

Postby Euro3000 » Fri Nov 15, 2013 9:22

I went throu the Equo way and this went out:

>> ## Package checksum matches: x11-drivers:nvidia-userspace-304.108.4b95a3083b130ca5d84c170ca2823b53aceace5b~0.tbz2
>> : GPG matches
>> : SHA1 matches
>> : SHA256 disabled
>> : SHA512 disabled
>> ## Package checksum matches: x11-drivers:nvidia-drivers-304.108#3.10.0-sabayon.a0a3231f09f4cdccb07092eb8d3880d34d9933a3~0.tbz2
>> : GPG matches
>> : SHA1 matches
>> : SHA256 disabled
>> : SHA512 disabled
>> +++ >>> (1/2) x11-drivers/nvidia-userspace-304.108
>> ## Unpacking: x11-drivers:nvidia-userspace-304.108.4b95a3083b130ca5d84c170ca2823b53aceace5b~0.tbz2
>> ## Package phase: setup
* Checking for suitable kernel configuration options... [ ok ]
* Checking for suitable kernel configuration options... [ ok ]
>> ## Package phase: preinstall
>> ## Installing package: x11-drivers/nvidia-userspace-304.108
>> ## [NVIDIA X11 userspace libraries and applications]
>> ## Updating database: x11-drivers/nvidia-userspace-304.108
>> ## Cleaning previously installed application data.
>>> Regenerating /etc/ld.so.cache...
>> ## Package phase: postinstall
Switching to xorg-x11 OpenGL interface... done
Switching to nvidia OpenCL interface... done
* You must be in the video group to use the NVIDIA device
* For more info, read the docs at
* http://www.gentoo.org/doc/en/nvidia-gui ... hap3_sect6
*
* To use the NVIDIA GLX, run "eselect opengl set nvidia"
*
* To use the NVIDIA CUDA/OpenCL, run "eselect opencl set nvidia"
*
* NVIDIA has requested that any bug reports submitted have the
* output of /opt/bin/nvidia-bug-report.sh included.
*
>> ## Cleaning: x11-drivers/nvidia-userspace-304.108
>> +++ >>> (2/2) x11-drivers/nvidia-drivers-304.108#3.10.0-sabayon
>> ## Unpacking: x11-drivers:nvidia-drivers-304.108#3.10.0-sabayon.a0a3231f09f4cdccb07092eb8d3880d34d9933a3~0.tbz2
>> ## Package phase: setup
>> ## Package phase: preinstall
>> ## Installing package: x11-drivers/nvidia-drivers-304.108#3.10.0-sabayon
>> ## [NVIDIA GPUs kernel drivers]
>> ## Updating database: x11-drivers/nvidia-drivers-304.108#3.10.0-sabayon
>> ## Cleaning previously installed application data.
>> ## Package phase: postinstall
* Updating module dependencies for 3.10.0-sabayon ... [ ok ]
* Adding module to moduledb.

* You must be in the video group to use the NVIDIA device
* For more info, read the docs at
* http://www.gentoo.org/doc/en/nvidia-gui ... hap3_sect6
*
* This package installs a kernel module and X driver. Both must
* match explicitly in their version. This means, if you restart
* X, you must modprobe -r nvidia before starting it back up
*
>> ## Cleaning: x11-drivers/nvidia-drivers-304.108#3.10.0-sabayon
>> @@ Installation complete.
>> @@ No configuration files to update.


$ eselect opengl list
Available OpenGL implementations:
[1] nvidia *
[2] xorg-x11
[3] ati

# eselect opengl set nvidia
Switching to nvidia OpenGL interface... done

But the screen resolution remained only 1024 x 768.
Now Rigo is reporting that I have 2 new updates:

1.) Nvidia Drivers 319.60#3.10.0-sabayon~1
NVIDIA GPUs kernel drivers
October 21, 2013, from sabayon-weekly
304.108#3.10.0-sabayon is installed

2.) Nvidia Userspace 319.60~0
NVIDIA X11 userspace libraries and applications
October 21, 2013, from sabayon-weekly
304.108 is installed

Shoul I update them ?
Euro3000
Young Hen
 
Posts: 21
Joined: Sat Nov 02, 2013 10:48

Re: System freezes after configuring xorg

Postby Euro3000 » Fri Nov 22, 2013 19:11

Here are my news:
I did not want to update to Nvidia Drivers 319.60 (as listed up here, etc.) allthought the Rigo insited (allways & allways), I allways ignored it.
BUT, when came out the notice for 32 new Sabayon's updates (or something) I didn't realise that the nvidia drivers 319.60 were included.
After that, at the restart or when I booted to Sabayon, my laptop needed to login about 3 minutes longer and the cooling fan allways remained on at max power!; and it was at max power all the time - even without running any app, only just booted into the desktop!
Not to mention that the sreen resolution was possible only 1024x786.
So, now I switched back to xorg-x11 and the cooling fan is on only 2-3sec / minute as it allways was.
For now it seems to me no chances to get my 1280x800 resolution with Sabayon.
(I had the 1280x800 by default with Ubuntu 32 & 64, Fedora64, Manjaro64 and Slax32 tested recently - both live and installed on disk)
Any suggestions, please?
Euro3000
Young Hen
 
Posts: 21
Joined: Sat Nov 02, 2013 10:48

Re: System freezes after configuring xorg

Postby Cb7 » Sun Nov 24, 2013 12:42

You can also try installing older drivers, that is nvidia-drivers-173.14.38, so it would be:
Code: Select all
equo i -a nvidia-drivers-173.14.38#$(uname -r) nvidia-userspace-173.14.38


From Rigo behaviour I guess that you should mask drivers if they will work:
Code: Select all
equo mask -a nvidia-drivers nvidia-userspace

You always can check available drivers by:
Code: Select all
equo s -qv nvidia-drivers
Why, and how to add "[Solved]" to your post. Please read. ← credits to Fitzcarraldo

Kind regards
~Zetok Zalbavar
Cb7
Growing Hen
 
Posts: 104
Joined: Sun Apr 07, 2013 7:13

Re: System freezes after configuring xorg

Postby Provia » Tue Nov 26, 2013 11:46

Hi guys,
form my experience i thnk that the problem is that you have not run
Code: Select all
sudo nvidia-xconfig

before the switch made by eselect
try these steps
-reinstall the drivers for your kernel
-run
Code: Select all
sudo nvidia-xconfig

-an then
Code: Select all
sudo eselect opengl set nvidia


Let me know if this is useful for you!
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo
Provia
Advanced Hen
 
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: System freezes after configuring xorg

Postby Euro3000 » Thu Nov 28, 2013 21:44

I am happy to reply you that now my screen resolution is finaly set on 1280x800. Thanks all of you and "Mille volte grazie!" to you Provia. After I wrote commands you've suggested I logged off and relogged in it automatictly switched to 1280x800.
Thanks agayin.
Euro3000
Young Hen
 
Posts: 21
Joined: Sat Nov 02, 2013 10:48

Re: System freezes after configuring xorg [Solved]

Postby Provia » Fri Nov 29, 2013 14:27

I'm happy to read that! I had the same problem some times ago. It happens when the driver is not updated properly.
Don't be afraid to ask for some help again!

PS: i recommend you, if you haven't done yet, to install nvidia-settings for configuring the screen resolution and other things related to the video card.
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo
Provia
Advanced Hen
 
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: System freezes after configuring xorg

Postby Euro3000 » Thu Feb 13, 2014 19:34

Hello everybody!
For admins: I hope it is all right if I continue solving my nvidia problems here. If not, just instruct me and I will post as it will be suggested.

Yestarday after my last automatic update/upgrade it seemed all is woorking fine and no problems were reported. But today after starting my comp the sistem stopped soon after the blue Sabayon logo appeared and this was seen on screen:

This is xxxx.unknown_domain (linux x86_64 3.12.0 sabayon)
xxxx.login: nvidia disagrees about version of symbol module_layout
systemd[1]: Unit lightdm.service entered failed state.
systemd[1]: Unit lightdm.service start request repeted to quickly, refuseing to start.
... entered failed state

after a while the login appears in basic terminal mode only.
So now I can't login into my grafic desktop enviroment.
I have no idea what I have to do now?
Euro3000
Young Hen
 
Posts: 21
Joined: Sat Nov 02, 2013 10:48

Re: System freezes after configuring xorg

Postby Stupot » Thu Feb 13, 2014 20:18

This indicates you have compiled the module against a different version of the kernel than is running, which is odd since you didn't say you've performed any updates since your last reboot.

Just to be sure, though, what version of nvidia-drivers are currently installed (can be found out via equo) and what's the output of "uname -r" ? I'm guessing uname -r will show 3.12.0 and that the nvidia-drivers are going to be different. If so, simply installing the correct nvidia drivers should get you where you wanna be.
Stupot
Sagely Hen
 
Posts: 1513
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: System freezes after configuring xorg

Postby Euro3000 » Thu Feb 13, 2014 21:34

Thanks for your reply Stupot!
This went out:

# uname -r
3.12.0-sabayon

# equo search -qv nvidia-drivers#$(uname -r)
x11-drivers/nvidia-drivers-173.14.39#3.12.0-sabayon
x11-drivers/nvidia-drivers-304.119#3.12.0-sabayon
x11-drivers/nvidia-drivers-331.38#3.12.0-sabayon

??
Euro3000
Young Hen
 
Posts: 21
Joined: Sat Nov 02, 2013 10:48

PreviousNext

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 2 guests

cron