Xsane stopped working...[Solved]

Discussions Regarding Software

Moderator: Moderators

Xsane stopped working...[Solved]

Postby greendave8 » Mon Nov 04, 2013 23:49

Hi All,

Since the recent weekend update, Xsane has stopped working. Here is the output. Does anyone know what it means?
Code: Select all
[email protected] ~ $ xsane
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
xsane: strlst.c:426: avahi_string_list_get_pair: Assertion `l' failed.
[email protected] ~ $

Any ideas on how to fix this small but annoying issue.

Many thanks in advance
gd8 :oops:
Growing Hen
Posts: 152
Joined: Thu Aug 02, 2007 12:23

Re: Xsane stopped working...[Solved]

Postby greendave8 » Thu Nov 07, 2013 0:05

OK, here is what I did to solve the "missing" scanner....

Removed the sane folder, and re-installed Xsane, using Rigo. This made the scanner function usable with the HP software, but still would not allow Sane to use the scanner.... Then a message from HP came up, saying new software was available, hplip 3.13.11... so after upgrading that, everything is back to normal.... I believe the problem to be with hplip 3.13.10....

Xsane and skanlite both work, as well as the HPlip software....

Thanks for looking

gd8 :D :D :D
Growing Hen
Posts: 152
Joined: Thu Aug 02, 2007 12:23

Re: Xsane stopped working...[Solved]

Postby r00t.ati » Sat Nov 30, 2013 13:54

Hello, i still have the same problem.
What sane folder have you erased? (I tried with ~/.sane/ and /etc/sane.d/, then i re-intalled sane-frontend, sane-backend and xsane)

I also installed hplip-3.13.11 (from emerge) but the situations dont change.

Code: Select all
[email protected] ~ $ equo search hplip && emerge -pv hplip
>>  @@ Cercando...
>>      @@ Pacchetto: net-print/hplip-3.13.10 branch: 5, [sabayonlinux.org]
>>         Disponibile:   versione: 3.13.10 ~ tag: NoTag ~ revisione: 0
>>         Installato:    versione: Non installato ~ tag: N/A ~ revisione: N/A
>>         Slot:          0
>>         Homepage:      http://hplipopensource.com/hplip-web/index.html
>>         Descrizione:   HP Linux Imaging and Printing.
>>                        Includes printer, scanner, fax
>>                        drivers and service tools.
>>         Licenza:       GPL-2
>>  Keyword:  hplip
>>  Trovati:  1 voce

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] net-print/hplip-3.13.11  USE="X fax hpcups hpijs libnotify parport policykit qt4 scanner snmp static-ppds -doc -kde -libusb0 -minimal" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Code: Select all
[email protected] ~ $ xsane
xsane: strlst.c:426: avahi_string_list_get_pair: asserzione "l" non riuscita.
Baby Hen
Posts: 18
Joined: Tue Mar 29, 2011 16:48

Re: Xsane stopped working...[Solved]

Postby Archdevil » Sat Dec 21, 2013 14:26

I have the same problem. How is this going to be repaired? I believe it has got something to do with HPLIP. This problem has been around for weeks now, without much complaints. Doesn't anyone use HP to scan?

Please help, as I need to use my scanner and I want to keep using Sabayon!
Baby Hen
Posts: 6
Joined: Sun Oct 20, 2013 16:37

Re: Xsane stopped working...[Solved]

Postby svantoviit » Sun Dec 22, 2013 9:30

I now it doesn't help, but all works fine for me with net-print/hplip-3.13.10 and media-gfx/xsane-0.999.
Maybe you'll find something useful here: Arch Linux Forums » Update broke sane.
Old Dear Hen
Posts: 716
Joined: Sun Feb 28, 2010 17:55

Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest