Help. Blinking cursor on reboot after updates

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
Baby Hen
Posts: 6
Joined: Sun Oct 27, 2013 8:37

Help. Blinking cursor on reboot after updates

Post by schick » Sun Oct 27, 2013 9:03

I installed Sabayon (new user) after determining I needed nomodeset (or was it acpi off, maybe both).

My system is a HP2000 laptop. Kinfocenter shows that I have a Radeon HD 6310 (under the OPENGL list.

Looked great. I I then installed the updates via Rigo.

After rebooting I find that I can't get past a black screen with a flashing cursor in the upper left. While attempting to adjust boot parameters at the boot screen, I noted that while I am supposedly able to use emacs style editing (no experience), the entries seem to already contain acpi=off and nomodeset. i was under the impression from looking online that these entries might fix the issue. It appears that these entries are actually not present in /etc/default/grub

i was forced to reinstall, but am afraid to update the system as it will likely screw up again.

I am tempted to add acpi=off or nomodeset or acpi_osi=Linux (or all of them) to /etc/default/grub, but realize that I am inexperienced and could make things worse.

Please help.

As well, If I fail to make the needed changes after an update, is there method I can use to gain access the linux partition, and make changes/

Please forgive my awkwardly written appeal, it is 2 Am and my brain hurts. :oops:

User avatar
Old Dear Hen
Posts: 873
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Help. Blinking cursor on reboot after updates

Post by linuxfluesterer » Sun Oct 27, 2013 9:28

I have read, when this blinking cursor in the beginning appears, it should be due to a bug in the Kernel.
The solution should be to
Press the 'Fn' key + Arrow (Cursor) Right key
I must confess, I didn't have this problem, so I've never tried this.
Hope, you'll have luck anyway.

-Linuxfluesterer (I love KDE ...)
Take away Facebook from me and let there be real people again...

User avatar
Sagely Hen
Posts: 1887
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Help. Blinking cursor on reboot after updates

Post by albfneto » Sun Oct 27, 2013 17:43

[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE

User avatar
Sagely Hen
Posts: 8159
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Help. Blinking cursor on reboot after updates

Post by Fitzcarraldo » Mon Oct 28, 2013 17:28

Just in case it is of help, I noticed that the LiveDVDs of the latest few releases of SL (including the Daily releases) have resulted in a blinking cursor or multi-coloured 'snow storm' on my laptop with an ATI Mobility Radeon HD 5650. To get around that I delete the deprecated "vga=791" from the kernel boot line and replace it with xdriver=radeon to stop the LiveDVD loading the closed-source FGLRX driver and force it to use the open-source Radeon driver instead.

So you might try creating a LiveDVD or LiveUSB from the latest Daily ISO release, boot it to see if you get the same effect as you do now, and then try switching to the open-source Radeon driver to see if that fixes it. If it does, you can then try Ctrl-Alt-F1 on your installation to switch to a TTY (or chroot from a LiveDVD or LiveUSB if you can't get to a TTY with Ctrl-Alt-F<n>), uninstall the FGLRX driver and install the open-source Radeon driver. I have not done the latter in SL for ages, but it would be something like the following:

Code: Select all

equo remove ati-drivers ati-userspace amdcccle
equo install xf86-video-ati
eselect opengl set xorg-x11
equo deptest
equo libtest
equo conf update

Technological Hen
Posts: 305
Joined: Sat Nov 17, 2007 15:37

Re: Help. Blinking cursor on reboot after updates

Post by anomaly65 » Thu Oct 31, 2013 20:47

also, another easy way when booting from livedvd, select options and input "nomodeset" on the boot line. Seems to work. I'll update the longer directions when I try my next install to keep them accurate :D
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)

Post Reply