screen brightness issues with ati hd7430

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

screen brightness issues with ati hd7430

Postby sedo_5 » Wed Oct 02, 2013 16:49

Hi all!

I have a netbook Sony Vaio sve-1111, with E2-1800 apu and Ati hd7430 vga.
Until some time ago, Sabayon was running smoothly (kernel 3.4.x); now after some time, I decided to reinstall everything from scratches.
I have installed the iso of sabayon 13.10 (kde, amd64) from your website. Everything ok. The only problem was with the Ati driver.
The free xorg driver gave me high temperatures, so I decided to install the Ati driver following these steps: https://wiki.sabayon.org/index.php?title=HOWTO:_Get_AMD/ATI_or_Nvidia_Video_Cards_working_in_Sabayon

Everything went ok and now the temperatures are lower and opengl seems to work fine. The only problem I have is with the brightness controls on my keyboard (fn+f5/f6). I also gave a look at these discussions on the forum:
https://forum.sabayon.org/viewtopic.php?f=56&t=28808&start=30&hilit=step+by+step+ati
https://forum.sabayon.org/viewtopic.php?f=56&t=30759

I have no idea of how to solve this problem.
Can you please give me some hints?

PS: currently i'm using kernel 3.11.1-sabayon and ati-driver 13.9#3.11

Thanks
Renzo
sedo_5
Growing Hen
 
Posts: 133
Joined: Sun Dec 05, 2010 19:20

Re: screen brightness issues with ati hd7430

Postby sedo_5 » Sun Oct 06, 2013 18:41

Hi.

No hints from you guys?
I just updated to the last version from sabayon-weekly, but no change at all. As usual, everything seems to work just fine, except the brightness control.
I hope someone could give me some suggestions on what to try...

Thanks

Renzo
sedo_5
Growing Hen
 
Posts: 133
Joined: Sun Dec 05, 2010 19:20

Re: screen brightness issues with ati hd7430

Postby sedo_5 » Wed Oct 23, 2013 18:24

Just an update, in case someone wanted to give me some help!

I tried some tricks but to no avail:

- adding "acpi_osi=Linux acpi_backlight=vendor" to the line GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub and updating grub after it;
- also tried to change "acpi_backlight=vendor" with the value "kernel" or "legacy"
- also tried to change "acpi_osi=Linux" with the value "!Windows 2012"

I tried all the possible combinations of these and didn't work.

Moreover, I tried playing around with the files in /sys/class/backlight/acpi_video0 , namely echoing a value to the file "brightness", but nothing happens.

I'm officially stuck with no solutions! :(
sedo_5
Growing Hen
 
Posts: 133
Joined: Sun Dec 05, 2010 19:20

Re: screen brightness issues with ati hd7430

Postby Fitzcarraldo » Wed Oct 23, 2013 19:52

Have a look in the sub-directories in /sys to see if you can find any files relating to backlight brightness. Depending on the laptop, these could be anything from /sys/class/backlight/intel_backlight/brightness to /sys/devices/platform/sony-laptop/kbd_backlight/brightness to /sys/class/backlight/sony/brightness and so on. If you can find the appropriate file in the kernel file system, you can then echo different values into it in order to vary the brightness. And that could be automated with a Bash script and bound to key shortcuts.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7997
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest