Если программы нет в репозитории? Где брать?

Общие переговоры относительно Sabayon Linux

Moderators: sidsoft, Moderators

Re: Если программы нет в репозитории? Где брать?

Postby Fox909 » Tue Oct 08, 2013 20:33

что-то со мной не так. Вроде протсо всё... А уменя проблема. Установил gcc и cmake вроде бы интересней получается но не работает... Псомотрите пожалуйста. Я ничего не удалял. Что было на диске для установки то и поставил. Ну разве что у меня не мини. Вот что теперь выдаёт;;
Code: Select all
sabayon ~ # emerge xfce4-whiskermenu-plugin

 * IMPORTANT: 8 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

!!! The following installed packages are masked:
- www-plugins/adobe-flash-11.2.202.310::gentoo (masked by: AdobeFlash-11.x license(s))
A copy of the 'AdobeFlash-11.x' license is located at '/usr/portage/licenses/AdobeFlash-11.x'.

- net-wireless/broadcom-sta-6.30.223.30-r1::sabayon (masked by: Broadcom license(s))
A copy of the 'Broadcom' license is located at '/usr/portage/licenses/Broadcom'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


>>> Verifying ebuild manifests

>>> Emerging (1 of 1) xfce-extra/xfce4-whiskermenu-plugin-1.1.1
 * xfce4-whiskermenu-plugin-1.1.1-src.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...         [ ok ]
>>> Unpacking source...
>>> Unpacking xfce4-whiskermenu-plugin-1.1.1-src.tar.bz2 to /var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/work
>>> Source unpacked in /var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/work
>>> Preparing source in /var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/work/xfce4-whiskermenu-plugin-1.1.1 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/work/xfce4-whiskermenu-plugin-1.1.1 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/work/xfce4-whiskermenu-plugin-1.1.1_build"
cmake --no-warn-unused-cli -C /var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/work/xfce4-whiskermenu-plugin-1.1.1_build/gentoo_common_config.cmake -G Unix Makefiles -DCMAKE_INSTALL_PREFIX=/usr -DENABLE_WERROR=OFF -DENABLE_AS_NEEDED=OFF -DCMAKE_BUILD_TYPE=Gentoo -DCMAKE_INSTALL_DO_STRIP=OFF -DCMAKE_USER_MAKE_RULES_OVERRIDE=/var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/work/xfce4-whiskermenu-plugin-1.1.1_build/gentoo_rules.cmake  /var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/work/xfce4-whiskermenu-plugin-1.1.1
Not searching for unused variables given on the command line.
loading initial cache file /var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/work/xfce4-whiskermenu-plugin-1.1.1_build/gentoo_common_config.cmake
-- The C compiler identification is unknown
-- The CXX compiler identification is unknown
CMake Error at /usr/share/cmake/Modules/CMakeCXXInformation.cmake:37 (get_filename_component):
  get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
  CMakeLists.txt:6 (project)


CMake Error: your C compiler: "" was not found.   Please set CMAKE_C_COMPILER to a valid compiler path or name.
CMake Error: your CXX compiler: "" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
-- Found Freetype: /usr/lib/libfreetype.so (found version "2.4.11")
-- Found GTK2_GTK: /usr/lib/libgtk-x11-2.0.so 
-- Found PkgConfig: /usr/bin/x86_64-pc-linux-gnu-pkg-config (found version "0.28")
-- checking for module 'exo-1'
--   found exo-1, version 0.10.2
-- checking for module 'garcon-1'
--   found garcon-1, version 0.2.1
-- checking for module 'libxfce4panel-1.0>=4.8'
--   found libxfce4panel-1.0, version 4.10.1
-- checking for module 'libxfce4ui-1>=4.8'
--   found libxfce4ui-1, version 4.10.0
-- checking for module 'libxfce4util-1.0>=4.8'
--   found libxfce4util-1.0, version 4.10.1
-- Found Gettext: /usr/bin/msgmerge (found version "0.18.2")
-- <<< Gentoo configuration >>>
Build type      Gentoo
Install path    /usr
Compiler flags:
C               -O2 -march=x86-64 -pipe
C++             -O2 -march=x86-64 -pipe
Linker flags:
Executable       -Wl,-O1 -Wl,--as-needed
Module           -Wl,-O1 -Wl,--as-needed
Shared           -Wl,-O1 -Wl,--as-needed

-- Configuring incomplete, errors occurred!
 * ERROR: xfce-extra/xfce4-whiskermenu-plugin-1.1.1 failed (configure phase):
 *   cmake failed
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 3163:  Called cmake-utils_src_configure
 *   environment, line  666:  Called _execute_optionaly 'src_configure'
 *   environment, line  268:  Called enable_cmake-utils_src_configure
 *   environment, line 1024:  Called die
 * The specific snippet of code:
 *       "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
 *
 * If you need support, post the output of `emerge --info '=xfce-extra/xfce4-whiskermenu-plugin-1.1.1'`,
 * the complete build log and the output of `emerge -pqv '=xfce-extra/xfce4-whiskermenu-plugin-1.1.1'`.
 * The complete build log is located at '/var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/temp/environment'.
 * Working directory: '/var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/work/xfce4-whiskermenu-plugin-1.1.1_build'
 * S: '/var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/work/xfce4-whiskermenu-plugin-1.1.1'

>>> Failed to emerge xfce-extra/xfce4-whiskermenu-plugin-1.1.1, Log file:

>>>  '/var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/temp/build.log'

 * Messages for package xfce-extra/xfce4-whiskermenu-plugin-1.1.1:

 * ERROR: xfce-extra/xfce4-whiskermenu-plugin-1.1.1 failed (configure phase):
 *   cmake failed
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 3163:  Called cmake-utils_src_configure
 *   environment, line  666:  Called _execute_optionaly 'src_configure'
 *   environment, line  268:  Called enable_cmake-utils_src_configure
 *   environment, line 1024:  Called die
 * The specific snippet of code:
 *       "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
 *
 * If you need support, post the output of `emerge --info '=xfce-extra/xfce4-whiskermenu-plugin-1.1.1'`,
 * the complete build log and the output of `emerge -pqv '=xfce-extra/xfce4-whiskermenu-plugin-1.1.1'`.
 * The complete build log is located at '/var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/temp/environment'.
 * Working directory: '/var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/work/xfce4-whiskermenu-plugin-1.1.1_build'
 * S: '/var/tmp/portage/xfce-extra/xfce4-whiskermenu-plugin-1.1.1/work/xfce4-whiskermenu-plugin-1.1.1'
sabayon ~ #

Уже вроде бы и про Вишкер пишет, и всё одно ошибка.
Justice exists, it is just not obvious!
User avatar
Fox909
Simple Hen
 
Posts: 57
Joined: Tue Jun 11, 2013 7:16

Re: Если программы нет в репозитории? Где брать?

Postby Fox909 » Wed Oct 09, 2013 5:32

По вашей инструкции, русификация прошла успешно :) Спасибо большое!
Justice exists, it is just not obvious!
User avatar
Fox909
Simple Hen
 
Posts: 57
Joined: Tue Jun 11, 2013 7:16

Previous

Return to Russian

Who is online

Users browsing this forum: No registered users and 0 guests

cron