libvirtd + systemd

Discussion for all VM - Installing, Software, Problems

Moderator: Moderators

Post Reply
Baby Hen
Posts: 1
Joined: Sat Sep 28, 2013 10:10

libvirtd + systemd

Post by TheWizardTower » Sat Sep 28, 2013 10:16

Hello, all.

I'm trying to get KVM up and running properly in Sabayon, but I'm running into a rather gnarly problem. I just installed my machine, so it has defaulted to using systemd as the boot service manager. However, the init.d script for libvirtd was written for OpenRC, and refuses to run without having that as the boot manager.


Code: Select all

# /etc/init.d/libvirtd status
 * You are attempting to run an openrc service on a
 * system which openrc did not boot.
 * You may be inside a chroot or you may have used
 * another initialization system to boot this system.
 * In this situation, you will get unpredictable results!
 * If you really want to do this, issue the following command:
 * touch /run/openrc/softlevel
True to form, if I run the suggested touch command, the output is appropriately nonsensical. Every command, whether it's start, stop, status, or restart fails.

Is there any plan to convert this script over to systemd anytime soon? Or should I just revert back to OpenRC and deal with it for now?



Growing Hen
Posts: 104
Joined: Sun Apr 07, 2013 7:13

Re: libvirtd + systemd

Post by Cb7 » Mon Nov 04, 2013 20:49

Seems to work for me:

Code: Select all

$ systemctl status libvirtd
libvirtd.service - Virtualization daemon
   Loaded: loaded (/usr/lib64/systemd/system/libvirtd.service; enabled)
   Active: active (running) since sob 2013-11-02 07:57:13 GMT; 2 days ago
I suggest reading

Code: Select all

man systemctl
Why, and how to add "[Solved]" to your post. Please read. ← credits to Fitzcarraldo

Kind regards
~Zetok Zalbavar

Post Reply