How to stop packages Downgrading?

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

How to stop packages Downgrading?

Postby No.2 » Wed Dec 13, 2006 2:26

I've emerge --sync layman -S and am trying to emerge -peND world but keep getting.

Code: Select all
!!! Problem resolving dependencies for dev-dotnet/gecko-sharp:0

!!! All ebuilds that could satisfy "www-client/mozilla" have been masked.
!!! One of the following masked packages is required to complete your request:
- www-client/mozilla-1.7.13 (masked by: package.mask)
# Need wxGTK 2.8 with GTK 2.10

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "dev-dotnet/gecko-sharp-0.6" [ebuild])

!!! Depgraph creation failed.

Now this is very strange as I have
dev-dotnet/gecko-sharp-0.11-r1 (Testing) installed which binds to firefox but it wants to take me back to
dev-dotnet/gecko-sharp-0.6 (Stable) which binds with the old mozilla www-client ??

I have "dev-dotnet/gecko-sharp ~x86" in my package.kewords file.

Why is it doing that?
Because the version number of the stable is higher than the testing build?
How do I fix this?

Now I'm getting;
Code: Select all
Calculating world dependencies  ..... ..... ..... ..... ..... ..... ..... ..... ..... ....Traceback (most recent call last):
  File "/usr/bin/emerge", line 4856, in ?
    retval = emerge_main()
  File "/usr/bin/emerge", line 4851, in emerge_main
    myopts, myaction, myfiles, spinner)
  File "/usr/bin/emerge", line 4179, in action_build
    if not mydepgraph.xcreate(myaction):
  File "/usr/bin/emerge", line 1831, in xcreate
    if not self.validate_blockers():
  File "/usr/bin/emerge", line 1542, in validate_blockers
    slot_atom = "%s:%s" % (portage.dep_getkey(mycpv),
  File "/usr/lib/portage/pym/", line 4461, in aux_get
    raise KeyError(mycpv)
KeyError: 'x11-plugins/beryl-plugins-0.1.3'

Any thoughts?
Young Hen
Posts: 26
Joined: Mon Oct 30, 2006 13:40

Postby Appleman1234 » Fri Dec 15, 2006 1:36

Try emerge syncng again.
11 is higher that 6 as far as I recall.

Why are you emerging world, it generally isn't necessary, just because you can update doesn't mean you should. (see wolfden on #Sabayon for a longer lecture) ?

Check the files in /etc/portage, you can a requirement not to install a version below as certain version number in there.
Old Dear Hen
Posts: 964
Joined: Mon Nov 27, 2006 9:48
Location: Land Down Under / Australia

Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest