Juniper Networks

Discussions Regarding Software

Moderator: Moderators

Post Reply
Young Hen
Posts: 33
Joined: Wed Apr 29, 2009 16:38

Juniper Networks

Post by Bunkmil » Tue Apr 09, 2013 15:03


I’m trying to connect to my job’s vpn server which works with Juniper Networks. When I was using Ubuntu, there was a script that took care of installing the program ( and the script can be found here: I tried this script with Sabayon but whenever I try to connect to the vpn, I have an error message saying that my configuration is incorrect.

I’m not a script expert, so I would really appreciate if someone could have a look at it and explain to me why it’s working with Ubuntu and not with Sabayon. I would really like to get rid of Ubuntu and I don’t want to quit my job because I don’t like their vpn server :wink:


Sagely Hen
Posts: 1708
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Juniper Networks

Post by Stupot » Tue Apr 09, 2013 16:26

I had attempted to do this for my job. I was also unsuccessful, although I'm sure it can be done.

I'm going to assume you are using a 64 bit install?

You'll need to install the 32 bit java libraries and figure out how to hijack when juniper is running and make it use the 32 bit libraries.

In the end, I wound up installing a CentOS VM, but there were other benefits for me having a CentOS install at home anyway.

Young Hen
Posts: 33
Joined: Wed Apr 29, 2009 16:38

Re: Juniper Networks

Post by Bunkmil » Tue Apr 09, 2013 17:09

I run Sabayon i686, so the problem of the 64 bits java libraries does not apply to my situation.

I'm also sure it can be done...

Growing Hen
Posts: 104
Joined: Sun Apr 07, 2013 7:13

Re: Juniper Networks

Post by Cb7 » Thu Apr 11, 2013 19:33

If you get something like "Your system does not have a /dev/net/tun device configured. (...)" it's because Sabayon `don't have` `device` called tun, which is (probably?) present in Ubuntu. That is what I deduced form this piece of script below, and fast check up in directory /dev

Code: Select all

# Check the host for configuration issues.
# It has been reported that Knoppix, for example, doesn't have a tun device
setup_host ()
    [ -c /dev/net/tun ] && return 0
    query "Your system does not have a /dev/net/tun device configured.
Should I create one?" \
        || exit 0

    ( $_sudo mknod /dev/net/tun c 10 200 && $_sudo chmod 666 /dev/net/tun) \
        >> "$_errlog" 2>&1 \
        || die "Failed to create /dev/net/tun!"
From my basic understanding of scripts and fast look up on this particular one, I guess that you have to write in console something like that (truly it's basically ripped of from script, with little adjustments):

Code: Select all

sudo mknod /dev/net/tun c 10 200 && sudo chmod 666 /dev/net/tun
or, if you prefer using root password instead of your administrative account:

Code: Select all

su -c "mknod /dev/net/tun c 10 200 && chmod 666 /dev/net/tun"
Though I firmly advise that someone more experienced than me looks at it and confirm that it's correct. Better do not do that if you're not sure that you can do this without breaking anything. After all doing what I proposed requires root privileges, and honestly, I'm just a little bit geeky kid bored enough to look through script with little knowledge about either script, or the topic.
Why, and how to add "[Solved]" to your post. Please read. ← credits to Fitzcarraldo

Kind regards
~Zetok Zalbavar

Post Reply