Windows not showing up in grub

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Windows not showing up in grub

Postby kage » Sat Apr 06, 2013 11:56

Hi,

Need some help please. I have Saba 11 KDE installed. I need to have Windows installed alongside it.
What did I do: Backed up Saba from my ssd with clonezilla. I learned that Grub2 should detect Windows by itself.

- Made room for windows on my harddisk
- Installed Windows 7
- Clonezilla restored Sabayon to my ssd
- Fired up my restored Sabayon
- No Win 7 entry in grub2
- told etc/fstab that there is a new partition (sdb2)
- Fired up Sabayon again
- Still no Win 7 entry in grub2
- ran grub2-mkconfig
- Fired up Sabayon again
- Still no Win 7 entry in grub2

What is wrong? What am I doing wrong?

Greetz kage
kage
Simple Hen
 
Posts: 77
Joined: Tue Feb 06, 2007 23:53

Re: Windows not showing up in grub

Postby dave_64 » Sat Apr 06, 2013 17:41

Is that the exact command you issued to run grub? I don't have much experience with this, but I think the correct command would be:
grub2-mkconfig -o /boot/grub/grub.cfg

That would be run from a root terminal, of course.
No guarantees...good luck.
dave_64
Advanced Hen
 
Posts: 225
Joined: Sun Feb 22, 2009 20:33

Re: Windows not showing up in grub

Postby Matte88 » Mon Apr 08, 2013 0:40

kage wrote:- Clonezilla restored Sabayon to my ssd
This scares me... Please, output here of
Code: Select all
# fdisk -l
Image
When I became the sun,
I shone life into the man's hearts.
Matte88
Technological Hen
 
Posts: 399
Joined: Wed Dec 29, 2010 14:37
Location: @/etc/entropy/repositories.conf.d/entropy_sabayon-limbo


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest

cron