nvidia 9629 stable

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

nvidia 9629 stable

Postby cvill64 » Wed Nov 08, 2006 17:05

Version: 1.0-9629
Operating System: Linux x86
Release Date: November 7, 2006

Release Highlights

* Added initial support for GLX_EXT_texture_from_pixmap.
* Added new "Display Configuration" page in nvidia-settings.
* Improved workstation OpenGL performance in Xinerama.
* Added support for NVIDIA Quadro Plex.
* Added support for Quad SLI.
* Improved X driver error recovery.
* Improved workstation overlay performance.
* Added SMBus functionality to the Linux/i2c interface.
* Fixed DFP scaling support.
* Added support for OpenGL 2.1.
* Added new "TwinViewXineramaInfoOrder" X configuration option to control the order of display devices when in TwinView.
* Fixed some problems related to TV Out.
* Added new NVIDIA logo artwork to nvidia-settings and X driver splashscreen; the X driver splashscreen can now be configured with the new "LogoPath" X configuration option.



QUAD SLI SUPPORTED ADDED

SabayonLinux 3.2 will support quad sli setups now :D
cvill64
Sagely Hen
 
Posts: 2185
Joined: Fri Dec 30, 2005 10:03
Location: Virginia, USA

Postby johnnyhay » Thu Nov 23, 2006 9:00

Yay for NVIDIA and Yay for SABAYON!
johnnyhay
Technological Hen
 
Posts: 304
Joined: Sun Oct 08, 2006 8:54
Location: Google's main DNS

Postby eduardhc » Fri Nov 24, 2006 14:14

Hi,
Be careful: 9629 release is buggy and makes OpenGL crash on GeForce4 cards (like my Ti4200...). And it's really annoying because that driver is intended to be last one compatible with GeForce4, as support for it is removed from 97xx on.

All GeForce4 users should use 9626, not 9629.

Cheers,
Eduard
eduardhc
Technological Hen
 
Posts: 372
Joined: Tue Sep 19, 2006 16:31
Location: Barcelona (Cat)

Postby lxnay » Fri Nov 24, 2006 16:44

where did you read this eduard?
Thanks!
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Postby eduardhc » Fri Nov 24, 2006 17:53

lxnay wrote:where did you read this eduard?
Thanks!


I found this will trying to install Ubuntu+Beryl on my machine. Even if I followed all the correct steps I wasn't able to set it up right. Beryl was still crashinh everytime I started it.

It was 'glxinfo' who gave me the clue, as this was also crashing with a segmentation fault error. Searching for it on Google lead me to some french and italian forums with people experiencing the same issues with 9629 and Ti4200 and Ti42800.

For instance, look here:
http://www.nvnews.net/vbulletin/showthr ... ?p=1059856

Or simply:
http://www.google.com/search?sourceid=n ... vidia+9629

What version will be included by default in 3.2? I've changing my card to a 6600, so this won't affect me any more, but I wanted just to let you know this problem.

Cheers,
Eduard
eduardhc
Technological Hen
 
Posts: 372
Joined: Tue Sep 19, 2006 16:31
Location: Barcelona (Cat)

Postby wolfden » Fri Nov 24, 2006 20:27

Well hopefully nvidia fixes this in a hurry cause 3.2 is 9629

the beta drivers of 9629 are fine or fall back to 8776 is being recommended for now
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Postby lxnay » Wed Nov 29, 2006 14:36

they are going to fix that by issuing a new <97xx driver. I talked with a NVIDIA dev about that.
Anyway, wolfden, is there any viable solution apart from reverting back to 9626, that seems to work?
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Postby wolfden » Wed Nov 29, 2006 23:09

not that I have seen :( , I see portage has a newer version hard masked testing.
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Postby analoguedarkness » Mon Dec 04, 2006 17:37

so here's the problem with reverting to 9626...it's been removed from portage, or so it appears, as when i change the package mask from 9629 to 9626, emerge immediately spits out 1.0.8776 as the package it will downgrade to. how can i manually build this so i can get around the annoying segfault problem with glx?
analoguedarkness
Baby Hen
 
Posts: 1
Joined: Mon Dec 04, 2006 17:34

Postby lxnay » Mon Dec 04, 2006 18:26

analoguedarkness,
Code: Select all
layman -s sabayon
emerge =x11-drivers/nvidia-drivers-1.0.9626-r99
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy


Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 0 guests