Want to request new package, unsure about term [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Want to request new package, unsure about term [Solved]

Postby ratcheer » Fri Jul 20, 2012 15:52

I want to submit a bug to request a new package in Sabayon. The first thing I encounter is, "Request a package to be added to entropy, if package is not in mainline portage or the sabayon overlay please submit a request there first",

The package I want is not in the main portage repos, but I am not sure what it means to check "the Sabayon overlay". Please help me to understand how to do this.

Tim
Last edited by ratcheer on Fri Jul 20, 2012 16:05, edited 2 times in total.
ratcheer
Growing Hen
 
Posts: 103
Joined: Wed Mar 14, 2012 16:41

Re: Want to request new package, unsure about terminology

Postby ratcheer » Fri Jul 20, 2012 16:04

Sorry, once again I found my answer myself. The solution seems to be to search the overlay using eix. I will work through this, but I had no idea until I searched "sabayon overlay" on Google.

Tim
ratcheer
Growing Hen
 
Posts: 103
Joined: Wed Mar 14, 2012 16:41

Re: Want to request new package, unsure about term [Solved]

Postby Fitzcarraldo » Fri Jul 20, 2012 17:29

If you don't want to use eix, which is a Portage utility (emerge --sync && layman -a sabayon && layman -a sabayon-distro && eix-update) you could instead look directly in the SL Git repositories for the two overlays online. See the link 'Git' at the top of this page? If you click on that you'll see two of the entries are 'overlays/for-gentoo.git' and 'overlays/sabayon.git'. The former is the repository for the sabayon Portage overlay and the latter is the repository of the sabayon-distro Portage overlay. If you click on those and then the 'tree' link you'll see a list of all the package categories, which you can look through to see what ebuilds (packages) there are in the overlay.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Want to request new package, unsure about term [Solved]

Postby ratcheer » Fri Jul 20, 2012 17:54

Thank you, fitzcarraldo. I will learn to use the git link.

One more question, please. I have verified that the package I want is not in the sabayon overlays. Since it is also not in the Gentoo repos, is that where I should start? I.e., do I file a Gentoo bug requesting that the package be added? Or, is that presumptuous?

The package I am interested in is GBonds, a US Savings Bonds database manager similar to the US Treasury's Savings Bond Wizard which, of course, is for Windows only. The Gbonds app is for Gnome, which I am running with Sabayon 9, and it can directly import my existing .sbw files from my old Windows PC.

Tim
ratcheer
Growing Hen
 
Posts: 103
Joined: Wed Mar 14, 2012 16:41

Re: Want to request new package, unsure about term [Solved]

Postby Fitzcarraldo » Fri Jul 20, 2012 18:08

As you're using SL, file your request in the SL Bugzilla. I notice that there is a very old, and probably non-functioning, ebuild for gbonds in Gentoo Bugzilla Bug Report No. 6808. You might want to link to that in your package request in the SL Bugzilla, as it would be a starting point for whoever takes up the challenge to develop an ebuild for the SL overlay.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Want to request new package, unsure about term [Solved]

Postby ratcheer » Fri Jul 20, 2012 21:04

Ok, thank you very much, fitzcarraldo.

Tim
ratcheer
Growing Hen
 
Posts: 103
Joined: Wed Mar 14, 2012 16:41

Re: Want to request new package, unsure about term [Solved]

Postby eor2004 » Sun Jul 22, 2012 22:16

I want to or wish to request the new devede 3.22.0 package, because I'm having issues with devede 3.21.0, the problem is that devede 3.21.0 it creates dvd with menus for some movies but not for others movies like anime movies this is very strange behavior! 3.17.0 was working ok, so I'm hoping that the issues I'm having with version 3.21.0 would have been fixed in version 3.22.0!
Sabayon Linux MATE 64-bit
Gigabyte G41M-ES2L-->2gb ram
Intel Pentium Dual Core 2.60ghz-->E5300
WD-6400AAKS-Caviar-SE16-640gb-->XFS filesystem
User avatar
eor2004
Simple Hen
 
Posts: 85
Joined: Thu Jul 12, 2012 15:46
Location: Puerto Rico

Re: Want to request new package, unsure about term [Solved]

Postby wolfden » Tue Jul 24, 2012 0:43

eor2004 wrote:I want to or wish to request the new devede 3.22.0 package, because I'm having issues with devede 3.21.0, the problem is that devede 3.21.0 it creates dvd with menus for some movies but not for others movies like anime movies this is very strange behavior! 3.17.0 was working ok, so I'm hoping that the issues I'm having with version 3.21.0 would have been fixed in version 3.22.0!


Please see:
viewtopic.php?f=76&t=13891
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 2 guests