entropy doesn't work

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

entropy doesn't work

Postby detestable » Tue Apr 10, 2012 10:51

Hello,

When I try to install packages with the help of command equo in terminal the installation process hangs for indefinitely long time till I interrupt it with ctrl+c. Same for emerge

below is an example of log:

Code: Select all
sudo equo install scilab
Password:
>>  @@ Calculating dependencies ...
>>  ## [R] [sabayonlinux.org] sci-mathematics/scilab-4.1.2-r2|5   [4.1.2-r2|5]
>>  @@ Packages needing to be installed/updated/downgraded: 1
>>  @@ Packages needing to be removed: 0
>>  @@ Download size: 0b
>>  @@ Freed disk space: 0.0b
>>  @@ You need at least: 30.5MB of free space
>>  :: (1/1) >>> 1 package
>>    ## Package checksum matches: sci-mathematics:scilab-4.1.2-r2~5.tbz2
>>  ++ (1/1) >>> sci-mathematics/scilab-4.1.2-r2
>>    ## Unpacking: sci-mathematics:scilab-4.1.2-r2~5.tbz2
>>    ## SPM: setup phase
^CTraceback (most recent call last):
  File "/usr/lib/portage/bin/lock-helper.py", line 28, in <module>
    rval = main(sys.argv[1:])
  File "/usr/lib/portage/bin/lock-helper.py", line 20, in main
    lock_obj = portage.locks.lockfile(args[0], wantnewlockfile=True)
  File "/usr/lib/portage/pym/portage/locks.py", line 158, in lockfile
    locking_method(myfd, fcntl.LOCK_EX)
KeyboardInterrupt


Any suggestions?

Thank you in advance
detestable
Young Hen
 
Posts: 20
Joined: Mon Jul 21, 2008 16:29

Re: entropy doesn't work

Postby mélodie » Thu Apr 12, 2012 3:21

Hi,

I suggest you will use "su" and not "sudo". I read somewhere over here or at the wiki that in Sabayon "su" is preferred, this is why I bring it back here.

Then you need to reload repos. If you have not done it yet, let it pick up the repos which will be the fastest for you. From this page:
http://wiki.sabayon.org/index.php?title=En:Entropy
Code: Select all
# equo repo mirrorsort sabayon-weekly


you may have the time to go fetch a cup of tea while it does the job.

Then:
Code: Select all
# equo update


it is the same as the reload button in Sulfur. It is needed so that the package manager can get a fresh list of the packages available at the remote server, compare with what is installed, and suggest updates to you. It will also make the programs you need available : if the database in your system is older than the information in the remote server, your package manager won't get what you ordered (fancy client/server relation in a restaurant, and you have the menu of last week instead of the current one).

Then you should be able to get your package... if there are updates to perform, then you should update prior to installing a new program.

Regards,
Mélodie

PS: I don't know if the package you try to install is broken, or healthy... of course.

PS-2 : I installed it successfully:

Code: Select all
comete kernel # equo install scilab
>>  @@ Calcul des dépendances ...
>>  ## [N] [sabayon-weekly] gnome-extra/gtkhtml-2.11.1|6
>>  ## [N] [sabayon-weekly] app-admin/eselect-lapack-0.1|1
>>  ## [N] [sabayon-weekly] sci-libs/lapack-reference-3.2.1|0
>>  ## [N] [sabayon-weekly] virtual/lapack-3.1|1
>>  ## [N] [sabayon-weekly] sci-mathematics/scilab-4.1.2-r3|0
>>  @@ Paquets qui ont besoin d'être installés/mis à jour/rétrogradés: 5
>>  @@ Paquets qui ont besoin d'être supprimés: 0
>>  @@ Taille du téléchargement: 20.1MB
>>  @@ Espace disque utilisé: 112.8MB
>>  @@ Vous avez besoin d'au moins: 152.9MB d'espace libre
>>  :: (1/2) >>> 3 packages
>>    ## Téléchargement: 3 archives
>>    ## ( mirror #1 ) [gnome-extra:gtkhtml-2.11.1~6.tbz2] @ http://ftp.surfnet.nl
>>    ## ( mirror #1 ) [app-admin:eselect-lapack-0.1~1.tbz2] @ http://ftp.surfnet.nl
>>    ## ( mirror #1 ) [sci-libs:lapack-reference-3.2.1~0.tbz2] @ http://ftp.surfnet.nl
>>   ## Aggregated download: 3 items
>>    # [1] ftp.surfnet.nl => gnome-extra:gtkhtml-2.11.1~6.tbz2
>>    # [2] ftp.surfnet.nl => app-admin:eselect-lapack-0.1~1.tbz2
>>    # [3] ftp.surfnet.nl => sci-libs:lapack-reference-3.2.1~0.tbz2
>> 8.0/727.0 kB <->   1% [>         ] => 8.7kB/seconde(s) : Temps restant es>> 16.0/874.6 kB <->   1% [>         ] => 17.1kB/seconde(s) : Temps restant >> 24.0/874.6 kB <->   2% [>         ] => 24.5kB/seconde(s) : Temps restant >>

 (...)

=> 667.9kB/seconde(s) : Temps rest>> 3338.6/5007.8 kB <->  66% [======>   ] => 685.1kB/seconde(s) : Temps rest>> 3954.6/5007.8 kB <->  78% [=======>  ] => 735.5kB/seconde(s) : Temps rest>> 4722.6/5007.8 kB <->  94% [=========>] => 803.4kB/seconde(s) : Temps rest>>    ## ( mirror #1 ) [gnome-extra:gtkhtml-2.11.1~6.tbz2] succès @ http://ftp.surfnet.nl
>>    ## ( mirror #1 ) [app-admin:eselect-lapack-0.1~1.tbz2] succès @ http://ftp.surfnet.nl
>>    ## ( mirror #1 ) [sci-libs:lapack-reference-3.2.1~0.tbz2] succès @ http://ftp.surfnet.nl
>>    ##  Taux de transfert groupé: 825.9kB/seconde
>>    ## Le contrôle de somme du paquet correspond: gnome-extra:gtkhtml-2.11.1~6.tbz2
>>       : GPG correspondances
>>       : SHA1 correspondances
>>       : SHA256 disabled
>>       : SHA512 disabled
>>    ## Le contrôle de somme du paquet correspond: app-admin:eselect-lapack-0.1~1.tbz2
>>       : GPG correspondances
>>       : SHA1 correspondances
>>       : SHA256 disabled
>>       : SHA512 disabled
>>    ## Le contrôle de somme du paquet correspond: sci-libs:lapack-reference-3.2.1~0.tbz2
>>       : GPG correspondances
>>       : SHA1 correspondances
>>       : SHA256 disabled
>>       : SHA512 disabled
>>  :: (2/2) >>> 2 packages
>>    ## Téléchargement: 2 archives
>>    ## ( mirror #1 ) [virtual:lapack-3.1~1.tbz2] @ http://ftp.surfnet.nl
>>    ## ( mirror #1 ) [sci-mathematics:scilab-4.1.2-r3~0.tbz2] @ http://ftp.surfnet.nl
>>   ## Aggregated download: 2 items
>>    # [1] ftp.surfnet.nl => virtual:lapack-3.1~1.tbz2
>>    # [2] ftp.surfnet.nl => sci-mathematics:scilab-4.1.2-r3~0.tbz2
>> 8.0/19582.1 kB <->   0% [>         ] => 15.3kB/seconde(s) : Temps restant>> 16.0/19711.5 kB <->   0% [>         ] => 27.7kB/seconde(s) : Temps restan>> 24.0/19711.5 kB <->   0% [>         ] => 41.1kB/seconde(s) : Temps restan>> 32.0/19711.5 kB <->   0% [>         ] => 54.3kB/seconde(s) : Temps restan>> 40.0/19711.5 kB <->   0%

(..........)

Temps rest>> 18633.4/19711.5 kB <->  94% [=========>] => 1.3MB/seconde(s) : Temps rest>> 19209.4/19711.5 kB <->  97% [=========>] => 1.3MB/seconde(s) : Temps rest>>    ## ( mirror #1 ) [virtual:lapack-3.1~1.tbz2] succès @ http://ftp.surfnet.nl
>>    ## ( mirror #1 ) [sci-mathematics:scilab-4.1.2-r3~0.tbz2] succès @ http://ftp.surfnet.nl
>>    ##  Taux de transfert groupé: 1.3MB/seconde
>>    ## Le contrôle de somme du paquet correspond: virtual:lapack-3.1~1.tbz2
>>       : GPG correspondances
>>       : SHA1 correspondances
>>       : SHA256 disabled
>>       : SHA512 disabled
>>    ## Le contrôle de somme du paquet correspond: sci-mathematics:scilab-4.1.2-r3~0.tbz2
>>       : GPG correspondances
>>       : SHA1 correspondances
>>       : SHA256 disabled
>>       : SHA512 disabled
>>  ++ (1/5) >>> gnome-extra/gtkhtml-2.11.1
>>    ## Dépaquettage: gnome-extra:gtkhtml-2.11.1~6.tbz2
>>    ## SPM: setup phase
>>    ## SPM: Phase de pré-installation
>>    ## Installation du paquet: gnome-extra/gtkhtml-2.11.1
>>    ## [a Gtk+ based HTML rendering library]
>>    ## Mise à jour de la base de données: gnome-extra/gtkhtml-2.11.1
>>    ## Cleaning previously installed application data.
>>> Regenerating /etc/ld.so.cache...
>>    ## SPM: Phase de post-installation
 * Updating desktop mime database ...
 * Updating shared mime info database ...
>>    ## Nettoyage: gnome-extra/gtkhtml-2.11.1
>>  ++ (2/5) >>> app-admin/eselect-lapack-0.1
>>    ## Dépaquettage: app-admin:eselect-lapack-0.1~1.tbz2
>>    ## SPM: setup phase
>>    ## SPM: Phase de pré-installation
>>    ## Installation du paquet: app-admin/eselect-lapack-0.1
>>    ## [LAPACK module for eselect]
>>    ## Mise à jour de la base de données: app-admin/eselect-lapack-0.1
>>    ## Cleaning previously installed application data.
>>    ## SPM: Phase de post-installation
>>    ## Nettoyage: app-admin/eselect-lapack-0.1
>>  ++ (3/5) >>> sci-libs/lapack-reference-3.2.1
>>    ## Dépaquettage: sci-libs:lapack-reference-3.2.1~0.tbz2
>>    ## SPM: setup phase
 * You need one of these Fortran Compilers: g77 gfortran ifc
 * Installed are:  gfortran
 * QA Notice: The 'hasq' function is deprecated (replaced by 'has')
 * QA Notice: The 'hasq' function is deprecated (replaced by 'has')
>>    ## Installation du paquet: sci-libs/lapack-reference-3.2.1
>>    ## [FORTRAN reference implementation of LAPACK Linear Algebra PACKage]
>>    ## Mise à jour de la base de données: sci-libs/lapack-reference-3.2.1
>>    ## Cleaning previously installed application data.
>>> Regenerating /etc/ld.so.cache...
>>    ## SPM: Phase de post-installation
 * lapack has been eselected to reference
>>    ## Nettoyage: sci-libs/lapack-reference-3.2.1
>>  ++ (4/5) >>> virtual/lapack-3.1
>>    ## Dépaquettage: virtual:lapack-3.1~1.tbz2
>>    ## SPM: setup phase
>>    ## SPM: Phase de pré-installation
find: `/var/tmp/entropy/packages/amd64/5/virtual_lapack-3.1_1.tbz2/portage/virtual/lapack-3.1/image/': No such file or directory
find: `/var/tmp/entropy/packages/amd64/5/virtual_lapack-3.1_1.tbz2/portage/virtual/lapack-3.1/image/': No such file or directory
>>    ## Installation du paquet: virtual/lapack-3.1
>>    ## [Virtual for Linear Algebra Package FORTRAN 77 (LAPACK) implementation]
>>    ## Mise à jour de la base de données: virtual/lapack-3.1
>>    ## Cleaning previously installed application data.
>>    ## SPM: Phase de post-installation
>>    ## Nettoyage: virtual/lapack-3.1
>>  ++ (5/5) >>> sci-mathematics/scilab-4.1.2-r3
>>    ## Dépaquettage: sci-mathematics:scilab-4.1.2-r3~0.tbz2
>>    ## SPM: setup phase
>>    ## SPM: Phase de pré-installation
>>    ## Installation du paquet: sci-mathematics/scilab-4.1.2-r3
>>    ## [Scientific software package for numerical computations (Matlab lookalike)]
>>    ## Mise à jour de la base de données: sci-mathematics/scilab-4.1.2-r3
>>    ## Cleaning previously installed application data.
>>> Regenerating /etc/ld.so.cache...
>>    ## SPM: Phase de post-installation
 * To tell Scilab about your printers, set the environment
 * variable PRINTERS in the form:
 *
 * PRINTERS="firstPrinter:secondPrinter:anotherPrinter"
>>    ## Nettoyage: sci-mathematics/scilab-4.1.2-r3
>>  @@ Installation terminée.
>>  @@ Configuration files scan complete.


There is one warning and one error message about files missing or not existing:
* QA Notice: The 'hasq' function is deprecated (replaced by 'has')
* QA Notice: The 'hasq' function is deprecated (replaced by 'has')


>> ## SPM: Phase de pré-installation
find: `/var/tmp/entropy/packages/amd64/5/virtual_lapack-3.1_1.tbz2/portage/virtual/lapack-3.1/image/': No such file or directory
find: `/var/tmp/entropy/packages/amd64/5/virtual_lapack-3.1_1.tbz2/portage/virtual/lapack-3.1/image/': No such file or directory


The demo does not work:
$
(zterm:16278): GLib-WARNING **: Failed to read from child watch wake up pipe: Appel système interrompu


The start of the program brings a warning about it being the last version used with... "the old graphic mode".

When you will succeed installing it you may have to fill a bug against it, if you find it to not work properly. I can't test it the right way because I have no idea what it is really supposed to do...
mélodie
Simple Hen
 
Posts: 97
Joined: Tue Feb 14, 2012 10:41

Re: entropy doesn't work

Postby detestable » Mon Apr 30, 2012 10:14

mélodie, thank you for the answer, but these operations do not save me from the trouble.

only when I reload my machine the entropy works normally again, but after some time the bug appears again and reloading the machine all the time is not a good option for me.
detestable
Young Hen
 
Posts: 20
Joined: Mon Jul 21, 2008 16:29

Re: entropy doesn't work

Postby albfneto » Tue May 01, 2012 15:32

May be a momentaneous problem in the package. Try installing another package, if the problem occurs with any packages, then try this:

Code: Select all
$ eselect python list (see the number if python 2.7, ebven when you is using python 3, you should  switch to 2.7)
# eselect python set NUMBER of python 2.7
# equo update --force
# equo upgrade
# equo libtest
# equo deptest


Now retry install packages.
ALBERTO FEDERMAN NETO
albfneto
albfneto@fcfrp.usp.br
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1689
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: entropy doesn't work

Postby Stupot » Tue May 01, 2012 15:43

Also, if you run into the problem again, try using the verbose flag to perhaps get more information.

Code: Select all
#equo install <whatever> --verbose


If it doesn't show up in there, something in the error log might give us an indication as well.
Stupot
Sagely Hen
 
Posts: 1518
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests

cron