IBus - Cannot change language/doesn't work

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

IBus - Cannot change language/doesn't work

Postby dudumomo » Sun Mar 11, 2012 11:42

Hi there,

I'm trying to use IBus to be able to type in Chinese (ZhuYin) but it doesn't seems to work with gnome3.

It's a fresh Sabayon Gnome 3 install with the latest IBus version (1.4.1) at this date.

After installing and adding the chinese language, I had the message: "No Input window" that I've sold with going to the Ibus settings --> Advanced and tick "Share the same input method among all application"

I see now the list of input language but cannot select any of them.

What should I do?

Thank you for your help !
dudumomo
Growing Hen
 
Posts: 149
Joined: Tue Nov 16, 2010 14:40

Re: IBus - Cannot change language/doesn't work

Postby dudumomo » Wed Mar 14, 2012 14:41

Any idea on how to do that?

Thank you !
dudumomo
Growing Hen
 
Posts: 149
Joined: Tue Nov 16, 2010 14:40

Re: IBus - Cannot change language/doesn't work

Postby dudumomo » Fri Mar 16, 2012 18:10

Could it be due to the USE flag?
-gtk3 (http://packages.sabayon.org/show/ibus,7 ... 5,standard) has been use for Ibus.

It seems that some people on Gentoo had the same issue:
https://forums.gentoo.org/viewtopic-t-9 ... art-0.html

So I will need to give a try I guess.
dudumomo
Growing Hen
 
Posts: 149
Joined: Tue Nov 16, 2010 14:40

Re: IBus - Cannot change language/doesn't work

Postby dudumomo » Sat Mar 17, 2012 5:09

Bingo, after compiling with USE = GTK3, ibus works.

But know, I have a problem with one of the input language: Chewing.

Ibus works well but I cannot type anything wih Chewing (Eng module of Chewing works well too)
With another chinese input, no problem
It is actually the same problem than this user: https://bbs.archlinux.org/viewtopic.php?id=77801

However I do have a error message when I try to type, asking me to check the .imsettings.log
Which contains:
Code: Select all
imsettings information
==========================
Is DBus enabled: yes
Is imsettings enabled: yes
Is GTK+ supported:
[ 1331957135.107008]: IMSettings-XIM backend[8099]: WARNING **: imsettings-xim XIM server isn't running.

[ 1331957135.107366]: IMSettings-LXDE backend[8099]: WARNING **: Unable to load the lxde configuration file.

[ 1331957135.117444]: IMSettings-XIM backend[8099]: WARNING **: imsettings-xim XIM server isn't running.

[ 1331957135.117663]: IMSettings-LXDE backend[8099]: WARNING **: Unable to load the lxde configuration file.
yes
Is Qt supported:
[ 1331957135.129626]: IMSettings-XIM backend[8099]: WARNING **: imsettings-xim XIM server isn't running.

[ 1331957135.129972]: IMSettings-LXDE backend[8099]: WARNING **: Unable to load the lxde configuration file.

[ 1331957135.140670]: IMSettings-XIM backend[8099]: WARNING **: imsettings-xim XIM server isn't running.

[ 1331957135.140880]: IMSettings-LXDE backend[8099]: WARNING **: Unable to load the lxde configuration file.
yes
DESKTOP: gnome
GUESS_DESKTOP: $GDMSESSION
DISABLE_IMSETTINGS:
IMSETTINGS_DISABLE_DESKTOP_CHECK:
DBUS_SESSION_BUS_ADDRESS:
GTK_IM_MODULE:
QT_IM_MODULE: xim
XMODIFIERS: @im=imsettings
IMSETTINGS_MODULE: IBus
IMSETTINGS_INTEGRATE_DESKTOP: yes

[ 1331957166.939710]: IMSettings-Daemon[8519]: INFO: Starting imsettings-daemon...
[ 1331957166.939821]: IMSettings-Daemon[8519]: INFO:   [HOME=/home/dudumomo]
[ 1331957166.939856]: IMSettings-Daemon[8519]: INFO:   [XINPUTRCDIR=/etc/X11/xinit/]
[ 1331957166.939889]: IMSettings-Daemon[8519]: INFO:   [XINPUTDIR=/etc/X11/xinit/xinput.d/]

[ 1331957166.939921]: IMSettings-Daemon[8519]: INFO:   [MODULEDIR=/usr/lib64/imsettings]

[ 1331957166.939956]: IMSettings-Daemon[8519]: INFO:   [MODULES=lxde, gsettings, xim, qt, gconf]


[ 1331957166.944131]: IMSettings-XIM backend[8519]: WARNING **: imsettings-xim XIM server isn't running.

[ 1331957166.945395]: IMSettings-LXDE backend[8519]: WARNING **: Unable to load the lxde configuration file.
[ 1331957167.064724]: IMSettings-Daemon[8519]: INFO: Attempting to switch IM to IBus [lang=en_US.UTF-8, update=false]
[ 1331957167.171418]: IMSettings-Daemon[8519]: INFO:   no need to invoke any auxiliary process for IBus
[ 1331957167.171490]: IMSettings-Daemon[8519]: INFO:   Starting the main process for IBus [lang:en_US.UTF-8]
[ 1331957167.172425]: IMSettings-Daemon[8519]: INFO:   Started IBus: [process: /usr/bin/ibus-daemon --xim, lang: en_US.UTF-8, pid: 8794, id: 17, time: 2012-03-17T04:06:07.172347Z
[ 1331957167.173657]: IMSettings-GConf backend[8519]: INFO: Setting up ibus as gtk+ immodule
[ 1331957167.174998]: IMSettings-Qt backend[8519]: INFO: Setting up xim as Qt immodule
[ 1331957170.183273]: IMSettings-XIM backend[8519]: INFO: Setting up ibus as XIM
[ 1331957170.183504]: IMSettings-GSettings backend[8519]: INFO: Setting up ibus as gtk+ immodule

[ 1331957170.183688]: IMSettings-LXDE backend[8519]: WARNING **: Unable to read the LXDE configuration file.

[ 1331957170.186105]: IMSettings-LXDE backend[8519]: WARNING **: the changes will not be applied until your next login.
[ 1331957170.186838]: IBus[8794]: current session already has an ibus-daemon.


[ 1331957170.186878]: IMSettings-Daemon[8519]: WARNING **: main Input Method process for IBus died with the status 255, but unexpectedly. restarting...
[ 1331957170.186925]: IMSettings-Daemon[8519]: INFO:   Starting the main process for IBus [lang:en_US.UTF-8]
[ 1331957170.187803]: IMSettings-Daemon[8519]: INFO:   Started IBus: [process: /usr/bin/ibus-daemon --xim, lang: en_US.UTF-8, pid: 9100, id: 26, time: 2012-03-17T04:06:10.187791Z
[ 1331957170.199907]: IBus[9100]: current session already has an ibus-daemon.


[ 1331957170.233267]: IMSettings-Daemon[8519]: WARNING **: main Input Method process for IBus died with the status 255, but unexpectedly. restarting...
[ 1331957170.233371]: IMSettings-Daemon[8519]: INFO:   Starting the main process for IBus [lang:en_US.UTF-8]
[ 1331957170.236280]: IMSettings-Daemon[8519]: INFO:   Started IBus: [process: /usr/bin/ibus-daemon --xim, lang: en_US.UTF-8, pid: 9103, id: 29, time: 2012-03-17T04:06:10.236267Z
[ 1331957170.244117]: IBus[9103]: current session already has an ibus-daemon.


[ 1331957170.280313]: IMSettings-Daemon[8519]: CRITICAL **: Giving up to bring the process up because main Input Method process for IBus rapidly died many times. See .imsettings.log for more details.


Any idea to solve that?
dudumomo
Growing Hen
 
Posts: 149
Joined: Tue Nov 16, 2010 14:40

Re: IBus - Cannot change language/doesn't work

Postby dudumomo » Wed Mar 21, 2012 13:46

Any help?
dudumomo
Growing Hen
 
Posts: 149
Joined: Tue Nov 16, 2010 14:40


Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests