Problem with nautilus-autostart.desktop

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Post Reply
undoIT
Young Hen
Posts: 24
Joined: Tue Feb 28, 2012 23:45

Problem with nautilus-autostart.desktop

Post by undoIT » Thu Mar 01, 2012 11:42

I installed Sabayon 8 KDE version. Then I installed GNOME desktop with equo install @gnome. In KDE, I have Restore previous session turned on in System Settings > Startup and Shutdown > Session Managament. Everytime I logged into KDE, a Nautilus window would open with the home folder, even after starting with a fresh KDE session. Also, I noticed that GNOME desktop was running under Plasma Desktop. The problem is not apparent in KDE unless you open System Monitor and see nautilus running when it shouldn't be or turn on session management. I figured out that the following autostart script is causing this.

/etc/xdg/autostart/nautilus-autostart.desktop

This is easily fixed by adding the following entry to that file:

Code: Select all

OnlyShowIn=GNOME;
I don't know if there are other GNOME autostart scripts that need to be adjusted as well. This fix should be added to future releases and perhaps the Sabayon team should check for any other autostart scripts that need to be adjusted in the same way.

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: Problem with nautilus-autostart.desktop

Post by wolfden » Thu Mar 01, 2012 12:01

We have a bugzilla for things like this:
https://bugs.sabayon.org/

Post Reply