Crash con drivers nvidia 295.20 [Risolto]

Se sei un utente alle prime armi con Linux o Sabayon, questo è il posto che fa per te :)

Moderator: Moderators

Crash con drivers nvidia 295.20 [Risolto]

Postby Kalastor » Mon Feb 27, 2012 18:39

Non sapendo dove scrivere ho optato per l'area principianti.. Spero di non avver errato completamente :D
Ho provato anche a fare una veloce ricerca sul forum, ma con scarso risultato..

Volevo avvisare che i driver 295.20 sembrano aver introdotto un bug che causa il crash di Gnome 3 quando si fa una ricerca fra le applicazioni e, a quanto pare, a volte anche in maniera randomatica mentre si naviga il web.

I log dei miei crash son questi:
Code: Select all
Niflheim kalastor # grep gnome /var/log/messages | grep nvidia
Feb 27 17:56:03 localhost kernel: [ 2004.622972] gnome-shell[16896]: segfault at 10 ip 00007fc541e89c0f sp 00007fc5107f8708 error 6 in libnvidia-tls.so.295.20[7fc541e89000+3000]
Feb 27 17:56:25 localhost kernel: [ 2026.061363] gnome-shell[17037]: segfault at 10 ip 00007f1498625c0f sp 00007f1480a4a708 error 6 in libnvidia-tls.so.295.20[7f1498625000+3000]
Feb 27 17:57:19 localhost kernel: [ 2080.470880] gnome-shell[17602]: segfault at 10 ip 00007fbda20e0c0f sp 00007fbd7359a708 error 6 in libnvidia-tls.so.295.20[7fbda20e0000+3000]
Feb 27 17:59:01 localhost kernel: [   49.381855] gnome-shell[8255]: segfault at 10 ip 00007f1e03833c0f sp 00007f1dd9ccc708 error 6 in libnvidia-tls.so.295.20[7f1e03833000+3000]
Feb 27 17:59:31 localhost kernel: [   79.989967] gnome-shell[8478]: segfault at 10 ip 00007f50bdcfac0f sp 00007f50966d3708 error 6 in libnvidia-tls.so.295.20[7f50bdcfa000+3000]
Feb 27 18:10:16 localhost kernel: [   54.972229] gnome-shell[8127]: segfault at 10 ip 00007f1272359c0f sp 00007f124ac76708 error 6 in libnvidia-tls.so.295.20[7f1272359000+3000]
Feb 27 18:15:49 localhost kernel: [  387.139840] gnome-shell[10561]: segfault at 10 ip 00007f8071973c0f sp 00007f803f9e8708 error 6 in libnvidia-tls.so.295.20[7f8071973000+3000]


Con una ricerca in internet ho letto che l'unico modo, che non sia solamente una temporanea panacea, è quello di fare un downgrade ai driver precedenti ma, se non ho inteso male, in sabayon questo non è possibile..

O c'è per caso qualche soluzione per passare ad una versione precedente degli stessi?

"Fonti":
http://www.nvnews.net/vbulletin/showthr ... 049&page=3
https://bugs.archlinux.org/task/28441
https://bbs.archlinux.org/viewtopic.php?id=135826&p=1
Last edited by Kalastor on Tue Feb 28, 2012 16:00, edited 1 time in total.
Kalastor
Baby Hen
 
Posts: 7
Joined: Sat Jan 20, 2007 20:45

Re: Crash con drivers nvidia 295.20

Postby belcocco » Tue Feb 28, 2012 10:02

Ma certo che si può fare il downgrade.:-)
Scarica questi pacchetti manualmente.
ftp://na.mirror.garr.it/pub/1/sabayonli ... .10~2.tbz2
ftp://na.mirror.garr.it/pub/1/sabayonli ... yon~3.tbz2
Poi dai nell'ordine:
#equo install x11-drivers:nvidia-userspace-290.10~2.tbz2
#equo install x11-drivers:nvidia-drivers-290.10#3.2.0-sabayon~3.tbz2

La cosa potrebbe finire qui con un reboot, ma non è così.
Chiaramente dopo il riavvio entropy ti dirà che ci sono due pacchetti nvidia da aggiornare, che NON vanno aggiornati.
Allora dai:
#equo upgrade --pretend
Scopri come si chiamano i pacchetti e li mascheri con:
#equo mask x11-drivers/nvidia-drivers-295.20#3.2.0-sabayon
#equo mask x11-drivers/nvidia-userspace-295.20

Adesso si può fare il reboot.
Ciao

P.S. Purtroppo una volta fatto il mask dei pacchetti con il baco accade che il sistema chiede addirittura di fare un downgrade alle versione .173 di nvidia. QUESTO non lo capisco molto. Indagherò.
belcocco
Old Dear Hen
 
Posts: 452
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: Crash con drivers nvidia 295.20

Postby Kalastor » Tue Feb 28, 2012 16:00

Ho seguito le tue istruzioni [scaricando la rev 5 invece della 3 per quanto riguarda i driver ftp://na.mirror.garr.it/pub/1/sabayonli ... yon~5.tbz2 ] e tutto sembra essere tornato alla normalità.. :D

Unico problema che ho riscontrato è l'impossibilità di installare l' nvidia-settings 290.10 [ ftp://na.mirror.garr.it/pub/1/sabayonli ... .10~0.tbz2 ], dato che per farlo richiede nuovamente l'upgrade alla versione 295.20 ... E non sono abbastanza fiducioso per provare un --nodeps.

Per quanto riguarda il mask accade lo stesso anche a me, dopo punta ai 173.. Visto il risultato ho quindi tolto la mask dai 295.. ;P

Comunque ti ringrazio!
Ora non resta che sperare in una nuova uscita dei driver nvidia :D
E in attesa aggiungo il tag Risolto al titolo ;P
Kalastor
Baby Hen
 
Posts: 7
Joined: Sat Jan 20, 2007 20:45

Re: Crash con drivers nvidia 295.20 [Risolto]

Postby sabayonino » Tue Feb 28, 2012 19:15

se vuoi mascherare anche le versioni precedenti devi giocherellare con gli operatori logici

= per mascherare una versione specifica (esempio : =x11-drivers/nvidia-drivers-290.10)
>= per mascherare una versione maggiore o uguale a quella indicata (esempio : >=x11-drivers/nvidia-drivers-290.10)
=< per mascherare una versione minore o uguale a quella indicata (esempio =<x11-drivers/nvidia-drivers-290.10)
> per mascherare le versioni maggiori di quella indicata ma non la stessa (esempio : >x11-drivers/nvidia-drivers-290.10)
< per mascherare le versioni minori di quella indicata ma non la stessa (esempio <x11-drivers/nvidia-drivers-290.10)
senza alcun parametro ma solo il nome del pacchetto per mascerare tutte le versioni (esempio : x11-drivers/nvidia-drivers)


idem per i pacchetti da smascherare
User avatar
sabayonino
Sagely Hen
 
Posts: 2512
Joined: Sun Sep 21, 2008 1:12
Location: Italy


Return to Sabayon Linux Area Principianti

Who is online

Users browsing this forum: No registered users and 0 guests

cron