Runlevel single does not start up LVM

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Runlevel single does not start up LVM

Postby tangram » Mon Feb 27, 2012 20:57

Hello
Runlevel single does not start LVM ( and probably any other scripts added to this runlevel) .
When I try to start up my sabayon in single user mode, my lvm partitions are not connected.
I have my own partition layout, where not whole disk is lvm managed, only partitions: /tmp, /opt, /home, /user, /var, /opt
Seems that some services did not run.
I tried to add scripts to the single runlevel, but no one of them was called.
I read init and inittab manuals, unfortunately I am not smarter as before.
It is a bit confused for me, do boot or sysinit runlevels run in single user mode or not ?
What I suppose, single user mode do not need inittab infos and therefore boot and / or default services are not started.
Any help / explain would be appreciated.
Thanks.

Menu entry for boot:
Code: Select all
menuentry 'Sabayon GNU/Linux, with Linux x86_64-3.2.0-sabayon (recovery mode)' --class sabayon --class gnu-linux --class gnu --class os {
   load_video
   insmod gzio
   insmod part_msdos
   insmod ext2
   set root='(hd0,msdos1)'
   search --no-floppy --fs-uuid --set=root 3d1e4223-f61e-492b-8c8c-2596a8d6bd72
   echo   'Loading Linux x86_64-3.2.0-sabayon ...'
   linux   /kernel-genkernel-x86_64-3.2.0-sabayon ro single init_opts=single  init=/linuxrc splash=verbose,theme:sabayon radeon.modeset=1 vga=791 console=tty1 quiet dokeymap keymap=pl domdadm resume=swap:UUID=e04952f2-07be-4724-b472-4f7d8ca18176 real_resume=UUID=e04952f2-07be-4724-b472-4f7d8ca18176 dolvm root=UUID=0d015365-2930-4de4-86d5-f3f565ebc1cc docrypt nox
   echo   'Loading initial ramdisk ...'
   initrd   /initramfs-genkernel-x86_64-3.2.0-sabayon
}


My /etc/inittab:
[url]
http://pastebin.sabayon.org/pastie/8452
[/url]

My equo --info
[url]
http://pastebin.sabayon.org/pastie/8453
[/url]
tangram
Baby Hen
 
Posts: 11
Joined: Mon Jul 04, 2011 21:16
Location: 3City, PL

Re: Runlevel single does not start up LVM

Postby tangram » Fri Mar 02, 2012 9:33

Dear admins, could someone remove my disgraceful topic, please ?
Runlevel single is just for that, that not all things are started, connected etc... :oops:
I needed it for LV volume resizing.
Yesterday, I done it, it was not simple, but I done it :D
tangram
Baby Hen
 
Posts: 11
Joined: Mon Jul 04, 2011 21:16
Location: 3City, PL


Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron