man uses wrong encoding: ascii for utf-8 [Solved]

Discussions Regarding Software

Moderator: Moderators

man uses wrong encoding: ascii for utf-8 [Solved]

Postby bjoernX » Wed Feb 22, 2012 17:42

Hi there!

I have problems displaying german manpages here. They are encoded utf-8 but man uses ascii it seems (displaying two funny characters for one).

#man ls
LS(1) Dienstprogramme für Benutzer LS(1)


First line should read: "Dienstprogramme für Benutzer". Looks like utf8 interpreted as ascii to me.
Same in konsole, xterm, terminal without X.

bzless /usr/share/man/de/man1/ls.1.bz2 an less work fine though. I decompressed and verified that this manpage is encoded in utf-8.

$LANG is de_DE.UTF-8, $LANGUAGE is empty, $LC_ALL is not defined. Setting all these to $LANG doesn't help.

The relevant definitions in /etc/man.conf look like this (vanilla, unchanged from installation):

Code: Select all
TROFF           /usr/bin/groff -Tps -mandoc
NROFF           /usr/bin/nroff -mandoc
JNROFF          /usr/bin/groff -Tnippon -mandocj
EQN             /usr/bin/geqn -Tps
NEQN            /usr/bin/geqn -Tlatin1
JNEQN           /usr/bin/geqn -Tnippon
TBL             /usr/bin/gtbl
# COL           /usr/bin/col
REFER           /usr/bin/refer
PIC             /usr/bin/pic
VGRIND
GRAP
PAGER           /usr/bin/less -isR
BROWSER         /usr/bin/lynx
HTMLPAGER       /usr/bin/lynx -dump
CAT             /bin/cat
#


Probably can be fixed there, but haven't tried yet.
I consider this a bug. IMHO man should be configured OOTB to display manpages correctly in the encoding used for manpages shipping with the distro - which means: configured for utf-8 regardless of language preference (that's what utf-8 was made for after all).
Last edited by bjoernX on Wed Feb 22, 2012 18:50, edited 1 time in total.
bjoernX
Baby Hen
 
Posts: 9
Joined: Sat Feb 18, 2012 22:38

Re: man uses wrong encoding: ascii for utf-8

Postby Fitzcarraldo » Wed Feb 22, 2012 18:33

Check if you have got all the localisation settings configured correctly, by going through the Gentoo Linux Localization Guide (it uses German as the case study). See also the post : Re: en_GB language missing after install. (of course changing "en_GB" to "de_DE") which might also be of help.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: man uses wrong encoding: ascii for utf-8

Postby bjoernX » Wed Feb 22, 2012 18:48

Easy Fix: equo install man-db
...will happily replace the old man

>> https://bugs.sabayon.org/show_bug.cgi?id=3067

As it turned out, it's an old buggy bastard-package that accidentally took to the Sabayon 8 Isos...
Thanks Enlik + micia for the quick help in irc! :)

BTW: This line in /etc/man.conf may be a workaround for that "old man" (but it feels somewhat awkward).
Code: Select all
NROFF           /usr/bin/nroff -mandoc -Tlatin1

man-db has no /etc/man.conf.
bjoernX
Baby Hen
 
Posts: 9
Joined: Sat Feb 18, 2012 22:38


Return to Software in General

Who is online

Users browsing this forum: No registered users and 2 guests

cron