Segfault in mocp

Discussions Regarding Software

Moderator: Moderators

Segfault in mocp

Postby aquarius » Fri Jan 27, 2012 15:07

Hi,
I was using moc as music player for some time. But for a few days it fails to launch. All I see is segfault in dmesg:
Code: Select all
[19408.886090] mocp[10737]: segfault at 358 ip 0000000000432f8a sp 00007fffff346880 error 4 in mocp[400000+4f000]
...
[22047.043546] mocp[11153]: segfault at 358 ip 0000000000432f8a sp 00007fff2b1fe730 error 4 in mocp[400000+4f000]

Reinstalling moc did not helped :(
I'm using the current moc from weekly repo: media-sound/moc-2.5.0_alpha4_p20111211
Any ideas what might went wrong?

Thanks in advance!
Gnome2 is dead! Long live... E17!

System76 Gazelle Professional:
Intel Core i7-2670QM
Nvidia GeForce GTX 560M
16GB DDR3 SDRAM
750GB HDD + 120GB SSD
15.6" Full HD LED-Backlit Matte Display

powered by Sabayon amd64 E17
aquarius
Simple Hen
 
Posts: 86
Joined: Sun Jun 26, 2011 22:17
Location: L'viv, Ukraine

Re: Segfault in mocp

Postby aquarius » Sat Jan 28, 2012 16:06

I just made a fresh install on daily E17 iso to verify this problem. After applying all upgrades there is no problem with mocp.
So, there can be 2 explainations:
-the problem is mine (on local machine);
-the problem is solved, but fix is not in weekly repo yet.
I hope the latter is the true one :)
Gnome2 is dead! Long live... E17!

System76 Gazelle Professional:
Intel Core i7-2670QM
Nvidia GeForce GTX 560M
16GB DDR3 SDRAM
750GB HDD + 120GB SSD
15.6" Full HD LED-Backlit Matte Display

powered by Sabayon amd64 E17
aquarius
Simple Hen
 
Posts: 86
Joined: Sun Jun 26, 2011 22:17
Location: L'viv, Ukraine

Re: Segfault in mocp

Postby aquarius » Mon Jan 30, 2012 10:35

I've updated my SL on the weekend.
Unfortunatelly, segfault is still there :cry:
Now I'm pretty sure that the problem is local (mine only).

Any ideas how can I fix it?
Gnome2 is dead! Long live... E17!

System76 Gazelle Professional:
Intel Core i7-2670QM
Nvidia GeForce GTX 560M
16GB DDR3 SDRAM
750GB HDD + 120GB SSD
15.6" Full HD LED-Backlit Matte Display

powered by Sabayon amd64 E17
aquarius
Simple Hen
 
Posts: 86
Joined: Sun Jun 26, 2011 22:17
Location: L'viv, Ukraine


Return to Software in General

Who is online

Users browsing this forum: No registered users and 2 guests