More problems after update... [Solved]

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Post Reply
Growing Hen
Posts: 104
Joined: Fri May 04, 2007 17:39

More problems after update... [Solved]

Post by Revolver » Tue Jan 24, 2012 21:24

Good Evening to all,

after an update made on my desktop pc (about 2 gb of updates, last update was october or november...) when the login screen appears the computer freeze (even pressing alt+F buttons doesn't go in shell mode, i have to start via interactive boot without starting xdm).

So i've checked the gcc version (it is the 4.6.2) and the video drivers (is set on ati) so i try to make another update without success.

I've also tried to merge config files through equo conf update. The result was always the same.

Now i'm trying to make a deptest and libtest.

I post the error log about Xorg, xdm and kdm.

My distro is Saby 7/8 x86_64 kde and video Ati radeon 5770 kernel 3.0.0.


When i checked the kernel version i see the kernel 3.2.0 installed (I HAVE NOT INSTALLED IT )but without asterisk.

When i force the kernel to boot via grub i see the new splash screen appear instead when i start with kernel 3.0.0 there is the old splash screen.

I hope in some good news and thnx!! :lol: :lol: :lol:
Last edited by Revolver on Thu Jan 26, 2012 0:01, edited 1 time in total.

Simple Hen
Posts: 50
Joined: Mon Apr 06, 2009 2:22

Re: More problems after update...

Post by DanAlucard » Wed Jan 25, 2012 1:56

I think this is an fglrx (ati-drivers) related problem.

if you want to install the new 3.2 kernel (which I recommend) you can do this:

first, test if u have the boot partition mounted:

Code: Select all

mount | grep boot
if it is mounted the result will be:

Code: Select all

/dev/sdXX on /boot type ext4 (rw,commit=0)
if u haven't it mounted, mount it on /boot.

Then do a kernel switch (as root):

Code: Select all

kernel-switcher switch linux-sabayon-3.2-r1
and it will automatically install the 3.2 kernel and needed kernel modules (such as ati-drivers and virtualbox-modules) for the new kernel.

Be careful with grub options. If u run kernel switcher (which runs grub-mkconfig) in safe mode (without Xorg) the grub normal kernel boot line will contain (after upgrading) the options nox AND/OR gentoo=nox AND/OR single. If any of them appears after upgrading the kernel, delete them at boot time or u will not have X at startup. After a successful desktop start, open a terminal an write:

Code: Select all

grub-mkconfig -o /boot/grub/grub.cfg
and it will be fine for next boots.

If u don't want to install the 3.2 kernel, try to reinstall the ati-drivers package and tell me what happens ;)
Sabayon Linux Fully updated ;)
CPU: AMD FX 4100 @4515MHz
RAM: 8GB Corsair Vengeance LP DDR3-1600
Video: Ati Radeon HD7770 - 1095MHz core 1GB GDDR5 @1250MHz

Lenovo ideapad S205 - 11.6" HD screen - AMD E450 APU - Ati HD 6320 - 4GB DDR3 RAM

Growing Hen
Posts: 104
Joined: Fri May 04, 2007 17:39

Re: More problems after update...

Post by Revolver » Wed Jan 25, 2012 23:55

Ok solved!

I have done the kernel-switcher command on kernel 3.0.0 (i want to wait a little bit before upgrade kernel) and everything goes fine!

before do it, i've launched the equo deptest and libtest commands.

Now saby works again. Thnx for the reply! :D

Post Reply