Supertux 0.3.3

Discussions Regarding Software

Moderator: Moderators

Post Reply
lhuser
Baby Hen
Posts: 18
Joined: Sun Nov 18, 2007 16:28

Supertux 0.3.3

Post by lhuser » Wed Jan 25, 2012 4:23

I've been using the latest version of this OS for quite a while (KDE) and I can say I'm happy with it, and it increased greatly my Linux knowledge and got rid of you know what.

Anyways, there's still one stagnant issue that I've searched everywhere and all they give me is either source files or weird bug fixes not related to Sabayon/Gentoo.

I downloaded Supertux 0.3.3 ( I don't want 0.1.3) and while running the make command, it stalls at 68% and gives me this all the time:

/home/lhuser/Downloads/supertux-0.3.3/src/addon/addon_manager.cpp:32:26: fatal error: curl/types.h: No such file or directory
compilation terminated.
make[2]: *** [CMakeFiles/supertux2.dir/src/addon/addon_manager.cpp.o] Error 1
make[1]: *** [CMakeFiles/supertux2.dir/all] Error 2
make: *** [all] Error 2



I've tried reinstalling curl, tried installing the 0.3.3 version from the Gentoo repository as well, tried a compiled RPM package (I know it's not the best thing to do) but no avail. I'm still stuck.

I checked all dependencies and they are all met.

What is making this occur every time?

joost
Sagely Hen
Posts: 2675
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: Supertux 0.3.3

Post by joost » Wed Jan 25, 2012 10:48

https://supertux.lethargik.org/bugs/view.php?id=855

So open src/addon/addon_manager.cpp and remove the # include <curl/types.h>
Image
My blog | Twitter

Please support Sabayon: Image

Post Reply