Creative X-Fi Titanium 20k2 [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Creative X-Fi Titanium 20k2 [Solved]

Postby Neuntausend » Fri Jan 20, 2012 6:02

Hi folks,

I recently installed the latest Sabayon and so far I am blown away by almost everything working out of the box and fast, including graphics drivers, flash, codecs ...
But as usual there is one thing that I can not get right - the sound. Oh how I hate linux when it comes to sound! And this time, at least output is working fine, but I need the damn mic as well.

I have a Creative X-Fi Titanium soundcard and the system recognizes it as such (X-Fi Titanium Series [Emu20k2]). I can easily switch modes from analog stereo to 4.0 to 5.1, you name it, and it seems to work well. But on the recording tab of the mixer I can only see one "input", labeled "Analog Stereo" which is actually just the loopback from the stereo output. The actual line-in/microphone jack is not listed anywhere and thus I can't record anything from it.

I have not looked into this fancy pulse audio stuff much yet and thus can't really tell anything more really, but i didn't dare to just uninstall it (who knows what else might break if i did that?).

Here's how it looks in pavucontrol:


Any ideas on how to get the mic working?
Last edited by Neuntausend on Fri Jan 20, 2012 10:27, edited 1 time in total.
Baby Hen
Posts: 3
Joined: Fri Jan 20, 2012 5:33

Re: Creative X-Fi Titanium (20k2)

Postby Fitzcarraldo » Fri Jan 20, 2012 9:22

Don't have your hardware, so cannot be of much help. What does alsamixer show (Press F6 and select your card)? Google is showing me: Creative X-Fi Titanium Fatality - Microphone gets no input, no sound. (Post #6 looks helpful).
User avatar
Sagely Hen
Posts: 8091
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Creative X-Fi Titanium (20k2)

Postby Neuntausend » Fri Jan 20, 2012 10:27

I tried googling quite a lot, but this one slipped past me and I look quite stupid now. :oops:

You are right - post #6 of your link has the answer: In addition to setting only the mic as recording device in the input section of alsamixer, I had to unmute line-in in the output section (I really don't get this part) wich activated the mic, but at the same time played back everything recorded by it. now to counter that, I had to turn the mic bar all the way down. It is a bit weird, but I guess it has to do with this so called "flexijack" that can be line in as well as microphone.

Anyways - thanks a lot, problem solved. 8)
Baby Hen
Posts: 3
Joined: Fri Jan 20, 2012 5:33

Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests