Weekly update installed 13th Jan

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Weekly update installed 13th Jan

Postby cl00t » Sat Jan 14, 2012 13:31

Firstly, hello :) , my 1st post here as I am a new Sabayan user, moved over in the last week from Opensuse.
I've used Linux on & off since the mid 90's but only in the last 6 months (since my mac died) have I used Linux as my sole OS on a new laptop bought for that purpose.

I wanted a rolling release & Sabayan is my choice :mrgreen:

Thank you to everyone involved in the project.

I use the weekly update repo, not limbo.

I was still on the original kernel (3.0.0 I think) & had yet to upgrade it. I was fully up to date with all updates on 12th Jan. Yesterday I ran equo refresh / then upgrade & followed the instructions implicitly, about 90+ updates downloaded & installed. The config files were updated. On reboot I get a flashing cursor, grub had disappeared.
I had to run a repair of grub from the live dvd.
Where did I go wrong? When updating the config files I chose to replace the old file with the new in every case, maybe that is where I went wrong?

I have since upgraded the kernel to 3.2 & all seems well.

One minor niggle is that before the update, I was using a timeserver to set my clock & it worked ok, after the upgrade it seemed to think I was in New York :lol: I am actually in the UK. I can get round that.

I thought I would post my experiences, but any comments are welcome.

Ps. One more thing. I use KDE, not gnome. When I go to install packages, for example Backintime, there was no specific KDE version as there was in Opensuse (a choice of KDE or Gnome), so installing Backintime installed a load of Gnome files, why is that?

Thanks,

Richard
cl00t
Growing Hen
 
Posts: 168
Joined: Thu Jan 12, 2012 15:29

Re: Weekly update installed 13th Jan

Postby Fitzcarraldo » Sat Jan 14, 2012 14:23

Welcome to SL.

Not sure what happened during your upgrade, but did you upgrade the kernel using the kernel-switcher tool? See the SL Wiki article Entropy for how to use that. As to your question about updating config files, I doubt that was the cause as the opposite is usually true, i.e. if you forget to update them then you run into trouble.

Regarding clock syncronisation, the post Re: Can`t change time and date in KDE, and the one after it, might be of help. There's also a link in that post to an SL Wiki article which it would also be worth your while reading.

Don't use Backintime myself but, if it pulled in GNOME packages then that would be presumably be because the pre-compiled Backintime package in Entropy has the gnome USE flag set:

https://packages.sabayon.org/show/backi ... 5,standard

The SL Entropy package maintainers don't normally build different versions of the same application for each DE. The Gentoo ebuild for Backintime allows you to build for either DE:

Code: Select all
DEPEND="
        net-misc/rsync[xattr,acl]
        kde? (
                >=kde-base/kdelibs-4
                kde-base/pykde4
                kde-base/kompare
                kde-base/kdesu
                )
        gnome? (
                gnome-base/libglade
                dev-util/meld
                gnome-base/gnome-session
                dev-python/gnome-vfs-python
                dev-python/libgnome-python
                dev-python/pygobject:2
                dev-python/pygtk
                )
        dev-python/notify-python"


As an aside, some things that are used in KDE can depend on GNOME: GStreamer is one of the KDE-recommended Phonon backends for KDE, but the tool gsteamer-properties used to configure GStreamer requires the package gnome-media to be installed. Needless to say, if you install gnome-media then you'd pull in GNOME packages too.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Weekly update installed 13th Jan

Postby BHReach » Sat Jan 14, 2012 14:59

I think the default time zone is NY, when you chose to overwrite your config files the TZ was set back to the default.

The following 2 command should fix it.

Code: Select all
cp /usr/share/zoneinfo/Europe/London  /etc/localtime
echo 'Europe/London' > /etc/timezone
BHReach
Growing Hen
 
Posts: 193
Joined: Thu Jan 31, 2008 20:40

Re: Weekly update installed 13th Jan

Postby cl00t » Sun Jan 15, 2012 18:33

Thanks for the reply.
At the time of getting the Grub problem after installing the updates on 13/01 I had not touched the kernel & was still running the one installed from the live DVD.

After repairing Grub & ensuring all was ok I did then change the kernel to 3.2 using kernel-switcher & the instructions in wiki (great tool by the way) & that is running fine.

Ok, good to know about why Backintime pulled in the Gnome dependencies. In Opensuse I had no Gnome installed at all & I know some people are purists & don't like Gnome libraries installed if they use KDE & visa versa. With a 500gb HDD I don't think it matters, it will just use a little space :)

After the update only 1 problem is apparent, the laptop does not fully shut down. It exits KDE & I get the progress shutdown bar at the bottom in blue which proceeds all the way across then the laptop remains like that, I have to hit the power button. Other than this, it is ok.

Thanks again.

Ps. One thing I forgot to mention, after repairing grub due to the machine not starting after the updates, my root password was reset to a blank password, was this normal?

Fitzcarraldo wrote:Welcome to SL.

Not sure what happened during your upgrade, but did you upgrade the kernel using the kernel-switcher tool? See the SL Wiki article Entropy for how to use that. As to your question about updating config files, I doubt that was the cause as the opposite is usually true, i.e. if you forget to update them then you run into trouble.

Regarding clock syncronisation, the post Re: Can`t change time and date in KDE, and the one after it, might be of help. There's also a link in that post to an SL Wiki article which it would also be worth your while reading.

Don't use Backintime myself but, if it pulled in GNOME packages then that would be presumably be because the pre-compiled Backintime package in Entropy has the gnome USE flag set:

https://packages.sabayon.org/show/backi ... 5,standard

The SL Entropy package maintainers don't normally build different versions of the same application for each DE. The Gentoo ebuild for Backintime allows you to build for either DE:

(snip)

As an aside, some things that are used in KDE can depend on GNOME: GStreamer is one of the KDE-recommended Phonon backends for KDE, but the tool gsteamer-properties used to configure GStreamer requires the package gnome-media to be installed. Needless to say, if you install gnome-media then you'd pull in GNOME packages too.
Last edited by cl00t on Sun Jan 15, 2012 18:39, edited 1 time in total.
cl00t
Growing Hen
 
Posts: 168
Joined: Thu Jan 12, 2012 15:29

Re: Weekly update installed 13th Jan

Postby cl00t » Sun Jan 15, 2012 18:34

All sorted, thank you

BHReach wrote:I think the default time zone is NY, when you chose to overwrite your config files the TZ was set back to the default.

The following 2 command should fix it.

Code: Select all
cp /usr/share/zoneinfo/Europe/London  /etc/localtime
echo 'Europe/London' > /etc/timezone
cl00t
Growing Hen
 
Posts: 168
Joined: Thu Jan 12, 2012 15:29


Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests

cron