Mouse accel off help......

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Mouse accel off help......

Postby Raklap88 » Fri Jan 13, 2012 16:17

Hello
Needing help to turn off mouse acceleration.
So far, I tried this:




Section "input class"
Identifier "Generic Mouse"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
Option "SendCoreEvents" "true"
Option "Buttons" "7"
Option "ButtonMapping" "1 2 3 4 5 6 7 8 9"

Following the set # 1 to a 0 to disable acceleration respectively.
Option "AccelerationNumerator" "1"
Option "AccelerationDenominator" "1"
Option "AccelerationThreshold", "0"
# Some curved Deceleration
Option "AdaptiveDeceleration" "2"
Deceleration # linear (mouse speed reduction)
Option "ConstantDeceleration" "2"

Option "AccelerationProfile" "-1"
Option "AccelerationScheme" "none"
Option "Resolution" "1600"
Option "samplerate" "1000"
Option "ExpectedRate" "1000"
Option "SendCoreEvents" "true"

EndSection

But sometimes it can feel as if they had stayed still accelerating.
Because sometimes too fast and sometimes slow.

Avails itself of all thank you in advance ...





looks solved
testing
Here:

Section "InputClass"
Identifier "generic mouse"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
Option "SendCoreEvents" "true"
Option "Buttons" "7"
Option "ButtonMapping" "1 2 3 4 5 8 9 6 7"
Option "AccelerationProfile" "-1"
Option "AccelerationScheme" "none"
Option "Resolution" "1600"
Option "SampleRate" "1000"
Option "ExpectedRate" "1000"
Option "SendCoreEvents" "true"
Option "AccelerationNumerator" "1"
Option "AccelerationDenominator" "1"
Option "AccelerationThreshold" "0"
EndSection

[email protected] ~ $ xset q | grep accel
acceleration: 1/1 threshold: 0

[email protected] ~ $ xset q | grep -A 1 Pointer
Pointer Control:
acceleration: 1/1 threshold: 0
Last edited by Raklap88 on Sun Jan 29, 2012 15:53, edited 1 time in total.
Raklap88
Baby Hen
 
Posts: 3
Joined: Thu Nov 03, 2011 18:51

Re: Mouse accel off help......

Postby wolfden » Sat Jan 14, 2012 17:22

try command

xset m 0 0
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Mouse accel off help......

Postby Raklap88 » Sat Jan 14, 2012 20:12

Hi, thanks but I know my help.
The xset m 0 0 at the same is the case.
But perhaps a little better in the xset m 1 1 but none of the real as something that ought to windovsnál mouseaccel.reg


How to improve the accuracy of the mouse pointing off linux?


Updated

Meoldva aprobléma all settings was good not only to be in plain xconfig 8)

Even be here: :lol:


etc/x11/xorg.d /

I did so and perfect

2 functions as a file

1: Here it is: create a config file and name it : 50-mouse-acceleration. conf

Section "Input Class"
Identifier "Generic Mouse"
Following the set # 1 to a 0 to disable acceleration respectively.
Option "AccelerationNumerator" "1​​"
Option "AccelerationDenominator" "1​​"
Option "AccelerationThreshold", "1"
Option "AccelerationProfile" "-1"
Option "AccelerationScheme" "none"


2 :File : Name: 50-mouse Deceleration. Conf

Section "Input Class"
Identifier "Generic Mouse"
# Some curved Deceleration
Option "AdaptiveDeceleration" "2"
Deceleration # linear (mouse speed reduction)
Option "ConstantDeceleration" "2"
EndSection
But sometimes you forget the system is at a good jentkezek back and I do not know why this is.




script format:

xset m 1 1
#You can change 5 by any value, even fractions (5/2) but keep 1 as this is the acceleration.
#xset m 5 1 is known to be a good value, but if it doesn't work you can try xset m 1 0
#"xset m default" resets the default configuration.
# Add your xset command to ~/.xinitrc to get your desired mouse speed when X starts.
# Or to launch at startup you can create a shortcut in a file ~/.config/autostart/nomouseaccel.desktop with the following content :

#!/usr/bin/env xdg-open
[Desktop Entry]
Encoding=UTF-8
Type=Application
Name=disable_mouse_acceleration
Comment=disable mouse acceleration
Exec=xset m 1 1
StartupNotify=false
Terminal=false
Hidden=false


#Another alternative if xset doesn't work at all, you can directly use the X server :
X -a 1 :0

#Be careful, some desktop environment reset the acceleration periodically or at each reboot or each time a software is launched (eg: KDE or Gnome), so you should either look the doc for these desktop environment and disable acceleration on those or use a Cron job to remove acceleration each minute.
Raklap88
Baby Hen
 
Posts: 3
Joined: Thu Nov 03, 2011 18:51


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest

cron