troubles with latest updates [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

troubles with latest updates [Solved]

Postby ursusca » Sat Jan 07, 2012 5:45

Hello All,

I am having a problem with updates. I'm trying to update my system but I'm getting the following messages:
Code: Select all
# equo update
>>  @@ Repositories synchronization ...
>>   # Sabayon Linux Official Repository
>>   # Repository URL: http://pkg.sabayon.org/standard/sabayonlinux.org/database/amd64/5
>>   # Repository local path: /var/lib/entropy/client/database/amd64/sabayonlinux.org/standard/amd64/5
>>   # Repository API: 3
>>      Attention: repository is already up to date.
>>  @@  Notice board: sabayonlinux.org
>>     [0] [Tue, 08 Nov 2011 08:53:31 +0000] Title: sabayonlinux.org repo accidentally enabled for sabayon-weekly users


When I'm using a graphical interface:

Code: Select all
If you are using the "sabayon-weekly" repository (AND ONLY IF),
please go ahead reading.
If you have troubles with latest updates and found That
you now have two repositories configured and enabled by
default. Can you restore the old (and expected) configuration
by removing / etc / entropy / repositories.conf.d / entropy_sabayonlinux.org
file (save it to a safer location first). Our apologies.


The /etc/entropy/repositories.conf.d / directory is empty
Code: Select all
# ls -la repositories.conf.d/
total 8
drwxr-xr-x 2 root root    4096 Jan  7 08:33 .
drwxrwxr-x 8 root entropy 4096 Jan  7 08:29 ..


Any idea how to fix the problem?
Last edited by ursusca on Mon Jan 09, 2012 5:19, edited 1 time in total.
You deserve free software!
ursusca
Baby Hen
 
Posts: 7
Joined: Thu Aug 07, 2008 22:49
Location: Toronto, ON, Canada

Re: troubles with latest updates

Postby batvink » Sat Jan 07, 2012 10:37

hello,

It seems that you have the sabayonlinux.org repository,
so you can ignore the "Sabayon-weekly" message of sulfur/magneto.

At the commandline, as root,
can you try the following:
Code: Select all
equo update --force

and:
Code: Select all
equo upgrade --ask

Try if you can install a package:
Code: Select all
equo install app-misc/sl

it's a tiny CLI-program, which corrects your miss typing.

if that won't work, try to reinstall Entropy:
1. Sync the sabayon overlay:
Code: Select all
layman -s sabayon

OR simply add the overlay in case you didn’t have it yet
Code: Select all
layman -a sabayon

2. Install Entropy directly from the overlay:
Code: Select all
emerge entropy equo --nodeps

3. Inform Entropy about the changes you made:
Code: Select all
equo rescue spmsync

5. Reinstall Entropy with Entropy
Code: Select all
equo update && equo install entropy equo
User avatar
batvink
Old Dear Hen
 
Posts: 495
Joined: Sun Oct 28, 2007 11:44
Location: the netherlands

Re: troubles with latest updates

Postby svantoviit » Sat Jan 07, 2012 13:11

Little bit off topic...

You can read the notice board with equo too, like this:
Code: Select all
equo notice [repo]

In my case:
Code: Select all
equo notice sabayon-weekly
>> [0] [Tue, 08 Nov 2011 08:53:31 +0000] Title: sabayonlinux.org repo accidentally enabled for sabayon-weekly users
>> [-1] Exit
Choose one by typing its identifier: 0
>> [0] [Tue, 08 Nov 2011 08:53:31 +0000] Title: sabayonlinux.org repo accidentally enabled for sabayon-weekly users
>>    Content: If you are using the "sabayon-weekly" repository (AND ONLY IF),
please go ahead reading.
If you have troubles with latest updates and found that
you now have two repositories configured and enabled by
default. You can restore the old (and expected) configuration
by removing /etc/entropy/repositories.conf.d/entropy_sabayonlinux.org
file (save it to a safer location first). Our apologies.
>>    Link: https://forum.sabayon.org/viewtopic.php?f=76&t=25776
Press Enter to continue:
svantoviit
Old Dear Hen
 
Posts: 646
Joined: Sun Feb 28, 2010 17:55

Re: troubles with latest updates

Postby ursusca » Sun Jan 08, 2012 3:12

Thank you for your help guys,

It seems that you have the sabayonlinux.org repository,
so you can ignore the "Sabayon-weekly" message of sulfur/magneto.

Maybe I should just ignore it but I think that I have some problem in updating. My kernel version is 3.0.0 and my Firefox version is 8.0.

I've run:
Code: Select all
equo update --force && equo upgrade --ask

and installed app-misc/sl

I can't reinstall Entrophy:
Code: Select all
# layman -a sabayon

 * Adding overlay,...
 * Adding repository "sabayon" failed!

 * CLI: Errors occured processing action add
 * Adding repository "sabayon" failed!


I thought server might be too busy but I tried many times today.

Any ideas?
You deserve free software!
ursusca
Baby Hen
 
Posts: 7
Joined: Thu Aug 07, 2008 22:49
Location: Toronto, ON, Canada

Re: troubles with latest updates

Postby svantoviit » Sun Jan 08, 2012 11:57

mvau2003 wrote:I think that I have some problem in updating...
I don't think so... the devs just took holidays, it was Christmas and New Year ;)

mvau2003 wrote:My kernel version is 3.0.0
You have to upgrade the kernel manually, it doesn't get upgraded automatically!
Use:
Code: Select all
kernel-switcher switch <kernel-you-want-to-use>


mvau2003 wrote:...my Firefox version is 8.0
Yes, that's the most recent version in standard repos, see https://packages.sabayon.org/quicksearch?q=firefox&x=0&y=0, remember limbo is just for testing.


mvau2003 wrote:
Code: Select all
 * Adding repository "sabayon" failed!
Probably you need to install dev-vcs/git, then try again.
svantoviit
Old Dear Hen
 
Posts: 646
Joined: Sun Feb 28, 2010 17:55

Re: troubles with latest updates

Postby ursusca » Mon Jan 09, 2012 5:19

Thank you for clarifying, svantoviit. I've reinstalled the entropy and my Virtualbox was upgraded from 4.1.6 to 4.1.8 and some other packages were upgraded either. I've upgraded my kernel manually.

I've decided to switch to Sabayon from Open Suse. My main system is Gentoo but so far I really like Sabayon.
You deserve free software!
ursusca
Baby Hen
 
Posts: 7
Joined: Thu Aug 07, 2008 22:49
Location: Toronto, ON, Canada


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest