can't see loaded module in lsmod [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Re: can't see loaded module in lsmod

Postby Fitzcarraldo » Sun Jan 01, 2012 22:57

coudy wrote:I have other issue. I can't see aacraid module version, because modinfo aacraid show, no module found.

Because, as I mentioned previously, the aacraid driver you are using is in-kernel, not a kernel module. There is no module.

According to the Adaptec Linux and Open Source Blog:

An updated Linux driver, version 1.1.7-28000, was submitted to for inclusion into the upstream kernel. It was officially included with the release of the 2.6.39 kernel ( ... Log-2.6.39).

Any Linux Distribution based on kernel 2.6.39 or greater should contain this updated driver and inbox (or in kernel) driver support should be available for Series 6 Adaptec controllers.

See also the official kernel text regarding the in-kernel aacraid driver: Documentation/scsi/aacraid.txt.

So I expect you are using version 1.1.7-28000 of the aacraid driver, given that the current version of the kernel supplied with SL is version 3.1.0.

As you are not getting the performance you expect, and as this is a very manufacturer-specific area, I think your best bet would be to contact Adaptec via the Adaptec Linux Blog or the general Adaptec support page.
User avatar
Sagely Hen
Posts: 7992
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: can't see loaded module in lsmod [Solved] partially

Postby coudy » Mon Jan 02, 2012 9:14

Thank You for your help and time
I'm running Sabayon 7 on Intel Quad Core Q8300, 4GB Ram, ATI HD4670
Linux sabayon 3.1.0-sabayon #1 SMP Wed Nov 30 10:37:12 UTC 2011 x86_64 Intel(R) Core(TM)2 Quad CPU Q8300 @ 2.50GHz GenuineIntel GNU/Linux
Baby Hen
Posts: 13
Joined: Sat Dec 31, 2011 15:44


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest