Gnome3 + Sabayon = Shaking Desktop [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Gnome3 + Sabayon = Shaking Desktop [Solved]

Postby SebMaus » Sun Dec 18, 2011 14:58

Hello everybody,

I've installed Sabayon + Gnome on my ThinkPad T510.
The Problem is everytime i am going on activities on the left upper corner my complete screen is "shaking".
I've also tryed xfce - there is no Problem.

On Google is only Information that this Problem exitsts also on Fedora - but no resolution.

What i have done so far:
-Reinstalled the system
-deleted xorg.conf
-(re)installed ati-drivers (sabayon)

Any suggestions?

Regards,
Sebastian
Last edited by SebMaus on Tue Jan 03, 2012 23:08, edited 1 time in total.
SebMaus
Baby Hen
 
Posts: 6
Joined: Sun Dec 18, 2011 14:52

Re: Gnome3 + Sabayon = Shaking Desktop

Postby micia » Sun Dec 18, 2011 19:05

Hi, welcome to the Sabayon forums,
the problem is a known (for a long time) and reported bug with AMD proprietary drivers, the issue exists in any Linux distrubution, it can only be solved in 2 ways:
1) using GNOME fallback
2) using open source ATI drivers
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Gnome3 + Sabayon = Shaking Desktop

Postby SebMaus » Tue Dec 20, 2011 17:17

After a lot of trying and reading i have installed the Radeon OpenSource driver.

It seems to be working.
But when i click on one of the Icons in the upper right (Volume Control as Example) the screen fade to black and after 2 trys xdm dies with an error "I should inform my system administrator"
SebMaus
Baby Hen
 
Posts: 6
Joined: Sun Dec 18, 2011 14:52

Re: Gnome3 + Sabayon = Shaking Desktop

Postby micia » Tue Dec 20, 2011 18:24

How did you setup your open source driver?
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Gnome3 + Sabayon = Shaking Desktop

Postby SebMaus » Wed Dec 21, 2011 9:32

I have done like described here:

http://joostruis.wordpress.com/2011/01/ ... -catalyst/

Here are some Informations about my Computer:

Code: Select all
ronb010-sabayon sebastian # eselect opengl list
Available OpenGL implementations:
  [1]   xorg-x11 *


Code: Select all
ronb010-sabayon sebastian # cat /etc/X11/xorg.conf

Section "Module"
    SubSection  "extmod"
       Option    "omit xfree86-dga"
    EndSubSection
    Load    "i2c"
    Load    "ddc"
    Load    "vbe"
    Load    "dri"
    Load    "glx"
    Load    "synaptics"
EndSection

Section "ServerFlags"
     Option    "AllowMouseOpenFail"    "true"
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    VertRefresh    43 - 60
    HorizSync      28 - 80
EndSection


Section "Device"

    Identifier  "SabayonVga0"
    Driver      "ati"
    #BusID    "PCI:01:00"
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
    # UseEvents is causing segmentation faults with
    # NVIDIA 6xxx, 7xxx and >=275.xx.xx drivers
    #Option "UseEvents" "True"
    Option "LogoPath" "/usr/share/backgrounds/sabayonlinux-nvidia.png"

EndSection
   


Section "Screen"

    Identifier    "Screen 0"
    Device        "SabayonVga0"
    Monitor       "Generic Monitor"
    #Option       "AddARGBGLXVisuals" "true"

    DefaultDepth 24

    SubSection "Display"
        Depth      8
        ViewPort   0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           16
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           24
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

EndSection


Section "DRI"
    Mode 0666
EndSection

Section "ServerLayout"
    Identifier   "Main Layout"
    Screen 0    "Screen 0"
EndSection

Section "Extensions"
   #Option "Composite" "Enable"
EndSection


Code: Select all
cat /etc/default/sabayon-grub
# this file has been added by the Anaconda Installer
# containing default installer bootloader arguments.
# DO NOT EDIT NOR REMOVE THIS FILE DIRECTLY !!!
GRUB_CMDLINE_LINUX="${GRUB_CMDLINE_LINUX} init=/linuxrc ,theme:sabayon quiet domdadm resume=swap:/dev/mapper/vg_ronb010sabayo-lv_swap real_resume=/dev/mapper/vg_ronb010sabayo-lv_swap dolvm root=/dev/mapper/vg_ronb010sabayo-lv_root docrypt"


Code: Select all
ronb010-sabayon sebastian # cat /etc/default/grub
# /etc/default/grub
# If you change this file, run 'grub-mkconfig -o /boot/grub/grub.cfg' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=saved
GRUB_DISTRIBUTOR="Sabayon"
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISABLE_LINUX_UUID=true

# Add your extra parameters here below
# Dear user, put your boot flags here ;-)
GRUB_CMDLINE_LINUX_DEFAULT="radeon.modeset=1"
# ATTENTION ATTENTION ATTENTION
# DO NOT EDIT THIS MANUALLY NOR SET IT TO EMPTY IF IT'S ALREADY FILLED WITH
# SOMETHING (DONE BY THE INSTALLER). REALLY, DON'T !
GRUB_CMDLINE_LINUX=""
# ATTENTION ATTENTION ATTENTION

# Uncomment to disable graphical terminal (grub-pc only)
# GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1024x768

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entrys
# GRUB_DISABLE_LINUX_RECOVERY="false"

# Default wallpaper image path
GRUB_WALLPAPER="/boot/grub/default-splash.png"

# Boot menu option normal color
GRUB_COLOR_NORMAL="white/black"

# Boot menu option "highlight" color
GRUB_COLOR_HIGHLIGHT="magenta/black"

if [ -f "/etc/default/sabayon-grub" ]; then
   # this file is placed by the Sabayon Installer and contains
   # custom GRUB_CMDLINE_LINUX parameters created at install
   # time.
   source /etc/default/sabayon-grub
fi

# DO NOT REMOVE THIS IF YOUR GRUB_CMDLINE_LINUX IS EMPTY (BACKWARD COMPAT)
if [ -z "${GRUB_CMDLINE_LINUX}" ]; then
   if [ ! -e "/proc/cmdline" ]; then
      echo "ATTENTION ATTENTION ATTENTION" >&2
      echo "GRUB_CMDLINE_LINUX is not set inside /etc/default/grub" >&2
      echo "  cannot generate a bootable configuration." >&2
   else
      echo "ATTENTION ATTENTION ATTENTION" >&2
      echo "GRUB_CMDLINE_LINUX is not set inside /etc/default/grub" >&2
      echo "  grub is going to use your /proc/cmdline content" >&2
      GRUB_CMDLINE_LINUX="`cat /proc/cmdline | sed -e 's#BOOT_IMAGE=.* ro ##g'`"
   fi
fi
SebMaus
Baby Hen
 
Posts: 6
Joined: Sun Dec 18, 2011 14:52

Re: Gnome3 + Sabayon = Shaking Desktop

Postby micia » Wed Dec 21, 2011 15:01

Have you added "radeon" to your /etc/conf.d/modules?
Adding to the end of that file:
Code: Select all
modules="radeon"
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Gnome3 + Sabayon = Shaking Desktop

Postby SebMaus » Wed Dec 21, 2011 17:02

Yeah i have. I will make a picture of the Error - maybe it helps.

Code: Select all
ronb010-sabayon sebastian # cat /etc/conf.d/modules
# You can define a list modules for a specific kernel version,
# a released kernel version, a main kernel version or just a list.
#modules_2_6_23_gentoo_r5="ieee1394 ohci1394"
#modules_2_6_23="tun ieee1394"
#modules_2_6="tun"
#modules="ohci1394"

# You can give modules a different name when they load - the new name
# will also be used to pick arguments below.
#modules="dummy:dummy1"

# Give the modules some arguments if needed, per version if necessary.
#module_ieee1394_args="debug"
#module_ieee1394_args_2_6_23_gentoo_r5="ieee1394 ohci1394"
#module_ieee1394_args_2_6_23="tun ieee1394"
#module_ieee1394_args_2_6="tun"

# You should consult your kernel documentation and configuration
# for a list of modules and their options.
modules="radeon"

Edit:/

Here the Picture what happens if i klick on one of the Buttons (Bluethooth, Network, Volume)

Image

And this are the bad Buttons.
Image
If i click them once only my Desktop disappers and all Programs close but the Desktops reappiers from itself. The second Time the Message from above is seen.
SebMaus
Baby Hen
 
Posts: 6
Joined: Sun Dec 18, 2011 14:52

Re: Gnome3 + Sabayon = Shaking Desktop

Postby micia » Sat Dec 24, 2011 10:50

Sorry for the delay, I have been a bit busy lately :)

Can you post the output from:
Code: Select all
eselect mesa list


By the way, merry Christmas :mrgreen:
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Gnome3 + Sabayon = Shaking Desktop

Postby SebMaus » Sun Dec 25, 2011 21:38

Merry Christmas too ;)

Here ist the output:
Code: Select all
ronb010-sabayon sebastian # eselect mesa list
64bit i915 (Intel 915, 945)
  [1]   classic *
  [2]   gallium
64bit i965 (Intel 965, G/Q3x, G/Q4x)
  [1]   classic *
  [2]   gallium
64bit r300 (Radeon R300-R500)
  [1]   classic
  [2]   gallium *
64bit r600 (Radeon R600-R700, Evergreen, Northern Islands)
  [1]   classic *
  [2]   gallium
64bit sw (Software renderer)
  [1]   classic
  [2]   gallium *
32bit i915 (Intel 915, 945)
  [1]   classic *
  [2]   gallium
32bit i965 (Intel 965, G/Q3x, G/Q4x)
  [1]   classic *
  [2]   gallium
32bit r300 (Radeon R300-R500)
  [1]   classic
  [2]   gallium *
32bit r600 (Radeon R600-R700, Evergreen, Northern Islands)
  [1]   classic *
  [2]   gallium
32bit sw (Software renderer)
  [1]   classic
  [2]   gallium *
SebMaus
Baby Hen
 
Posts: 6
Joined: Sun Dec 18, 2011 14:52

Re: Gnome3 + Sabayon = Shaking Desktop

Postby micia » Tue Dec 27, 2011 0:47

Turn each entry to "gallium", especially the r600 one:
(as root)
Code: Select all
eselect mesa set r600 gallium


then reboot, I hope this can help you.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Next

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 2 guests