iPhone 3GS- What do I need? [Solved]

Discussions Regarding Software

Moderator: Moderators

Post Reply
Growing Hen
Posts: 152
Joined: Thu Aug 02, 2007 12:23

iPhone 3GS- What do I need? [Solved]

Post by greendave8 » Mon Dec 19, 2011 22:41

Hi All,

What programmes/software do I need to make an iPhone 3gs work in Sabayon? At the moment it shows up ONLY in Amarok, but the tracks are not viewable, nor video files....

I have kernel 3.1 and kde 4.7.4

Or am I wasting my time?

Thanks in anticipation...

Last edited by greendave8 on Tue Feb 07, 2012 9:19, edited 1 time in total.

Sagely Hen
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: iPhone 3GS- What do I need?

Post by micia » Mon Dec 19, 2011 23:20

Changing the topic title not to use caps lock and multilple question marks. Please write topic titles without abusing of capital letters and question or exclamation mark, since it will not bring more attention to your topic and it is considered impolite.

Advanced Hen
Posts: 208
Joined: Wed Dec 13, 2006 22:25
Location: Cincinnati, OH

Re: iPhone 3GS- What do I need?

Post by cmost » Fri Dec 23, 2011 18:55

First, you should know that syncing your iPhone is supported by both the Gnome and KDE desktops. In KDE 4.7.x, all things iPhone are handled most succinctly by Amarok. And you're in luck as the latest and greatest Amarok v2.5.x is now available in the Limbo repository! In order to get it to work with your iPhone, make sure you have the following dependencies installed, make note of the ones that support the iPod/iPhone:

ifuse (optional) - support for Apple iPod Touch and iPhone
libgpod (optional) - support for Apple iPod audio devices
libmtp (optional) - support for portable media devices
libmygpo-qt (optional) - gpodder.net Internet Service for syncing podcasts
loudmouth (optional) - backend needed by mp3tunes for syncing

Once you have Amarok 2.5 and it's required iPod/iPhone dependencies installed, you should be able to sync your iPhone in KDE.

A common problem, which you seem to experience is that Amarok doesn't show any iPhone files.

Starting from the iPod classic and Touch era, the iPods use a method to check the consistency of the database with an algorithm called SHA1. To either prevent 3rd party apps to manipulate your iPod or to have a reliable database, the iPod checks the data of the db and could not show the tracks you have synced. If you can add tracks with iTunes but not with gtkpod, this may be happening.

Upgrading to at least libgpod 0.6.0 may solve your problems. Otherwise, have a look at the Gtkpod wiki or follow these steps:

Mount your iPod.
Open a terminal and type in: "sudo lsusb -v | grep -i Serial" without the quotes. Then you will see a 16-character-long hash. Copy it to the clipboard.
Fire up a text editor, like Kate, Kwrite, vi, nano.
Type in: FirewireGuid: 0x...
... and paste that hash of step 2 (do not omit the 0x).
Save the file with the name SysInfo in the iPod_Control/Device folder under your iPod mount point.

For example, a /media/ipod/iPod_control/Device/SysInfo file can look like this:

Code: Select all

ModelNumStr: xB029
FirewireGuid: 0x000A27001301221F

Good luck!
AMD Phenom II 64 X6 1090T Black Edition
8192 MB DDR2 RAM
nVidia GeForce GTX 660 w 2048 MB DDR5
Sabayon 2014.x 64 Bit KDE
"Better to remain silent and be thought a fool than to speak out and remove all doubt." -- Abraham Lincoln

Post Reply