NVidia HDA sound channels haywire after upgrade. [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

NVidia HDA sound channels haywire after upgrade. [Solved]

Postby BoeroBoy » Mon Nov 21, 2011 2:53

Hi I've been keeping pretty recent with entropy lately but since the last time I did it, my sound has been crazy. VLC DVDs play with channels off. I have an analog 2.1 system that has been working great until recently. Dialog is really quiet only from the right channel and music/sound are really loud, particularly from the left channel. One DVD I tried had an optional 2 channel stereo audio track that made the problem go away.

VLC's [Audio->Audio Device] menu is disabled. When I open Kmix, it shows all my audio channels but also pops up a dialog that says several of my audio devices are no longer found and it would like to remove them. Whether I click yes or no, they're removed anyway.

...WTH? Now my video is choppy too. Something is seriously messed up and I'm just going to try another equo update hoping my problems go away...

Anyway has anybody had any problems lately with sound channels getting crossed by entropy? It would be nice if I could reset my settings to default somehow...
Last edited by BoeroBoy on Mon Dec 19, 2011 17:18, edited 1 time in total.
User avatar
BoeroBoy
Simple Hen
 
Posts: 68
Joined: Fri Feb 23, 2007 20:25

Re: NVidia HDA sound channels haywire after upgrade.

Postby BoeroBoy » Tue Nov 22, 2011 22:27

Even after a full upgrade plus kernel 3.1.0-r1, no update on this problem...
User avatar
BoeroBoy
Simple Hen
 
Posts: 68
Joined: Fri Feb 23, 2007 20:25

Re: NVidia HDA sound channels haywire after upgrade.

Postby genfool » Tue Nov 22, 2011 23:35

sounds as simple as opening a terminal and as user enter command alsamixer
Then use f6 to select sound card, be sure no columns are muted... will have a (mm) under each column to show it is muted.
Post back if this does not work.
genfool
Technological Hen
 
Posts: 342
Joined: Fri Apr 03, 2009 17:56
Location: Albuquerque, NM

Re: NVidia HDA sound channels haywire after upgrade.

Postby BoeroBoy » Tue Nov 22, 2011 23:41

No dice. Thanks for the suggestion. One channel was down but it did not correct the muffled dialog. Just wish every DVD had a 2 channel stereo soundtrack.
User avatar
BoeroBoy
Simple Hen
 
Posts: 68
Joined: Fri Feb 23, 2007 20:25

Re: NVidia HDA sound channels haywire after upgrade.

Postby carmey » Sun Dec 04, 2011 19:09

i solved exactly the same probrem by installing the drivers from the nvidia website
you have to shut down the x server to install the drivers, and because it builds a kernel module, you have to reinstall them every time you upgrade your kernel. you need to have entropy download the kernel source, and the kernel & source must must be the same version

(my card is a gtx 550 ti, and i am using the latest 290.10 drivers from nvidia)
carmey
Baby Hen
 
Posts: 2
Joined: Sun Dec 04, 2011 19:00

Re: NVidia HDA sound channels haywire after upgrade.

Postby BoeroBoy » Mon Dec 19, 2011 17:17

Thanks for the tip. I think I finally resolved this problem by forcing off the Dolby surround option in settings. I think I tried that before but it didn't work. We'll see if this works for all DVDs.
User avatar
BoeroBoy
Simple Hen
 
Posts: 68
Joined: Fri Feb 23, 2007 20:25


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest