console boot: need to run startx TWICE to get E17? [Solved]

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Re: console boot: now need to run startx TWICE to get E17?

Postby joe3 » Wed Dec 07, 2011 1:58

BHReach wrote:There is a way to load modules using /etc/modprobe.d, I don't recall the details but this message thread discusses your problem:

http://forums.gentoo.org/viewtopic-t-895556-start-0.html


Seems like it's supposedly a two part process:

(1)put a file in /etc.modprobe.d named radeon.conf containing:
options radeon modeset=1

(2)add modules="radeon" to /etc/conf.d/modules

I note there existed a modules="fbcon" line there.
When I tried simply adding a separate line with modules="radeon" leaving both lines intact, the only thing that seemed to change was that when the startup messages said that consolefont failed to start, I noticed another error line just before it "putfont: KDFONTOP: Invalid argument"
Which error I also saw if I tried to use setfont prior to the first startx command... ??

Will try again without the fbcon line. A little lator... My lady is calling for some attention right now... bye
joe3
Advanced Hen
 
Posts: 200
Joined: Sun May 06, 2007 21:28

Re: console boot: now need to run startx TWICE to get E17?

Postby joe3 » Wed Dec 07, 2011 4:52

OK so that did make a difference... In my case it was a 3 step process. {though it's possible that only one or two of them were necessary)...

(1)put a file in /etc.modprobe.d named radeon.conf containing:
options radeon modeset=1

*But it's possible that once step 3 is in place, having "radeon.modeset=1" in the kernel's command line options (grub) might have worked after all

(2)add modules="radeon" to /etc/conf.d/modules
* though for all I know it might have been pulled in automatically because of step 1 {or the grub equivalent) if only I'd already done step 3... (it used to work until recently with only the grub option...)

(3)When I took the line:
modules="fbcon"
OUT of my /etc/conf.d/modules file, it suddenly started working properly...

That is both, setting the font with consolefont, & startx working the first time I call it...
It looks to me like the fbcon module must have been interfering somehow.


I don't know why, however, the focus no longer automatically returns to tty1 after it displays the "initializing the kernel {spash?} screen... But I can deal with having to use an <alt>+<Fkey> binding to pull up the first console login screen.

So from my point of view, I'll be marking this one as solved...
joe3
Advanced Hen
 
Posts: 200
Joined: Sun May 06, 2007 21:28

Previous

Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 0 guests