console boot: need to run startx TWICE to get E17? [Solved]

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

console boot: need to run startx TWICE to get E17? [Solved]

Postby joe3 » Fri Dec 02, 2011 17:33

Hello I'm a multi-linux multi-booter who always boots to console and then when/if I'm ready for the gui to start I use startx (almost always with my ~/.xinitrc pointing at E17...) Any way; Lately, when running Sabayon on my Gateway laptop (MT6451 Notebook PC) which has AMD Turion 64x2 processors, I've got to call startx twice to get X (E17) ??? This didn't used to happen, and still doesn't with the other three distro's I've got installed on it.

When startx runs the first time I wind up looking at a blue screen that says "Sabayon" and something about "initializing the kernel"... But by typing the appropriate <Alt>+<Fkey> combination I can return to the tty I ran startx from. Except that the font size is now much smaller than my eyes are comfortable with <sigh> Though that doesn't really matter since this {tiny font garbage} don't happen until I want the gui anyway, so it's easy enough to just repeat the startx command and then poof I'm in E17 where I decide how big a font is used in the Konsole terminal windows. In fact I only mention it because: it's hard telling {not knowing} what facts actually are significant to the guys with smarter brains than mine...
------------------------------
==== my ~/.xinitrc ===========
------------------------------
Code: Select all
xdaliclock -12 -noseconds -builtin1 &
yakuake &
konsole --workdir ~/STUFF/ShuttleStuff --name F12crap --profile BlackYellow -e 'medosumc' &
konsole --workdir ~/mail --name F2alpine  --profile BlackGray -e alpine &
synclient TouchpadOff=2
/usr/bin/enlightenment_start


------------------------------
=screen capture on 1st startx=
------------------------------
Code: Select all
X.Org X Server 1.10.4
Release Date: 2011-08-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.38-sabayon x86_64 Gentoo
Current Operating System: Linux Esabayonish 2.6.39-sabayon #1 SMP Wed Aug 3 22:0
9:31 UTC 2011 x86_64
Kernel command line: ro  init=/linuxrc  radeon.modeset=1 nox gfxpayload=text con
sole=tty1 dokeymap keymap=us domdadm root=LABEL=Esaba_lap-6
Build Date: 30 September 2011  08:26:36PM

Current version of pixman: 0.24.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Dec  2 07:05:37 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] drm report modesetting isn't supported.
(EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
[dri] This chipset requires a kernel module version of 1.17.0,
[dri] but the kernel reports a version of 2.9.0.[dri] Make sure your module is loaded prior to starting X, and
[dri] that this driver was built with support for KMS.
[dri] Aborting.
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error



------------------------------
==============================
------------------------------
I'm thinking this line is likely the big clue here:

[dri] This chipset requires a kernel module version of 1.17.0,

But I'm not quite sure what to do about it. I'm hoping it doesn't mean I'm going to have to {first learn how} customize the kernel every time it gets upgraded from now on... Or maybe I'll just try putting this in my ~/.bashrc:

alias startx='/usr/bin/startx;/usr/bin/startx'

But even if that works, it'd be too much of a kludge, even for me...
There simply has to be a better solution.

Could somebody point me at a good how-to that might give me a clue?

--
joe3
Last edited by joe3 on Wed Dec 07, 2011 4:54, edited 1 time in total.
joe3
Advanced Hen
 
Posts: 200
Joined: Sun May 06, 2007 21:28


Re: console boot: now need to run startx TWICE to get E17?

Postby joe3 » Sat Dec 03, 2011 13:52

Thanks for the link BHReach , Im not using Sabayon at the moment so I'll have to look at it again when I can use it as a guide to running some of the listed diagnostic commands...

It does make some sense to me that this could be KMS related. Though I do already have "radeon.modeset=1" set in my kernel options... And I'm not so sure that any "missing firmware files" that would stop x from starting the first time wouldn't also stop it from running the second time I gave the command???

But I did notice that by the time I issue the second startx command (the one that works) my console font size has shrunk significantly... Historically I always used to keep my console fonts legible by way of the {now defunct} kernel option "vga=normal" Which I basically replaced with "gfxpayload=text" instead of learning how to explicitly set a LARGE console font in sabayon. I do have a dim memory of having had to install some large console font to my Arch Linux installation when they began using KMS...

Anyway, not knowing how gfxpayload=text actually works, {nor why it always stops working in the consoles after x starts, or evidently, even just "tries" to start} So I don't have a clue if it could be a factor...
I'll have to try booting without that option to see if it makes any difference. If it does, then I'll be looking for a how-to on properly setting a "huge" console font in Sabayon. Which might be a better method than using a kernel option that x blows away anyhow. Would you happen to know the URL of a how-to for that??

Thanks again!

--
joe3
joe3
Advanced Hen
 
Posts: 200
Joined: Sun May 06, 2007 21:28

Re: console boot: now need to run startx TWICE to get E17?

Postby BHReach » Sat Dec 03, 2011 16:32

https://sites.google.com/site/drunkvegetarian/computer/linux/consolefont

For Sabayon use equo instead of emerge.

Code: Select all
equo install terminus-font --ask
BHReach
Growing Hen
 
Posts: 193
Joined: Thu Jan 31, 2008 20:40

Re: console boot: now need to run startx TWICE to get E17?

Postby joe3 » Sun Dec 04, 2011 7:57

Thanks again for the link BHReach... This one really hit the spot, and was very easy to follow. And thanks for the equo/vs/emerge tip too {though I'd like to think I'd have tried equo first anyway [emerge makes me nervous]}

Anyway, I've now got a nice console font set up... And no BTW, booting without 'gfxpayload=text' didn't make any difference on the startx issue.

Which brings me back to the first link you posted to this thread.

I notice {now that I've had time to look closer} that your link indexes the part of the wiki article titled "Check if radeon-KMS is enabled before X is started" which section just about exactly describes my error message. It would make me think that radeon-KMS isn't so enabled except that I do already have "radeon.modeset=1" in my "kernel" command line options.

I note that much of the radeon-KMS wiki artical is written above my skill level. It's like the informative auto motive manual that tells you to use 10w30 oil without telling you where to put it, (I've seen idiots pouring motor oil in their radiator before {shudder}) In like manor that wiki advises "don't load radeonfb, uvesafb or vesafb module" But other than looking in my menu.lst file for those exact terms (which are not there BTW) I have no idea how to check that I'm not somehow loading them...

Though I can say that I've never customized my kernel. (wouldn't know how...) So unless an entropy managed Sabayon system would by default load one of those for a generic kernal, then logic tells me they weren't loaded. I only ever install anything to my sabayon via equo (with the sole exception that I followed explicit blow by blow instructions to emerge music on console with use flags that let it actualy recognise my *.wav music files).

That wiki article section titled "Check if your ddx and mesa-dri driver have KMS support" is also problematical for me. Again I don't know HOW to check. Though since this is Sabayon, not gentoo I'd expect that the default drivers from entropy would have KMS support??

That section of the wiki also says to: "check if you have fitting components of the Linux graphics driver stack"

And lists a few commands along with examles of the expected output. All of which do so Except lsof | grep ^Xorg | egrep '_drv.so|_dri.so' | egrep 'radeon' Which doesn't give any output what so ever...

In general though I'm not understanding how any of these issues would only stop the first instance of startx from succeeding in starting X while always the second instance of startx works, every time.

I don't know if it would be useful or not, but the last time I booted I ran startx, and when it failed I copied the "Xorg.0.log" file. ran startx again, and as soon as E17 was done loading I logged out of X and copied Xorg.0.log again. These logs can be found at:

http://pastebin.com/wsrvDwS0 xorg failed log

http://pastebin.com/1Ci1YSaW xorg worked log

But in any case, Thanks again!

--
Joe3
joe3
Advanced Hen
 
Posts: 200
Joined: Sun May 06, 2007 21:28

UPDATE:[!framebuffer??] run startx TWICE to get E17?

Postby joe3 » Sun Dec 04, 2011 15:28

Looks like I spoke too soon...
joe3 wrote:Anyway, I've now got a nice console font set up...

I should have rebooted to test that "consolefont would actually work. especially in light of the fact that:
https://sites.google.com/site/drunkvegetarian/computer/linux/consolefont wrote:First thing is that you need to make sure and have a framebuffer already setup and running. Consolefont will fail to start unless you do this first. If you already have a framebuffer setup, then don't worry about it.

But to tell you the truth, I wasn't sure how to tell if framebuffer was working, and I was {and still am} much more interested in solving the startx failure. Especially since, not knowing why the second startx attempt works, I have to assume that I'm depending on some fluke. And thus that some future "equo upgrade" might result in total startx failure... Last night I booted Sabayon on the laptop and proceeded to follow the rest of the consolefont how-to's instructions. Only this was AFTER starting X so I could use opera to view the how-to... I used <ctrl>+<alt>+<F2> to log in as root on tty2 where I installed the "terminus-font" package and tested the fonts with setfont, {found that any terminus font name ending in 24b would approximate what vga=normal used to do before KMS} So I put 'consolefont="ter-124b"' in /etc/conf.d/consolefont, and then ran "eselect rc add consolefont default" and assumed the font was installed... <sigh> But just before going to bed, I got around to rebooting the laptop just to test that I'd actually get ter-124b in the console's both before and after startx. But on the way in, as the verbose text of the boot process scrolled by on tty1, I happened to spot that consolefont failed to start... {whimper}

So now I wonder if a lack of framebuffer could cause the startx failure???

I did some googleing and it looks like I'd need to get into building my own kernel {shudder} (or at least custom modules) to get KMS compatible framebuffer working??? If I had the time and desire to do much of that, I might as well have installed gentoo instead of Sabayon. {sigh}

At this point I'm just hoping running startx TWICE will continue to work. I mean that as far as the console font issue goes, since it don't matter till after I call startx, I'm thinking of just using something like:
alias startx='/usr/bin/startx;setfont ter-124b.psf.gz'


--
Joe3
joe3
Advanced Hen
 
Posts: 200
Joined: Sun May 06, 2007 21:28

Re: console boot: now need to run startx TWICE to get E17?

Postby BHReach » Sun Dec 04, 2011 15:29

356. [ 116.456] (II) [KMS] drm report modesetting isn't supported.

356. [ 604.513] (II) [KMS] Kernel modesetting enabled.

The above lines are from your 2 files. Something enables modesetting between your 2 attempts. You do not need to recompile your kernel.

You can try this before startx:

Code: Select all
modprobe -r -v drm radeon    <--- Unload drm and radeon kernel-module (-r: remove, -v: verbose)
modprobe -v drm debug=1      <--- Additional for debugging DRM issues (maximum debug-level is 15)
modprobe -v radeon modeset=1 <--- Load radeon kernel-module with KMS support


It is from the previous radeon build link under troubleshooting.
BHReach
Growing Hen
 
Posts: 193
Joined: Thu Jan 31, 2008 20:40

Re: console boot: now need to run startx TWICE to get E17?

Postby BHReach » Sun Dec 04, 2011 17:24

If the consolefont did not stick on reboot maybe the eselect command did not work.

Code: Select all
rc-update show


Will show which daemons start and on which runlevel. See if consolefont is listed.

Also, make sure /etc/conf.d/consolefont has your selected font listed. Comment out the one that was originally there and add the one you want. If both are listed it may just use the 1st or last one listed.

Also, make sure the font you choose is in /usr/share/consolefonts, I have Sabayon 7 LXDE x86 booted up and the one you want is not listed there.
BHReach
Growing Hen
 
Posts: 193
Joined: Thu Jan 31, 2008 20:40

Re: console boot: now need to run startx TWICE to get E17?

Postby joe3 » Tue Dec 06, 2011 8:33

BHReach wrote: Something enables modesetting between your 2 attempts. You do not need to recompile your kernel.


Good!

You can try this before startx:

Code: Select all
modprobe -r -v drm radeon    <--- Unload drm and radeon kernel-module (-r: remove, -v: verbose)


Code: Select all
 ~
UnderTree=-> modprobe -r -v drm radeon
 ~
UnderTree=->


hmmnn wasn't very verbose??



modprobe -v drm debug=1 <--- Additional for debugging DRM issues (maximum debug-level is 15)



Code: Select all
 ~
UnderTree=-> modprobe -v drm debug=1
insmod /lib/modules/2.6.39-sabayon/kernel/drivers/gpu/drm/drm.ko debug=1
 ~
UnderTree=->


modprobe -v radeon modeset=1 <--- Load radeon kernel-module with KMS support


Code: Select all
 ~
UnderTree=-> modprobe -v radeon modeset=1
insmod /lib/modules/2.6.39-sabayon/kernel/drivers/i2c/algos/i2c-algo-bit.ko
insmod /lib/modules/2.6.39-sabayon/kernel/drivers/gpu/drm/drm_kms_helper.ko
insmod /lib/modules/2.6.39-sabayon/kernel/drivers/gpu/drm/ttm/ttm.ko
insmod /lib/modules/2.6.39-sabayon/kernel/drivers/gpu/drm/radeon/radeon.ko modes
et=1 modeset=1
 ~
UnderTree=->


OK so as soon as I hit enter on that, I got that blue Sabayon {splash?}
screen that I've been getting when startx fails... When I used
<alt>+<Fkey> to switch back to a tty, I'm seeing that annoying
small font again... I'm betting though, that startx will work on the
first attempt. (it's looking to me like the kernel command line
option: "radeon.modeset=1" simply isn't initializing radeon-KMS)

But before I test startx, I'm going to look at the consolefont
issue...

If the consolefont did not stick on reboot maybe the eselect command did not work.

Code: Select all
rc-update show


Will show which daemons start and on which runlevel. See if consolefont is listed.


Perhaps, but it said it was adding it to default...

Code: Select all
 ~
UnderTree=-> rc-update show
            alsasound |      default
         avahi-daemon |      default
             bootmisc | boot
          consolefont |      default
           consolekit | boot
         cpufrequtils |      default
                cupsd |      default
                 dbus | boot
                devfs |                                        sysinit
        device-mapper | boot
                dmesg |                                        sysinit
           fbcondecor | boot
                 fsck | boot
                  gpm | boot
             hostname | boot
              hotplug | boot
              hwclock | boot
              keymaps | boot
            killprocs |                        shutdown
                local |      default nonetwork
           localmount | boot
                  lvm | boot
                mdadm |      default
              modules | boot
             mount-ro |                        shutdown
                 mtab | boot
               net.lo | boot
             nfsmount |      default
               procfs | boot
                 root | boot
            savecache |                        shutdown
                 swap |      default
               sysctl | boot
            syslog-ng |      default
         termencoding | boot
                 udev |                                        sysinit
       udev-postmount |      default
                  ufw |      default
              urandom |      default
           vixie-cron |      default
                 wicd |      default
              x-setup | boot
                  xdm | boot
 ~
UnderTree=->



Also, make sure /etc/conf.d/consolefont has your selected font listed. Comment out the one that was originally there and add the one you want. If both are listed it may just use the 1st or last one listed.


Code: Select all
 ~
UnderTree=-> cat /etc/conf.d/consolefont
# consolefont specifies the default font that you'd like Linux to use on the
# console.  You can find a good selection of fonts in /usr/share/consolefonts;
# you shouldn't specify the trailing ".psf.gz", just the font name below.
# To use the default console font, comment out the CONSOLEFONT setting below.
# This setting is used by the /etc/init.d/consolefont script (NOTE: if you do
# not want to use it, run "rc-update del consolefont boot" as root).
# consolefont="default8x16"
consolefont="ter-124b"

# consoletranslation is the charset map file to use.  Leave commented to use
# the default one.  Have a look in /usr/share/consoletrans for a selection of
# map files you can use.
#consoletranslation="8859-1_to_uni"

# unicodemap is the unicode map file to use. Leave commented to use the
# default one. Have a look in /usr/share/unimaps for a selection of map files
# you can use.
#unicodemap="iso01"
 ~
UnderTree=->



Also, make sure the font you choose is in /usr/share/consolefonts, I have Sabayon 7 LXDE x86 booted up and the one you want is not listed there.



Code: Select all
 ~
UnderTree=-> ls /usr/share/consolefonts/*24b*
/usr/share/consolefonts/ter-124b.psf.gz  /usr/share/consolefonts/ter-d24b.psf.gz  /usr/share/consolefonts/ter-p24b.psf.gz
/usr/share/consolefonts/ter-224b.psf.gz  /usr/share/consolefonts/ter-g24b.psf.gz  /usr/share/consolefonts/ter-u24b.psf.gz
/usr/share/consolefonts/ter-724b.psf.gz  /usr/share/consolefonts/ter-i24b.psf.gz  /usr/share/consolefonts/ter-v24b.psf.gz
/usr/share/consolefonts/ter-924b.psf.gz  /usr/share/consolefonts/ter-k24b.psf.gz
/usr/share/consolefonts/ter-c24b.psf.gz  /usr/share/consolefonts/ter-m24b.psf.gz
 ~
UnderTree=->


I'm thinking I got them when I "equo install terminus-font --ask"...

I can't think of any reason why consolefont is failing, unless it's
framebuffer?

But at least the setfont method works...

And BTW I was right about startx working on the 1st try this time... I'll
have to figure out how to load the module without calling it on the kernel
command line... I'll have to look at that KMS how-to a little more.
joe3
Advanced Hen
 
Posts: 200
Joined: Sun May 06, 2007 21:28

Re: console boot: now need to run startx TWICE to get E17?

Postby BHReach » Tue Dec 06, 2011 10:44

There is a way to load modules using /etc/modprobe.d, I don't recall the details but this message thread discusses your problem:

http://forums.gentoo.org/viewtopic-t-895556-start-0.html
BHReach
Growing Hen
 
Posts: 193
Joined: Thu Jan 31, 2008 20:40

Next

Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron