Quit shipping nouveau with the kernel! [Solved]

Discussion in general that pertains to Sabayon Linux - Must Pertain to Sabayon Linux

Moderator: Moderators

Quit shipping nouveau with the kernel! [Solved]

Postby Gordon » Tue Sep 06, 2011 14:29

Seriously, stop it! It's starting to get really annoying now.

I ordered a new PC and specifically requested a nVidia graphics card because of the continuous problems with Radeon and now with every kernel update X comes to a grinding halt because of that blasted non-functional nouveau driver that interferes with the nVidia driver.
Last edited by Gordon on Wed Nov 30, 2011 21:02, edited 1 time in total.
Gordon
Simple Hen
 
Posts: 56
Joined: Tue Jul 20, 2010 8:22

Re: Quit shipping nouveau with the kernel!

Postby DHalens » Tue Sep 06, 2011 14:57

Maybe you're not updating the nvidia driver with the kernel? That driver tag must match the kernel in use.
Also, I wonder if you have x11-drivers/xf86-video-nouveau installed.
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: Quit shipping nouveau with the kernel!

Postby Gordon » Tue Sep 06, 2011 15:12

Nope, nouveau is not installed. And neither are sis, radeon, s3, via, intel and some other drivers that I have no clue about. The kernel modules are just there with every new kernel pushed by equo, even if I only select the kernel to be installed and verify in the progress view.
Gordon
Simple Hen
 
Posts: 56
Joined: Tue Jul 20, 2010 8:22

Re: Quit shipping nouveau with the kernel!

Postby Fitzcarraldo » Tue Sep 06, 2011 18:45

You have my sympathies: the nouveau module is a PITA. And welcome to binary distributions: one size fits all.

To stop the dreaded nouveau module making your life a misery, add the following line to the file /etc/modprobe.d/blacklist.conf:

Code: Select all
blacklist nouveau

then run the following command as root user in a Konsole/Terminal window, or VT (Ctrl-Alt-F1) if you don't have a GUI:

Code: Select all
update-modules

and reboot (therefore this only applies in the case of SL installed to the HDD).
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7985
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Quit shipping nouveau with the kernel!

Postby joost » Tue Sep 06, 2011 18:52

Never ran into this on any system, how weird.
:D

I guess its same thing as radeon && fglrx modules conflicting?
If so I wonder why I never had this problem.

You forgot to mention what kernel by the way.
joost
Sagely Hen
 
Posts: 2582
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Quit shipping nouveau with the kernel!

Postby Gordon » Tue Sep 06, 2011 23:15

It's a new system. Being familiar with Gentoo I thought it unwise to start off with my existing 5.2 install disk (it's practically impossible to get up to date with Gentoo if you've fallen back say a year or more) and downloaded a fresh copy of Sabayon 6 (I dislike that it includes a standard activated firewall BTW), so the first kernel revision introducing the problem would be 2.6.39-r-[something]. Next the 3.0.0 release and today the revision on 3.0.0.

The thing that puzzles me is that a kernel module gets installed even when the package that the module is supposed to belong to has been removed. I have every driver, as far as dependencies allow me to, removed and still see many of the corresponding drivers pop up in the /lib/modules directory. Why is that?

@Fitzcarraldo
Good hint about the blacklist option. Didn't know it existed and will most definitely apply it before the next kernel update. Much appreciated.
Gordon
Simple Hen
 
Posts: 56
Joined: Tue Jul 20, 2010 8:22

Re: Quit shipping nouveau with the kernel!

Postby Gordon » Thu Sep 22, 2011 18:09

joost wrote:Never ran into this on any system, how weird.
:D

I may have found the reason for that. I verified on my older system that was originally installed as version 5.2 and found that nouveau was in fact already included in the blacklist file. Not so on the fresh 6.0 install however.

So I'm guessing that means that version 6.0 was built from scratch and you forgot to apply the fixes for hardware issues that you already knew about. You should probably investigate what other old issues may have returned by starting over.
Gordon
Simple Hen
 
Posts: 56
Joined: Tue Jul 20, 2010 8:22

Re: Quit shipping nouveau with the kernel!

Postby raman » Fri Sep 23, 2011 12:55

good point :) +1 for Gordon :P
raman
Advanced Hen
 
Posts: 236
Joined: Mon Sep 06, 2010 17:18
Location: Poland

Re: Quit shipping nouveau with the kernel!

Postby res0r9lm2 » Fri Oct 28, 2011 21:39

I can say for a fact "blacklist nouveau" does exist in /etc/modprobe.d/blacklist.conf by default on Sabayon 6 xfce fresh install
res0r9lm2
Simple Hen
 
Posts: 44
Joined: Mon Oct 24, 2011 17:52

Re: Quit shipping nouveau with the kernel! [Solved]

Postby Gordon » Wed Nov 30, 2011 21:07

I guess it's fine now. The new 3.1 kernel boots just fine into graphic mode with the new blacklist. I noticed the blacklist nouveau and a bunch of other blacklist items was also included in a conf update I pulled in a while back.

Marked as solved.
Gordon
Simple Hen
 
Posts: 56
Joined: Tue Jul 20, 2010 8:22


Return to Sabayon Linux General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest