Kmix uses wrong sound card [Solved]

Discussions Regarding Software

Moderator: Moderators

Kmix uses wrong sound card [Solved]

Postby Izmo » Sat Nov 26, 2011 18:47

My problem is that kmix uses the worng sound card, and therefore I am unable to adjust the volume using it. I can hear sound, and I can even adjust the volume using alsamixer, but that's an ugly workaround.

My questions therefore are the following:
1) Is it possible to force kmix to use the correct sound card? How? I haven't been able to find any meaningful documentation on this.
2) If not - is it possible to disable the offending sound card in order to force kmix into using the correct one?

Before you answer the second question, I need to elaborate a bit on my setup. The sound card I want to use is the one integrated in the motherboard. The "offending" sound card is not a real sound card, but a HDMI controller on a Nvidia graphics card that is recognized as a sound card. This means that neither disabling the card from the BIOS, nor physically removing the sound card is an option. To make matters worse, both cards use the same module (snd_hda_intel) so blacklisting the module is not an option either.

Code: Select all
lspci | grep -i audio
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
02:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)


Code: Select all
cat /proc/asound/cards
 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfcdf0000 irq 16
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe97c000 irq 18


Code: Select all
cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_hda_intel


Any help would be much appreciated...
Last edited by Izmo on Sun Nov 27, 2011 8:41, edited 1 time in total.
Izmo
Baby Hen
 
Posts: 3
Joined: Sat Nov 26, 2011 18:29

Re: Kmix uses wrong sound card

Postby genfool » Sat Nov 26, 2011 23:25

Not sure if this helps, couple ideas.
If you open a terminal and as user run the command
Code: Select all
alsamixer

Then while in alsamixer f6 and select correct sound card ... does that help?

Another option could be to open root terminal and run
Code: Select all
alsaconf

select your sound card, complete the installation and then as user, run alsamixer again.
If any of the columns have a (mm) under them, means they are muted.
Use the arrow keys to select column and m key to unmute, + key to turn the volume up

Is possible that you may need to go to start button > system settings > multimedia > phonon and play with that some...
But try these and see if it works for you. Often it is front speakers in alsamixer that are turned down and adjusting the volume level is all I need.
genfool
Technological Hen
 
Posts: 342
Joined: Fri Apr 03, 2009 17:56
Location: Albuquerque, NM

Re: Kmix uses wrong sound card

Postby Izmo » Sun Nov 27, 2011 6:54

Thanks for your suggestion, but that's unfortunately not the problem I'm trying to solve. As I mentioned in my original post, I do get sound, and I can even adjust the volume with alsamixer (which quite correctly recognized both devices and picked the correct default). What I'm trying to do is get the convenience of being able to adjust the volume without opening a terminal, and running a command, by getting kmix to do what it's supposed to do.

The problem I'm having is specifically kmix related. Kmix has picked the wrong device as default, and there are no obvious ways of changing it. (And despite lots of googling, I haven't managed to find any non-obvious way either.)
Izmo
Baby Hen
 
Posts: 3
Joined: Sat Nov 26, 2011 18:29

Re: Kmix uses wrong sound card [Solved]

Postby Izmo » Sun Nov 27, 2011 8:39

Ok. Managed to get this working. Using the word "fix" might be something of a stretch since I still don't really know how to change the kmix device. This page suggested it can't be done manually, which IMHO is a mighty boneheaded design decision. https://help.ubuntu.com/community/Kmix

What I did do was the following:
Code: Select all
killall kmix
equo remove kmix --ask --configfiles --nodeps
emerge -av kmix


I don't know what precisely is the difference between the entropy-supplied kmix and the locally compiled one, but now kmix works as expected.
Izmo
Baby Hen
 
Posts: 3
Joined: Sat Nov 26, 2011 18:29


Return to Software in General

Who is online

Users browsing this forum: No registered users and 2 guests

cron