Cannot install/configure printer EPSON Stylus Photo R340

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Re: Cannot install/configure printer EPSON Stylus Photo R340

Postby vovim » Tue Nov 22, 2011 13:50

Svantoviit, I managed to get KDE working again by following the links that you provided. Thanks for that.

I managed to install the overlay O.K. I had to change the name of the ebuild from 1.0.2 to 1.1.0 as this was the name of the file in SRPMS on the avasys site. But it installed O.K. I then tried to add the printer using Hardware/Printer Configuration and it said that it was missing the cups filter /usr/lib/cups/filter/epson-escpr-wrapper so I looked and found that it was installed in /usr/libexec/cups/filter/epson-escpr-wrapper so I made a link to where the file actually was and then I could add the printer.
But it would not print a test page. So I tried deleting that printer and adding it through the CUPS Admin web page. it added O.K. (I used http://localhost:631/ipp/ as the connection string) but still would not print a test page.
So I enabled debug in CUPS and got the following :

D [22/Nov/2011:12:23:00 +0000] [Job 10] Calling FindDeviceById(printer)
D [22/Nov/2011:12:23:00 +0000] [Job 10] Failed to send: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
D [22/Nov/2011:12:23:00 +0000] [Job 10] Failed to get profile filename!
I [22/Nov/2011:12:23:00 +0000] [Job 10] no profiles specified in PPD
D [22/Nov/2011:12:23:00 +0000] [Job 10] Set job-printer-state-message to "no profiles specified in PPD", current level=INFO

So it looks like after all that it is a bad ppd file (no profiles specified in PPD). I have no idea what it is looking for with ColorManager and .service files.

If you can help further that would be great. But I don't know where to go from here.
Thanks for your help.
vovim
Baby Hen
 
Posts: 7
Joined: Thu Nov 17, 2011 20:27

Previous

Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests

cron