Cannot install/configure printer EPSON Stylus Photo R340

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Cannot install/configure printer EPSON Stylus Photo R340

Postby vovim » Sat Nov 19, 2011 16:46

I have tried to install/configure my printer using System Settings/Hardware/Printer Configuration and I get the error :
Missing driver Printer printer requires the /usr/lib/cups/filter/rastertogutenprint.5.2 program but it is not currently installed. Please install it before using this printer.

I have searched in Entropy Store (Sulfur) and there is no such package.

Any help would be greatly appreciated.
vovim
Baby Hen
 
Posts: 7
Joined: Thu Nov 17, 2011 20:27

Re: Cannot install/configure printer EPSON Stylus Photo R340

Postby svantoviit » Sat Nov 19, 2011 18:18

Have you CUPS installed? (net-print/cups, net-print/cups-pk-helper)

And have you tried to install net-print/gutenprint? = cups printer drivers

And there's en epson driver in the bgo-overlay too> epson-inkjet-printer-escpr
svantoviit
Old Dear Hen
 
Posts: 649
Joined: Sun Feb 28, 2010 17:55

Re: Cannot install/configure printer EPSON Stylus Photo R340

Postby vovim » Sat Nov 19, 2011 22:50

Yes, CUPS is installed and gutenprint is installed too. But not cups-pk-helper. In Entropy store is says cups-pk-helper is only to help with fine grained privileges. Do you think that this will help ?
The epson-inkjet-printer-escpr driver looks promising as it lists the R340 as a supported printer but what is a bgo-overlay and how do I install it ?
vovim
Baby Hen
 
Posts: 7
Joined: Thu Nov 17, 2011 20:27

Re: Cannot install/configure printer EPSON Stylus Photo R340

Postby svantoviit » Sun Nov 20, 2011 0:02

You have to install the driver using a local overlay. But I can not confirm it will work... haven't tried to install it myself.

Why not start with updating the portage tree:
Code: Select all
emerge --sync

Download the ebuild.

Create a local overlay:
1. append these lines to /etc/make.conf
Code: Select all
PORTDIR_OVERLAY="${PORTDIR_OVERLAY} /usr/local/portage/"
ACCEPT_LICENSE="*"

2. your overlay should have a name
Code: Select all
mkdir /usr/local/portage/profiles
echo "local_overlay" > /usr/local/portage/profiles/repo_name

3. create the necessary folders in your overlay
Code: Select all
mkdir -p /usr/local/portage/net-print/epson-inkjet-printer-escpr

4. copy the downloaded ebuild into the created folder

5. create a manifest
Code: Select all
cd /usr/local/portage/net-print/epson-inkjet-printer-escpr
ebuild epson-inkjet-printer-escpr-1.0.2 manifest

Install
Code: Select all
emerge -av epson-inkjet-printer-escpr

If you succeed to install the ebuild, don't forget to inform Entropy about it:
Code: Select all
equo rescue spmsync --ask


Good luck!
svantoviit
Old Dear Hen
 
Posts: 649
Joined: Sun Feb 28, 2010 17:55

Re: Cannot install/configure printer EPSON Stylus Photo R340

Postby vovim » Sun Nov 20, 2011 14:44

O.K. I'll give it a try and let you know how I got on.
It might take a while tho' as I'm suffering from the flu and can only work on this for short periods before I need to take a break.
vovim
Baby Hen
 
Posts: 7
Joined: Thu Nov 17, 2011 20:27

Re: Cannot install/configure printer EPSON Stylus Photo R340

Postby vovim » Mon Nov 21, 2011 13:01

I am not going to try this.
There was a similar post to this 'install in overlay' one in the past that I found in the forums and tried before I posted this request for help.
However, when I tried it, it said that I needed to update portage, which I did, although later in the fix I could not install the ebuild in the overlay.
Message to update portage when running "emerge -- sync" :
* An update to portage is available. It is _highly_ recommended
* that you update portage now, before any other packages are updated.

* To update portage, run 'emerge portage' now.

Updating portage using emerge meant that I kept getting an error when trying to install any packages.
I later discovered though a bug report that was posted when I was searching about the error I received when trying to install some packages that you should not update portage with emerge.
So, I thought that I would do a re-install of sabayon before I tried this fix.
The re-install went fine (I re-formatted all used partitions), and I had 399 packages to be upgraded. So I upgraded my system.
This has now broken KDE. Konqueror can not open any web pages and although kwrite is installed when I tried to open the ebuild that I had downloaded it could not find kwrite. The actual error was "A KDE text-editor component could not be found. Please check your KDE installation.".

So if a simple re-install breaks KDE then I do not think that this release of sabayon (Sabayon 7 KDE) is ready for the public (or for me anyway).
So I am going back to Slackware.
vovim
Baby Hen
 
Posts: 7
Joined: Thu Nov 17, 2011 20:27

Re: Cannot install/configure printer EPSON Stylus Photo R340

Postby svantoviit » Mon Nov 21, 2011 18:06

Not to upgrade portage with portage is a basic rule when mixing Entropy and Portage...
See: HOWTO: Safely mix Entropy and Portage

The second part of your post looks like you got into GCC-udating troubles as a lot of other users too. Nothing that couldn't be solved > 16th Nov. update breaks Firefox, Thunderbird, [Solved] or here > Sabayon 7 KDE fails to boot after update! [Solved]
That's the prize of a bleeding edge distro... unfortunately.
svantoviit
Old Dear Hen
 
Posts: 649
Joined: Sun Feb 28, 2010 17:55

Re: Cannot install/configure printer EPSON Stylus Photo R340

Postby vovim » Mon Nov 21, 2011 19:53

Thanks Svantoviit (hope I spelled that right).
Yes, it was doing a gcc upgrade when it said that there were 399 updates and then proceeded to ask if I wanted to upgrade.
I might give it another go if I can get the fix to work and it will recognise my printer.
vovim
Baby Hen
 
Posts: 7
Joined: Thu Nov 17, 2011 20:27

Re: Cannot install/configure printer EPSON Stylus Photo R340

Postby vovim » Mon Nov 21, 2011 23:13

Svantoviit, so far so good. However when I run "equo rescue spmsync --ask" I get this :

darkstar epson-inkjet-printer-escpr # equo rescue spmsync --ask
>> Scanning Source Package Manager and Entropy databases for differences...
>> cannot convert COUNTER for media-gfx/fbgrab-1.0,
>> cannot convert COUNTER for media-plugins/gst-plugins-x264-0.10.18,
>> cannot convert COUNTER for kde-base/kcminit-4.7.3,
>> cannot convert COUNTER for kde-base/kstartupconfig-4.7.3,
>> cannot convert COUNTER for kde-base/kioclient-4.7.3,
>> cannot convert COUNTER for kde-base/libksane-4.7.3,
>> cannot convert COUNTER for kde-base/korganizer-4.7.2,
>> cannot convert COUNTER for kde-base/kpasswdserver-4.7.3,
>> cannot convert COUNTER for kde-base/kgpg-4.7.3,
>> cannot convert COUNTER for kde-base/kactivities-4.7.3,
>> @@ Someone removed these packages. They would be removed from the system database:
>> # kde-base/kioclient-4.7.3
>> # media-plugins/gst-plugins-x264-0.10.18
>> # kde-base/libksane-4.7.3
>> # dev-libs/libnl-1.1-r2
>> # kde-base/kactivities-4.7.3
>> # kde-base/korganizer-4.7.2
>> # media-gfx/fbgrab-1.0
>> # kde-base/kstartupconfig-4.7.3
>> # dev-java/icedtea6-bin-1.10.3
>> # kde-base/kpasswdserver-4.7.3
>> # kde-base/kcminit-4.7.3
>> # kde-base/kgpg-4.7.3
>> Continue with removal ? [Yes/No]

Is it O.K. to remove these packages ?

Thanks
vovim
Baby Hen
 
Posts: 7
Joined: Thu Nov 17, 2011 20:27

Re: Cannot install/configure printer EPSON Stylus Photo R340

Postby svantoviit » Tue Nov 22, 2011 0:55

The reason, why I run equo rescue spmsync with --ask option is, that it tries to remove packages I want to keep. Like drivers for another installed kernels.
In this case there are probably a new replacements for the listed packages... I would choose "No" anyway. The new packages will be pulled with next equo upgrade and the deprecated removed I suppose.
Someone correct me if I'm wrong.
svantoviit
Old Dear Hen
 
Posts: 649
Joined: Sun Feb 28, 2010 17:55

Next

Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests

cron