After updating this weekend no Login Possible KDE [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Post Reply
maulbongo
Simple Hen
Posts: 60
Joined: Wed Oct 19, 2011 13:19

After updating this weekend no Login Possible KDE [Solved]

Post by maulbongo » Mon Nov 21, 2011 9:08

Hi folks,

After updating this weekend (sabayon-weekly) and using Intel GFX (Mesa) it was not possible for me to Log into kdm again.
I could encounter this problem on two Intel GFX machines and I also have two Nvidia and one ATI machine, there I didn't have these problems.
With one Machine the Language on the Welcomescreen also changed from german to bulgarian (cyrillic), good to always have another machine running ;)
So when trying to login it imediately switches back to Welcomescreen, Fluxbox for example worked.
After some researching I found this message in the /var/log/kdm.log:

Code: Select all

Could not open library klauncher: Cannot load library /usr/lib64/libkdeinit4_klauncher.so: (/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/lib64/libstreamanalyzer.so.0))
So the reason was found, seemed that the update of base-gcc-4.6.2 did not run correctly.
Ok, what to do.
Go to the cli and become su, then type

Code: Select all

equo install base-gcc-4.6.2 --ask
.
With one machine I also had to make

Code: Select all

equo conf update
and it showed me, that the config of kdm had to be updated, after doing this stuff and rebooting the machines all went fine again.
Hope this helps out.
greetings

maulbongo

Image

Post Reply