ATI driver showing artifacts in Gnome [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

ATI driver showing artifacts in Gnome [Solved]

Postby xjonquilx » Sun Nov 20, 2011 15:47

The ATI driver in Gnome shows artifacts every time I do anything in the GUI, like bring up the bottom panel or switch to the Activities menu. Can someone walk me through using another driver?
Last edited by xjonquilx on Sun Nov 20, 2011 23:05, edited 1 time in total.
xjonquilx
Simple Hen
 
Posts: 81
Joined: Tue Oct 25, 2011 18:23

Re: ATI driver showing artifacts in Gnome

Postby xjonquilx » Sun Nov 20, 2011 15:56

Or even better help me fix whatever is causing the artifacts?
xjonquilx
Simple Hen
 
Posts: 81
Joined: Tue Oct 25, 2011 18:23

Re: ATI driver showing artifacts in Gnome

Postby Fitzcarraldo » Sun Nov 20, 2011 17:54

Option 1: Open-source X.Org Radeon userspace driver

Install x11-drivers/xf86-video-ati

Uninstall ati-drivers

Edit /etc/X11/xorg.conf and change "fglrx" to "ati"

Code: Select all
$ su
Password:
# eselect opengl set xorg-x11
# exit

Reboot.

Option 2: Open-source kernel Radeon module

See Getting rid of Catalyst
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: ATI driver showing artifacts in Gnome

Postby xjonquilx » Sun Nov 20, 2011 23:05

Thanks!
xjonquilx
Simple Hen
 
Posts: 81
Joined: Tue Oct 25, 2011 18:23


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron