Sulfur broke while updating today [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Sulfur broke while updating today [Solved]

Postby MarzioDance » Mon Oct 24, 2011 23:49

Hi I'm a new user of Sabayon, been using ubuntu for the last 4 years or so, bu t wanted a change, and so far i like what i see.
Today sulfur broke while i was updating and now it won't even load here the output
Code: Select all
 xenons-desktop xenon # sulfur
Attempting to fix moveinst
100% [========================================================================>]
Traceback (most recent call last):
  File "/usr/lib/entropy/sulfur/", line 29, in <module>
    from sulfur import SulfurApplication
  File "/usr/lib/entropy/sulfur/sulfur/", line 57, in <module>
    from sulfur.packages import EntropyPackages, Queue
  File "/usr/lib/entropy/sulfur/sulfur/", line 34, in <module>
    from sulfur.package import EntropyPackage, DummyEntropyPackage
  File "/usr/lib/entropy/sulfur/sulfur/", line 27, in <module>
    ENTROPY = Equo()
  File "/usr/lib/entropy/lib/entropy/core/", line 54, in __new__
    singleton.init_singleton(*args, **kwds)
  File "/usr/lib/entropy/sulfur/sulfur/", line 319, in init_singleton
    Client.init_singleton(self, *args, **kwargs)
  File "/usr/lib/entropy/lib/entropy/client/interfaces/", line 745, in init_singleton
  File "/usr/lib/entropy/lib/entropy/client/interfaces/", line 83, in _validate_repositories
    dbc = self._open_repository(repoid, _enabled_repos = all_repos)
  File "/usr/lib/entropy/lib/entropy/client/interfaces/", line 201, in _open_repository
    _enabled_repos = _enabled_repos)
  File "/usr/lib/entropy/lib/entropy/client/interfaces/", line 307, in _load_repository
    updated = self.repository_packages_spm_sync(repoid, conn)
  File "/usr/lib/entropy/lib/entropy/client/interfaces/", line 877, in repository_packages_spm_sync
  File "/usr/lib/entropy/lib/entropy/db/", line 1715, in runTreeUpdatesActions
  File "/usr/lib/entropy/lib/entropy/core/settings/", line 179, in get_updatable_configuration_files
    for setting_id, dir_sett, auto_update in self.__setting_dirs.items():
ValueError: need more than 2 values to unpack

I hope that someone will be able to help me out, Thanks in advance :D
Baby Hen
Posts: 5
Joined: Mon Sep 12, 2011 4:23

Re: Sulfur broke while updating today

Postby genfool » Tue Oct 25, 2011 1:53

sorry to hear this, was a bug and you did nothing wrong.
Is a newer version of entropy available to fix this, rc63-r1
How you get this version is the trick, I have one 32 bit system and after it crashed and the new version showed up
Code: Select all
equo install equo entropy

was all I needed to do to get it working again.
On another system that is amd64, I needed to use portage to install it, not sure if 32 or 64 had a play in this.
Code: Select all
emerge --sync

Code: Select all
layman -s

Code: Select all
emerge equo entropy

Code: Select all
equo upgrade

This worked for me to get the new version of entropy installed, but had issues with it, would install rc59
I then ran equo install equo entropy, it installed 63 again and was broke again, I then emerge equo entropy and it installed 59 again, then I just ran equo upgrade and it installed the 15 updates I had and entropy 63-r1 ... this gave me an equo entropy mis match, then I equo installed equo entropy again and all was fine ... never had these issues before, not sure why I had them this time ... is just a little mussing with it and you will be as good as new again.
Technological Hen
Posts: 344
Joined: Fri Apr 03, 2009 17:56
Location: Albuquerque, NM

Re: Sulfur broke while updating today [Solved]

Postby MarzioDance » Tue Oct 25, 2011 3:31

Thank you, that fixed my problem
Baby Hen
Posts: 5
Joined: Mon Sep 12, 2011 4:23

Re: Sulfur broke while updating today

Postby hmhofman » Mon Oct 31, 2011 10:55

I got several version conflicts trying this.
The solution is here: ... ut_Entropy

First make sure you use the correct overlay and update it.
# layman --add sabayon
Then Update it (if necessary):
# layman --sync sabayon
Then emerge equo, sulfur and dependencies
# emerge entropy sulfur equo entropy-client-services
Eventually: Upgrade your machine:
# equo upgrade
Baby Hen
Posts: 2
Joined: Tue Oct 11, 2011 15:42
Location: Lemmer

Re: Sulfur broke while updating today [Solved]

Postby fripper66 » Tue Nov 01, 2011 11:12

Hmhofman's method worked for me. The only additional step I had to do was run
Code: Select all
equo conf update

After that it equo updated and upgraded as normal.
Baby Hen
Posts: 3
Joined: Sun Feb 13, 2011 20:20

Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest