nautilus lento [Risolto]

Problemi relativi a KDE, GNOME o altri ambienti grafici? Scrivi pure qui!

Moderator: Moderators

Re: nautilus lento

Postby Alessio » Sat Oct 22, 2011 11:48

Ok, ora che ho riavviato funziona anche Unity!!!! Non ho più problemi con "Cheese", "Riproduttore filmati" ed "Empathy", che ora funzionano perfettamente. Il problema de nautilus lento invece persiste. Comunque, ecco qua l'output dei comandi:
Code: Select all
sabayon alessio # lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
01:00.0 VGA compatible controller: ATI Technologies Inc Madison [Radeon HD 5000M Series]
01:00.1 Audio device: ATI Technologies Inc Redwood HDMI Audio [Radeon HD 5600 Series]
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
7f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
7f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
7f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
7f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
7f:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
7f:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

sabayon alessio # glxinfo | grep vendor
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
OpenGL vendor string: Tungsten Graphics, Inc

sabayon alessio # glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile
    GL_EXT_vertex_array_bgra, GL_NV_conditional_render,

sabayon alessio # eselect opengl list
Available OpenGL implementations:
  [1]   ati
  [2]   nvidia
  [3]   xorg-x11 *

E ora il file /etc/X11/xorg.conf:
Code: Select all
Section "Module"
    SubSection  "extmod"
       Option    "omit xfree86-dga"
    EndSubSection
    Load    "i2c"
    Load    "ddc"
    Load    "vbe"
    Load    "dri"
    Load    "glx"
    Load    "synaptics"
EndSection

Section "ServerFlags"
     Option    "AllowMouseOpenFail"    "true"
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    VertRefresh    43 - 60
    HorizSync      28 - 80
EndSection


Section "Device"

    Identifier  "SabayonVga0"
    Driver      "intel"
    BusID    "PCI:00:02"
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
    # UseEvents is causing segmentation faults with
    # NVIDIA 6xxx, 7xxx and >=275.xx.xx drivers
    #Option "UseEvents" "True"
    Option "LogoPath" "/usr/share/backgrounds/sabayonlinux-nvidia.png"

EndSection

Spero sia tutto ok!
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Re: nautilus lento

Postby micia » Sat Oct 22, 2011 11:59

Eccellente, sì, tutto perfetto, comunque è GNOME Shell quello che stai usando, non Unity :wink:

Con nautilus cosa accade se lo avvii da terminale, nessun messaggio di errore?
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: nautilus lento

Postby Alessio » Sat Oct 22, 2011 12:25

Sì, scusa, gnome shell!! :D
Comunque, se avvio nautilus da terminale nessun messaggio di errore: si avvia subito senza alcun problema, proprio come dovrebbe essere... è veloce e reattivo da subito.. Se invece riprovo ad avviarlo dalla sua icona, il problema persiste...
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Re: nautilus lento

Postby Thema89 » Sat Oct 22, 2011 12:27

Eccomi con degli aggiornamenti... buone notizie :D
Ho trovato una soluzione che -da quanto ho potuto studiare oggi- non dovrebbe causare alcuna noia e fixare la piccola noia all'avvio di Nautilus...

Per quanto riguarda il "problema grafico", avevo inizialmente pensato fosse un problema strettamente correlato alla gestione e all'organizzazione dei files da parte di nautilus...
mi sono invece accorto che non è questo a rallentare l'operazione di caricamento, bensì il suo lanciatore, il che mi ha lasciato abbastanza perplesso inizialmente :?

Facendo ulteriori ricerche sui codici della FreeDesktop usati da Gnome 3.2 e aiutandomi con alcune prove, ho individuato il colpevole: il protocollo di notifica di avvio (Startup Notification Protocol), che dovrebbe lasciar gestire all'applicazione la notifica di avvio anziché farla gestire di default dal sistema.
Fortunatamente, è una flag del tutto accessoria e -almeno dai miei test- tranquillamente disattivabile senza alcuna ripercussione negativa (anzi) sul Nautilus...

Prima di proseguire, controlla se avviando il nautilus via terminale hai dei miglioramenti:
Code: Select all
(1) ALT+ F2 => scrivi "nautilus", senza virgolette ovviamente, e premi invio

Chi ha solo il "fastidio" grafico della clessidra, noterà che questo non è più presente (nel tuo caso che hai anche dei rallentamenti, forse non è l'unico problema però...)


Qui sotto la procedura per risolvere il caricamento pachidermico: :mrgreen:

- Eseguite da terminale
Code: Select all
sudo gedit /usr/share/applications/nautilus.desktop

- Scorrete in fondo, dopo tutti i nomi ed i commenti nelle varie lingue, fino ad arrivare qui:
Code: Select all
Exec=nautilus %U
Icon=system-file-manager
Terminal=false
Type=Application
StartupNotify=true
OnlyShowIn=GNOME;Unity;
Categories=GNOME;GTK;Utility;Core;
MimeType=inode/directory;application/x-gnome-saved-search;

- Impostate StartupNotify=false, salvate e chiudete gedit.

- Ora aggiorniamo il GDE per rendere effettive le modifiche:
Premete di nuovo ALT+F2 e scrivete solo " r " e premete invio.


Nel mio caso, oltre alla clessidra si è anche velocizzato l'avvio, e da stamattina sto utilizzando nautilus senza rilevare alcun problema.
Spero vi sia d'aiuto ! :D
God's in his Heaven. All's right with the world.
Image
Image
Image
Image
Thema89
Baby Hen
 
Posts: 11
Joined: Mon Oct 17, 2011 16:54
Location: Italy (Roma)

Re: nautilus lento

Postby Alessio » Sat Oct 22, 2011 12:37

Graaande!!! Problema risolto al 100%!!! Unica nota: il comando "r" non funziona, sia se lo digito da root che da utente normale.
Code: Select all
[email protected] ~ $ r
bash: r: command not found...

Per il resto, tutto ok, sembra che funzioni tutto benissimo! :D
Comunque, questa è la mia prima esperienza con gnome shell, e devo dire che, personalmente, non ci trovo nulla di male. Ho letto molte critiche al riguardo, perciò ero scettico, ma adesso mi sento soddisfatto! Anzi, mi piace proprio!
Grazie ancora! :D
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Re: nautilus lento

Postby micia » Sat Oct 22, 2011 12:40

Ottimo lavoro Thema89, proverò la tua soluzione nel mio sistema, se funziona riporterò il problema al team di sviluppo con un rapporto bug, in modo che questo venga risolto permanentemente :mrgreen:

Il comando r è della GNOME shell, non del terminale, devi avviarlo dandolo con Alt+F2, non direttamente da console.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: nautilus lento

Postby Thema89 » Sat Oct 22, 2011 12:43

Son contento che hai risolto...
il comando r non lo devi usare dentro il terminale ma dalla riga di comando gnome, che la apri appunto premendo ALT + F2... comunque serve solo a ricaricare il desktop completamente senza riavviare il pc, nulla di importante insomma, l'ho aggiunto per sicurezza, è sempre buona norma dopo aver modificato le impostazioni :wink:
God's in his Heaven. All's right with the world.
Image
Image
Image
Image
Thema89
Baby Hen
 
Posts: 11
Joined: Mon Oct 17, 2011 16:54
Location: Italy (Roma)

Re: nautilus lento

Postby Alessio » Sat Oct 22, 2011 12:44

Ah, ok, ma comunque con Alt+F2 l'unica cosa che succede è che diminuisce la luminosità dello schermo, non si apre niente... per questo ho provato dal terminale!
Alessio
Growing Hen
 
Posts: 168
Joined: Mon May 02, 2011 14:14

Re: nautilus lento [Risolto]

Postby micia » Sat Oct 22, 2011 14:26

Confermo che la soluzione di Thema89 funziona perfettamente anche sul mio sistema, ho aggiunto un rapporto bug:
https://bugs.sabayon.org/show_bug.cgi?id=2797
Spero che venga risolto presto su ogni versione di Sabayon.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Previous

Return to Sabayon Linux Ambienti Grafici

Who is online

Users browsing this forum: No registered users and 3 guests