I want ALSA back!

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Re: I want ALSA back!

Postby Sisko43 » Tue Oct 18, 2011 20:48

In the beginning of this topic you said you did an update. Was this the update to KDE 4.7.2?
If yes, I would assume this must be a KDE-related issue.

Sound-sensitive folders in KDE are:

- .config
- .local
- .dbus
- .kde4 (especially the file "phonondevicesrc"
- .gstreamer-0.10
- .xine

Renaming these folders could be another way...
Sisko43
Growing Hen
 
Posts: 195
Joined: Sun Mar 29, 2009 12:59

Re: I want ALSA back!

Postby Ponder » Tue Oct 18, 2011 21:22

I have no ALSA audio without a GUI loaded (unless I'm root) so it's not a KDE issue, nor anything to do with xorg. It's the same on a test user I created without ever having loaded a UI.

The reboot accomplished nothing BTW.

Edit: I've checked all the directories listed, nothing helps I'm afraid.
Ponder
Simple Hen
 
Posts: 61
Joined: Wed Apr 28, 2010 21:30

Re: I want ALSA back!

Postby dunsurfin » Wed Oct 19, 2011 8:30

You mentioned "back to basics". Do libtest, deptest and conf update throw up anything? I noticed during the KDE update that a new pulseaudio was installed and various other sound related packages - it may be worth looking through your log to see exactly was installed and that may give a clue.
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: I want ALSA back!

Postby Sisko43 » Wed Oct 19, 2011 10:40

Ponder wrote:I have no ALSA audio without a GUI loaded (unless I'm root)


Sorry, can't picture this clearly. What does that mean. You're in text console mode and you want to play music or what? Normally you log in to something KDE, Gnome, Xfce, aso. Your pictures telling me you're using KDE and you have HDA ATI HDMI as a second audio device. This a typical sore point in KDE. This is my list:

Code: Select all
Karte 0: Intel [HDA Intel], Gerät 0: VT1828S Analog [VT1828S Analog]
  Sub-Geräte: 1/2
  Sub-Gerät #0: subdevice #0
  Sub-Gerät #1: subdevice #1
Karte 0: Intel [HDA Intel], Gerät 1: VT1828S Digital [VT1828S Digital]
  Sub-Geräte: 2/2
  Sub-Gerät #0: subdevice #0
  Sub-Gerät #1: subdevice #1
Karte 1: NVidia [HDA NVidia], Gerät 3: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: NVidia [HDA NVidia], Gerät 7: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: NVidia [HDA NVidia], Gerät 8: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: NVidia [HDA NVidia], Gerät 9: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0


As you can see I have HDA Nvidia. When this device is activated it interferes with the HDA Intel. One example when playing a sound file via vlc:

Code: Select all
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
ERROR: Cannot open device alsa.


I think this error message sounds familiar.

To solve this I installed the PulseAudio Volume Control panel

Code: Select all
equo install pavucontrol


and deactivated the entry HDA Nvidia. Another way is to deactivate in BIOS directly, but sometimes I need this device.
Anyway, since then I have no problems with sound through pulseaudio anymore.

Before that I had pulseaudio deactivated, too. And I didn't notice the option in BIOS to stop HDA Nvidia. I created an ".asoundrc"-file in my home-directory adressing directly HDA-Intel:

Code: Select all
pcm.!default {
 type hw
 card 0
 }

 ctl.!default {
 type hw
 card 0
 }


Also it was important to execute "alsamixer" in terminal (NOT as root) to assign the desired soundcard to my user and setting up the separate channels. End alsamixer with Esc. Everytime pulseaudio was updated through entropy I had to redo that. That was kind of annoying. The deactivation of HDA Nvidia through pavucontrol was the final and best solution.

I wouldn't be surprised if your HDA ATI HDMI device is making here trouble, too...
Sisko43
Growing Hen
 
Posts: 195
Joined: Sun Mar 29, 2009 12:59

Re: I want ALSA back!

Postby Fitzcarraldo » Wed Oct 19, 2011 14:20

Some additional information: Even if one has PulseAudio activated, it is still simple enough to access the ALSA Mixer controls from the GUI DE: Nostalgia for those ALSA mixer channels that KMix and GNOME Volume Control used to have?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: I want ALSA back!

Postby Ponder » Wed Oct 19, 2011 14:39

dunsurfin, it works as root, it's not a hardware issue, it's down to permissions somewhere, but everywhere I know of is set correctly in this aspect, but I will check the logs when I next get the chance.

Sisko43 yes, I have always been able to play music in plain text console, and always with the Intel HDA. The Azalia is an alias of the same device, if I disable it I'll have no sound at all. I cannot access ALSA as a user by any method because it fails. Only pulseaudio is working.

Fitzcarraldo, I cannot access any aspect of ALSA as a user, alsamixer and alsamixergui always fail to load.
Ponder
Simple Hen
 
Posts: 61
Joined: Wed Apr 28, 2010 21:30

Re: I want ALSA back!

Postby dunsurfin » Wed Oct 19, 2011 14:56

Ponder wrote:dunsurfin, it works as root, it's not a hardware issue, it's down to permissions somewhere, but everywhere I know of is set correctly in this aspect, but I will check the logs when I next get the chance.


I don't think I suggested it was a hardware issue. I'm thinking along the lines "something borked during the upgrade" as that is when it appears to have happened.
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: I want ALSA back!

Postby Fitzcarraldo » Wed Oct 19, 2011 15:07

Ponder wrote:Fitzcarraldo, I cannot access any aspect of ALSA as a user, alsamixer and alsamixergui always fail to load.

Ok... Understood. And, having scanned back through the thread, I agree with you that it's nothing to do with the DE. I wonder if it's a problem with udev (see second post in [Solved] In audio group, but only have sound as root)?

BTW, have you tried specifying the default sound device explicitly (see http://en.gentoo-wiki.com/wiki/ALSA#Def ... und_Device )?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: I want ALSA back!

Postby Sisko43 » Wed Oct 19, 2011 15:27

What error message do you have, when you try to start alsamixer. Something like this:

Code: Select all
alsamixer: function snd_ctl_open failed for default: No such device or directory


If yes, I would reinstall the kernel...
Sisko43
Growing Hen
 
Posts: 195
Joined: Sun Mar 29, 2009 12:59

Re: I want ALSA back!

Postby batvink » Wed Oct 19, 2011 18:48

can you check if all binaries involved alsa has proper rights?
they're located in /usr/bin
and all have to be owner:root, group: root (chown root:root filename)
and the read, write, access for all is: root: rwx, group: rx rest: rx (chmod 755 filename)

but, on the other hand,
if you do get a error message when opening alsmixer in terminal,
then it's not a permission issue, 'cause otherwise you would get a "permission denied" message,
or "only root can ...."
then, something else is going on...
User avatar
batvink
Old Dear Hen
 
Posts: 495
Joined: Sun Oct 28, 2007 11:44
Location: the netherlands

PreviousNext

Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest