XFCE Mounting drives "not authorized" [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Re: XFCE Mounting drives "not authorized"

Postby rumahsiput » Tue Sep 06, 2011 3:51

Just follow one of these links and you can't go wrong:
http://wiki.sabayon.org/index.php?title ... t_to_do.3F
or
http://joostruis.wordpress.com/2011/08/ ... -what-now/
If it doesn't come with the update, remember to install xfce-extra/xfce4-notifyd.
I've not had any problems since. Good luck and enjoy Sabayon.
rumahsiput
Simple Hen
 
Posts: 50
Joined: Sun Mar 28, 2010 6:22

Re: XFCE Mounting drives "not authorized"

Postby bitERROR » Wed Sep 07, 2011 9:01

This doesn't work to me, I'm not in a clean installation and all my packages are already updated.

Playing with the policies mentioned by @joost, I've discovered that changing the action filesystem-mount (and others necessary to mount as filesystem-mount-system-internal and filesystem-check) in /usr/share/polkit-1/actions/org.freedesktop.udisks.policy to yes in the key allow_any and restarting consolekit
Code: Select all
# /etc/init.d/consolekit restart

Allows to any normal user to mount drives
Code: Select all
$ udisks --mount /dev/sda2
Mounted /org/freedesktop/UDisks/devices/sda2 at /media/BIT

But this looks like dangerous, so changing to auth_admin_keep
Code: Select all
$ udisks --mount /dev/sda2
Mount failed: Authentication is required

This could be great, but from XFCE it stills doesn't ask me for authentication. Now instead of "Not Authorized" it says "Authentication is required".

:'(
bitERROR
Simple Hen
 
Posts: 43
Joined: Mon Jul 04, 2011 20:14

Re: XFCE Mounting drives "not authorized"

Postby joost » Wed Sep 07, 2011 9:16

To me it looks like the supposed to popup window that would ASK for your root password simply doesn't launch.
This might be due the recent migrations to GNOME 3 and the fact that Xfce for a great deal, especially stuff like this, depends on GNOME.

We are aware of the problem now and it has some prio.
joost
Sagely Hen
 
Posts: 2548
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: XFCE Mounting drives "not authorized"

Postby bitERROR » Wed Sep 07, 2011 9:36

Thank you, I've tested with polkit-gnome and lxpolkit with the same result.

I can survive mounting the drives manually as root and then thunar lets browse and write. I'll continue searching a proper solution.
bitERROR
Simple Hen
 
Posts: 43
Joined: Mon Jul 04, 2011 20:14

Re: XFCE Mounting drives "not authorized"

Postby bitERROR » Wed Sep 07, 2011 14:11

I've seen that some people has this problem because polkit-gnome-authentication-agent-1 is not automatically started.

In my case it's running due to /etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop file. And this one isn't duplicated in ~/.config/autostart, which could be a problem.
Code: Select all
# ps -ef | grep gnome-auth
root      1683  1560  0 15:20 pts/0    00:00:00 grep --colour=auto gnome-auth
myuser      9303     1  0 08:45 ?        00:00:00 /usr/libexec/polkit-gnome-authentication-agent-1

All ok, so i cat it:
Code: Select all
# cat /etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop
[Desktop Entry]
Name=PolicyKit Authentication Agent
Comment=PolicyKit Authentication Agent
Exec=/usr/libexec/polkit-gnome-authentication-agent-1
Terminal=false
Type=Application
Categories=
NoDisplay=true
NotShowIn=KDE;
AutostartCondition=GNOME3 if-session gnome-fallback


I'm 99% sure that this parameters are incorrect, because it references to GNOME3 and KDE, and I need it in XFCE.

How should be this file for XFCE? Or is correct?
bitERROR
Simple Hen
 
Posts: 43
Joined: Mon Jul 04, 2011 20:14

Re: XFCE Mounting drives "not authorized"

Postby bitERROR » Fri Sep 09, 2011 0:22

I've done a fresh installation in an other HD with the XFCE ISO of Sabayon 6, and I can confirm that this happens from the beggining.

Booted by first time, the problem it is.

After perfom full upgrade as recomended in wiki.sabayon.org, the problem continues.

thunar-volman is not installed by default, so you got an error when trying to configure through Thunar's preferences menu option.

After install thunar-volman and once configured and restarted xfce and consolekit, the problem persists.

console-kit-daemon and polkitd are running.

polkit-gnome isn't installed by default, so polkit-gnome-authentication-agent-1 is not running.

Installing polkit-gnome and restarting, finally solves the problem.
bitERROR
Simple Hen
 
Posts: 43
Joined: Mon Jul 04, 2011 20:14

Re: XFCE Mounting drives "not authorized"

Postby rumahsiput » Fri Sep 09, 2011 8:07

Thanks bitERROR, I learn something new today. Sorry, all the while, I thought it was just the usb... apparently I have no need to mount other drives :) Perhaps you should edit title to "solved".
rumahsiput
Simple Hen
 
Posts: 50
Joined: Sun Mar 28, 2010 6:22

Previous

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 2 guests

cron