XFCE Mounting drives "not authorized" [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

XFCE Mounting drives "not authorized" [Solved]

Postby bitERROR » Wed Aug 31, 2011 9:29

Hi!

I can't mount any hard drive or removable disk with Thunar (or Nautilus) in XFCE.

Mounting works correctly in a terminal by typing (for ex.):
# mount /dev/sda1 /mnt

But Thunar seems unable to do. Doesn't ask for authentication, directly says;

Can't mount 'DRIVE_NAME'
"Not Authorized"


Could you help me with this issue?
Last edited by bitERROR on Fri Sep 09, 2011 8:46, edited 1 time in total.
bitERROR
Simple Hen
 
Posts: 43
Joined: Mon Jul 04, 2011 20:14

Re: XFCE Mounting drives "not authorized"

Postby batvink » Wed Aug 31, 2011 23:14

i don't know much about xfce,
but you can put the drives in your '/etc/fstab' file

example:
(first create the mountpoints as root, then edit fstab, matching your mountpoints)
Code: Select all
/dev/sda5                                         /media/server      ntfs-3g    defaults           0 0
/dev/sdc1                                         /media/Se7en       ntfs-3g    defaults           0 0
/dev/sdc2                                         /media/backup      ntfs-3g    defaults           0 0

warning: It does have a disadvantage,
everybody who can login to your computer also has full read/write access to your drives.
If you want, you can restrict, or forbid other users to access the drives by delete 'defaults'
and add disk quota or set user ID (uid) and/or Group ID (gid)
more about fstab:
https://wiki.archlinux.org/index.php/Fstab
more about mount:
http://linux.die.net/man/8/mount
please note that some options are filesystem specific.
User avatar
batvink
Old Dear Hen
 
Posts: 495
Joined: Sun Oct 28, 2007 11:44
Location: the netherlands

Re: XFCE Mounting drives "not authorized"

Postby joost » Thu Sep 01, 2011 10:56

Can you post the output of this:
Code: Select all
rc-update show | grep consolekit


You need to run it as root.
joost
Sagely Hen
 
Posts: 2603
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: XFCE Mounting drives "not authorized"

Postby bitERROR » Thu Sep 01, 2011 11:17

Hi, thanks for your answers.

I prefer not to change fstab with static values, my idea is to fix this problem with Xfce.

@joost
Code: Select all
# rc-update show | grep consolekit
           consolekit | boot



More information, the first DM installed in this machine was gdm + gnome2->3, now it's slim + xfce4, following the gentoo guide.
bitERROR
Simple Hen
 
Posts: 43
Joined: Mon Jul 04, 2011 20:14

Re: XFCE Mounting drives "not authorized"

Postby joost » Thu Sep 01, 2011 11:21

consolekit is at boot level, good thing.
Just wanted to make sure.

You have polkit-gnome installed there?
This should give you a dialog where you need to elevate your authority. If you do not have it installed, install it.

Alternatively you can change the rules and simply allow users to mount partitions on internal HD.
open: /usr/share/polkit-1/actions/org.freedesktop.udisks.policy
look for: <action id="org.freedesktop.udisks.filesystem-mount-system-internal">
change its configuration to: <allow_active>yes</allow_active>
joost
Sagely Hen
 
Posts: 2603
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: XFCE Mounting drives "not authorized"

Postby bitERROR » Thu Sep 01, 2011 12:31

Yes, I have.

I'll try when I come back home tonight.
bitERROR
Simple Hen
 
Posts: 43
Joined: Mon Jul 04, 2011 20:14

Re: XFCE Mounting drives "not authorized"

Postby rumahsiput » Thu Sep 01, 2011 14:05

I had similar problems when I installed xfce (wifi won't work as well and also thunar took a long time to load) but I went ahead and updated the system anyway (wired) since I already lost gnome. After the full update, wifi worked and installing xfce-extra/xfce4-notifyd, all my problems were solved. I hope this help.
rumahsiput
Simple Hen
 
Posts: 50
Joined: Sun Mar 28, 2010 6:22

Re: XFCE Mounting drives "not authorized"

Postby bitERROR » Fri Sep 02, 2011 10:50

Hi,

I edited /usr/share/polkit-1/actions/org.freedesktop.udisks.policy (line 30) and it doesn't work (I restarted xfce and system).

I'm thinking that the problem is more global than just device mounting. polkit-gnome is installed but dialogs doesn't appear anywhere in my XFCE, except when opening sulfur. Can't graphically change system options.

Trying, for ex.,
Code: Select all
$ gksu users-admin

asks for authentication but after authenticate the users-admin window remains frozen with all controls disabled.

I tried to purge and reinstall polkit-gnome and nothing changes.
bitERROR
Simple Hen
 
Posts: 43
Joined: Mon Jul 04, 2011 20:14

Re: XFCE Mounting drives "not authorized"

Postby bitERROR » Sat Sep 03, 2011 22:12

I've followed this gentoo thread and now authentication dialogs appear when accessing to some system configurations GUIs like users-admin, but ... still not running with Thunar, Nautilus or when simply shutting down or rebooting from the panel plugin.

:x
bitERROR
Simple Hen
 
Posts: 43
Joined: Mon Jul 04, 2011 20:14

Re: XFCE Mounting drives "not authorized"

Postby bitERROR » Mon Sep 05, 2011 9:57

@rumahsiput how did you do the "full system update" ?
bitERROR
Simple Hen
 
Posts: 43
Joined: Mon Jul 04, 2011 20:14

Next

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest