masked package asks to be upgraded? [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

masked package asks to be upgraded? [Solved]

Postby sedo_5 » Fri Aug 26, 2011 10:39

Hi everyone.
As I know (very little) about masked packages is that they don't show up in the upgrade list (just because they're masked...), or at least I thought so!
Some days ago, during an upgrade with Sulfur (the GUI) it happened that libgweather-9999 package showed up in the ugrade list; after a quick consultation in the irc channel thay suggested me to try with equo (the TUI) and, strangely, this package didn't show up, so I could execute the upgrade flawlessly.

Today this package has come up again! but this time it's shown either in Sulfur and in equo, i'll paste here the terminal output:
Code: Select all
# equo upgrade --pretend
>>  @@ Calcolo Aggiornamenti di Sistema...
>>  @@ 11 => Pacchetti risolti da aggiornare
>>  @@ 0 => Pacchetti risolti non disponibili
>>  @@ 1637 => Pacchetti accoppiati già aggiornati
>>  @@ Questi sono i pacchetti scelti:
>>    # (1/11) [sabayonlinux.org] app-admin/equo-1.0_rc44
>>     Versioni: 1.0_rc43 / NoTag / 0 ===> 1.0_rc44 / NoTag / 0
>>      Azione:          Aggiorna
>>    # (2/11) [sabayonlinux.org] app-admin/sulfur-1.0_rc44
>>     Versioni: 1.0_rc43 / NoTag / 0 ===> 1.0_rc44 / NoTag / 0
>>      Azione:          Aggiorna
>>    # (3/11) [sabayonlinux.org] app-misc/magneto-loader-1.0_rc44
>>     Versioni: 1.0_rc43 / NoTag / 0 ===> 1.0_rc44 / NoTag / 0
>>      Azione:          Aggiorna
>>    # (4/11) [sabayonlinux.org] dev-libs/libgweather-9999
>>     Versioni: 3.0.2 / NoTag / 0 ===> 9999 / NoTag / 2
>>      Azione:          Aggiorna
>>    # (5/11) [sabayonlinux.org] kde-misc/magneto-kde-1.0_rc44
>>     Versioni: 1.0_rc43 / NoTag / 0 ===> 1.0_rc44 / NoTag / 0
>>      Azione:          Aggiorna
>>    # (6/11) [sabayonlinux.org] sys-apps/entropy-1.0_rc44
>>     Versioni: 1.0_rc43 / NoTag / 0 ===> 1.0_rc44 / NoTag / 0
>>      Azione:          Aggiorna
>>    # (7/11) [sabayonlinux.org] sys-apps/entropy-client-services-1.0_rc44
>>     Versioni: 1.0_rc43 / NoTag / 0 ===> 1.0_rc44 / NoTag / 0
>>      Azione:          Aggiorna
>>    # (8/11) [sabayonlinux.org] sys-apps/magneto-core-1.0_rc44
>>     Versioni: 1.0_rc43 / NoTag / 0 ===> 1.0_rc44 / NoTag / 0
>>      Azione:          Aggiorna
>>    # (9/11) [sabayonlinux.org] x11-drivers/ati-drivers-11.8#2.6.37-sabayon
>>     Versioni: 11.6 / 2.6.37-sabayon / 0 ===> 11.8 / 2.6.37-sabayon / 0
>>      Azione:          Aggiorna
>>    # (10/11) [sabayonlinux.org] x11-drivers/ati-drivers-11.8#2.6.39-sabayon
>>     Versioni: 11.6 / 2.6.39-sabayon / 3 ===> 11.8 / 2.6.39-sabayon / 0
>>      Azione:          Aggiorna
>>    # (11/11) [sabayonlinux.org] x11-drivers/ati-userspace-11.8
>>     Versioni: 11.6 / NoTag / 1 ===> 11.8 / NoTag / 0
>>      Azione:          Aggiorna
>>  @@ Pacchetti coinvolti: 11
>>  @@ calcolo delle dipendenze ...
>>  @@ Questi sono i pacchetti che verrebbero installati:
>>  ## [U] [sabayonlinux.org] x11-drivers/ati-userspace-11.8|0   [11.6|1]
>>  ## [U] [sabayonlinux.org] x11-drivers/ati-drivers-11.8#2.6.37-sabayon|0   [11.6|0|2.6.37-sabayon]
>>  ## [U] [sabayonlinux.org] sys-apps/entropy-1.0_rc44|0   [1.0_rc43|0]
>>  ## [U] [sabayonlinux.org] sys-apps/entropy-client-services-1.0_rc44|0   [1.0_rc43|0]
>>  ## [U] [sabayonlinux.org] sys-apps/magneto-core-1.0_rc44|0   [1.0_rc43|0]
>>  ## [U] [sabayonlinux.org] app-misc/magneto-loader-1.0_rc44|0   [1.0_rc43|0]
>>  ## [U] [sabayonlinux.org] kde-misc/magneto-kde-1.0_rc44|0   [1.0_rc43|0]
>>  ## [U] [sabayonlinux.org] dev-libs/libgweather-9999|2   [3.0.2|0]
>>  ## [U] [sabayonlinux.org] app-admin/sulfur-1.0_rc44|0   [1.0_rc43|0]
>>  ## [U] [sabayonlinux.org] app-admin/equo-1.0_rc44|0   [1.0_rc43|0]
>>  ## [U] [sabayonlinux.org] x11-drivers/ati-drivers-11.8#2.6.39-sabayon|0   [11.6|3|2.6.39-sabayon]


What should I do? honestly I wouldn't like that much installing a masked package, even worse wether this is a dependency of a gnome package (I'm using kde but i have a few gnome packages..)
Could this be a bug?

By the way, doing an equo search libgweather that's what it shows up:
Code: Select all
 # equo search gweather
>>  @@ Cercando...
>>      @@ Pacchetto: dev-libs/libgweather-9999 branch: 5, [sabayonlinux.org]
>>         Disponibile:   versione: 9999 ~ tag: NoTag ~ revisione: 2
>>         Installato:    versione: 3.0.2 ~ tag: NoTag ~ revisione: 0
>>         Slot:          2
>>         Homepage:      http://www.gnome.org/
>>         Descrizione:   Library to access weather information
>>                        from online services
>>         Licenza:       GPL-2
>>  Keyword:  gweather



Thanks for your attention!
Bye

Renzo
Last edited by sedo_5 on Sun Aug 28, 2011 11:46, edited 1 time in total.
sedo_5
Growing Hen
 
Posts: 133
Joined: Sun Dec 05, 2010 19:20

Re: masked package asks to be upgraded?

Postby sabayonino » Fri Aug 26, 2011 23:14

Hi Renzo, Don't worry .... see viewtopic.php?f=24&t=25031#p139555

this package fix some problems to gnome users

I think you can install this without problems.
User avatar
sabayonino
Sagely Hen
 
Posts: 2464
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: masked package asks to be upgraded? [Solved]

Postby sedo_5 » Sun Aug 28, 2011 11:47

Thanks a lot, i did as showed in that post and now it's fine :)

Thanks,

Bye

Renzo
sedo_5
Growing Hen
 
Posts: 133
Joined: Sun Dec 05, 2010 19:20


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest