NVIDIA Driver problem [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
kitsios
Baby Hen
Posts: 11
Joined: Sun Mar 13, 2011 16:04

NVIDIA Driver problem [Solved]

Post by kitsios » Tue Aug 09, 2011 12:01

Hi, I updated my system, and now X does not work. It is stuck in an infinite loop with the NVIDIA logo and a black screen with the busy cursor showing. What can I do to fix it?

Here's my xorg.conf:

Code: Select all

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 280.13  ([email protected])  Wed Jul 27 17:18:55 PDT 2011

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 260.19.21  ([email protected])  Wed Dec 15 15:22:17 UTC 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics LG TV"
    HorizSync       30.0 - 83.0
    VertRefresh     60.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9700M GT"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "DynamicTwinView" "1"
    Option         "TwinView" "1"
    Option         "metamodes" "DFP: 1920x1080 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Last edited by kitsios on Tue Aug 09, 2011 20:47, edited 1 time in total.

popsUlfr
Young Hen
Posts: 34
Joined: Sun Aug 07, 2011 16:41

Re: NVIDIA Driver problem

Post by popsUlfr » Tue Aug 09, 2011 12:38

Remove your current xorg.conf

Code: Select all

rm /etc/X11/xorg.conf
Generate a new one with the nvidia tool

Code: Select all

nvidia-xconfig
Make sure 'x-setup' isn't on any runlevel

Code: Select all

rc-status --all

Code: Select all

rc-update del x-setup boot
Check if your DISPLAYMANAGER variable is set accordingly to what you use in

Code: Select all

/etc/conf.d/xdm
either reboot or restart x

Code: Select all

/etc/init.d/xdm restart
For further options try: http://forum.sabayon.org/viewtopic.php? ... 63#p138736

kitsios
Baby Hen
Posts: 11
Joined: Sun Mar 13, 2011 16:04

Re: NVIDIA Driver problem

Post by kitsios » Tue Aug 09, 2011 20:46

I solved it by doing:
equo update --force
equo upgrade
I also had to manually add xdm into the default runlevel.

popsUlfr
Young Hen
Posts: 34
Joined: Sun Aug 07, 2011 16:41

Re: NVIDIA Driver problem

Post by popsUlfr » Tue Aug 09, 2011 20:54

kitsios wrote:I also had to manually add xdm into the default runlevel.
Are you sure it wasn't already in your boot runlevel? You shouldn't have it in both runlevels.

kitsios
Baby Hen
Posts: 11
Joined: Sun Mar 13, 2011 16:04

Re: NVIDIA Driver problem [Solved]

Post by kitsios » Wed Aug 10, 2011 18:22

If I remember it was either in boot, or nowhere. If I run into problems I'll try putting it in boot.

Post Reply