KDE 4.7 Network gone and USB problems [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

KDE 4.7 Network gone and USB problems [Solved]

Postby dunsurfin » Sat Aug 06, 2011 16:23

Dell studio 17 running SL 6 x86 K fully updated and with kernel 3.
Halfway through the installation of today's big KDE upgrade the wireless stopped working. The wifi light on the laptop stayed on but there was a report of the wlan interface being broken - either because something wasn't installed or something wasn't removed (it was no more specific than that). The upgrade continued without any problem but a reboot shows the same problem. I haven't got that machine running at the moment so have no logs yet. Anyone else have this problem?

Edit:
Some more information. When logging in I get this error message:
"Warning: Cannot open consolekit session: unable to open session: process /usr/libexec/dbus-daemon-launch-helper signal 6"
This, I think, causes an additional problem; I can't mount a thumb drive and can't mount my "C" drive so am not having much success in getting the logs transferred to this machine.
Last edited by dunsurfin on Sun Aug 07, 2011 20:36, edited 2 times in total.
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: KDE 4.7 wlan problem

Postby James_AC » Sun Aug 07, 2011 1:19

Same here Network Manager doesn't work

Can't enable networking either through the manager.
I can however enable wifi over wireless, so it seems to be related to the network manager itself.
James_AC
Baby Hen
 
Posts: 5
Joined: Wed Jul 27, 2011 22:27

Re: KDE 4.7 Network gone and USB problems

Postby dunsurfin » Sun Aug 07, 2011 15:40

Not sure now if this should be in this shed or some other one as I've found it's it's not a KDE problem - the same problems exist whatever I try to boot into and gnome just goes into a login loop. I managed to get the logs with a trusty livedisc but even plugging the machine directly to my router gives nothing. A message comes up "No network interface". A look at the entropy log shows no errors or warnings. I also have kdm.log, lspci, lsusb, dmesg and .xsession-errors. I shall not post them all unless someone asks for them. The lsusb doesn't agree with what I know to be on the machine.
I hope there's something I can do as, with no connection, it will mean a reinstall and that would be a shame. Sadly, I don't know where to start. :(
My SL 6 amd64 K updated with no problem. I'm not going to risk my main machine (x86) until I know what the problem is.
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: KDE 4.7 Network gone and USB problems

Postby joost » Sun Aug 07, 2011 16:41

dbus-glib has been broken on x86 in the sabayonlinux.org repository. (not on sabayon-weekly)

You could try this:

Download the package here http://packages.sabayon.org/show/dbus-g ... -show-what

Put it on USB copy it to the other PC and then:
Code: Select all
equo install dev-libs-dbus-glib-0.94-r1~0.tbz2


Or try to alternatively enable the wired network:
Code: Select all
/etc/init.d/NetworkManager stop
/etc/init.d/net.eth0 start


Then run equo update && equo upgrade
joost
Sagely Hen
 
Posts: 2605
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: KDE 4.7 Network gone and USB problems

Postby dunsurfin » Sun Aug 07, 2011 17:03

Thanks joost. I've downloaded and will give that a go later this evening.
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: KDE 4.7 Network gone and USB problems

Postby dunsurfin » Sun Aug 07, 2011 20:36

The easiest way didn't work but the copy and local install worked perfectly. Thank you, I've learned something else! :)
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest