compiz problem [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Sagely Hen
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: compiz problem [Solved]

Post by dunsurfin » Fri Aug 05, 2011 21:50

Another thank you micia. I updated my laptop (Dell Studio 17 with Intel graphics running SLx86 6 K, fully updated, kernel 3) today and found the same problem as well as some curious black areas before menus appeared. Your fix has worked for me using the pic flag and emerging the latest mesa. It cured the black areas too. :) Thanks also for the information about ignore-spm-downgrades which I didn't know about and have now enabled.
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!

Sagely Hen
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: compiz problem [Solved]

Post by micia » Sat Aug 06, 2011 11:13

I think that the one to thank should be DanAlucard that had the patience to solve this issue :mrgreen:

However today I found mesa-7.11 on entropy, maybe this version will solve the issue on entropy based systems too.

Code: Select all

equo search mesa
>>  @@ Searching...
>>      @@ Package: media-libs/mesa-7.11 branch: 5, []
>>         Available:     version: 7.11 ~ tag: NoTag ~ revision: 0
>>         Installed:     version: 7.11 ~ tag: NoTag ~ revision: 0
>>         Slot:          0
>>         Homepage:
>>         Description:   OpenGL-like graphic library for
>>                        Linux
>>         License:       LGPL-2 kilgard

Simple Hen
Posts: 50
Joined: Mon Apr 06, 2009 2:22

Re: compiz problem [Solved]

Post by DanAlucard » Sun Aug 07, 2011 18:19

@ micia: sorry for the late reply, but as we've solved this, i forgot to keep track of the post :mrgreen:

answering your question about the pic flag, I haven't enabled/disabled any USE flag. Just installed mesa from portage with "emerge -1av mesa", and it worked.
I've thought trying to install it with default config first, and then try other flag enabling/disabling if default don't work... but that wasn't necessary :wink:

I'm glad to see that this is useful for someone else :D

I'm performing now a global update. After that i will install the entropy version of mesa and see if the problem persists. If it doesn't, then i will edit the main message to show everyone with this problem that upgrading mesa from entropy is the solution. But only if that works :lol:

EDIT: it seems that mesa 7.11 from entropy works just nicely. no need to use portage now.

Thanks a lot for your help on this micia :wink:
Sabayon Linux Fully updated ;)
CPU: AMD FX 4100 @4515MHz
RAM: 8GB Corsair Vengeance LP DDR3-1600
Video: Ati Radeon HD7770 - 1095MHz core 1GB GDDR5 @1250MHz

Lenovo ideapad S205 - 11.6" HD screen - AMD E450 APU - Ati HD 6320 - 4GB DDR3 RAM

Post Reply